Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by DJ Sures!

Wifi Keeps Disconnecting For Six

In my robotics class, a pair of students have a basic Six robot that they are trying to program to do a 5-minute dance routine. They are using the standard, canned, Six movements for their routine and have added a 5-minute mp3 to choreograph to. It's basic stuff, but their Six consistently loses WiFi communication, thus interrupting the dance routine.

WiFi loss does not occur at the same place. It happens pretty randomly. It happens when connected to different computers. It happens when Six is fully charged. It happens after the computer has been rebooted. We could not trace the problem down to anything specific.

Has anyone else experienced this problem?

#3  
make sure your battery is fully charged before starting a 5 minute routine. Because of the large number of servos a Six will only run about 10 minutes of constant motion on a full charge. I have sometimes seen the WiFi connection start to have problems (dropping the connection, not rebooting) a bit before the "my battery is low" indicator triggers, particularly if I am doing a lot of motion. I suspect it is low enough that it is starting to brownout, but since it stops moving as soon as the Wifi drops, it recovers before rebooting.

Alan
#4  
Thanks for the prompt responses...much appreciated.

Answers to questions:

1) It is not the reboot sound when it disconnects.
2) We have not tried different WiFi channels. Will give it a shot tomorrow.
3) Not using the latest ARC version. Seems like the versions come out so frequently that there is no time to get them updated during class. I will get updated tonight.
4) No problem sharing if the other suggestions do not solve the problem.

I downloaded WiFiInfo and will see what's going on with the channels here.

I do tell the students to fully charge their EZ-Robots frequently. I'll remind them again tomorrow. Also, maybe I'll cut back the dance routine to 3 minutes to save on juice.

Thanks again for your responses.
PRO
Synthiam
#5  
I will need clarification on these questions...

1) When the connection to the robot drops, does it reboot or disconnect? The difference is in the sound that is made. A reboot will play the startup sound. A disconnect will play a disconnect sound. I need to know if it reboots or disconnects. Which sound does it play? If it does not play a sound, respond with "does not play a sound on disconnect" or something similar.

Regarding the battery - that would not be an issue. Alan's experience is coincidental, as the wifi requires 3.3v and the battery cutoff is 7v.

In our tests a Six in "Forward Fast" action will run for 18 minutes non-stop before the battery saver kicks in. That is non-stop, meaning never stopping or changing actions. This means simply selecting "forward fast" and letting it run until battery saver kicks in without touching it or stopping it.
#6  
DJ, he answered your question:

Quote:

1) It is not the reboot sound when it disconnects.


I don't think it is coincidental. I have the same issue with both Six and Roli. Either one will sometimes, and only when under heavy movement load, lose WiFi connection when the battery is approaching but not at the low point. Again, I suspect it is starting to brownout and would reboot, but because the WiFi disconnects and the movement stops, it self recovers, but when I reconnect, I invariably and almost immediately start getting the low battery warning.

You should know me well enough by now to know that I don't post about my experiences without having tested and validated what I am seeing a number of times.

That being said, if you are getting 18 minutes from your Sixes, I may try swapping the battery that came in mine with the spare I recently ordered. I never get more than 10 minutes of moderate movement. Walk around a little, do one dance and it is done. (this is the same Six that came from Brookstone with a bad camera and no fuse, and a poorly calibrated servo. If it wasn't packed so well, I would think it had been a reshipped return).

Alan
PRO
Synthiam
#7  
Oh bummer that brookstone would have sold a refurb as a brand new item. grrrr

I'm sure we'll get him up and running. I have a feeling that it is software related anyhow. I understand that it is hard to keep up to date with all of the versions. However, if there is an issue severe enough to post about, it's probably best to do an update first - although we rarely think of it:D I can't tell you how many computers we have at the office with outdated ARC versions for that exact reason!

I'd also like to see the project - because that helps us identify software updates as well, if that's what is causing the disconnect.

I still need to know if it is a disconnect, restart, or no sound.
PRO
Synthiam
#9  
@proeusy - please do not hijack this unrelated thread. Sounds like your router is unstable. Create a new thread for your issue.
#10  
spongebob.EZB

I uploaded the project the students are using. They told me that when Six disconnects from the WiFi, it repeatedly performs its last commanded movement (unknown how many times) and then makes the disconnect tone (not the reboot sequence). They said it always waits to get through the movement before disconnecting and making the tone. Also they said that if they do not run with the music playing, it does not disconnect.
PRO
Synthiam
#11  
Thanks aBrown - i will run each of the music files in the project when i get to the office. There are 4 mp3 dance routines in this project, so i'll try each one and see what's up.

Did you update the software and it still performed the same scenario?
PRO
Synthiam
#12  
I noticed the project has an RGB Animator added - does this mean your Six has an RGB display attached to it?

I connected an RGB Display to my six and ran all mp3 dance routines to the end without issues. Here are possible reasons for your disconnect

1) Ensure the latest version of ARC is installed

2) If there is no RGB Display on the six, this will cause a lockup

3) If there is an RGB Display on the six, ensure the plugs are secure. Attempt to reset the plug connections. The plug inside of the RGB Display may have been accidentally "tugged/pulled" and is loose. You can use a screw driver to remove the back of the rgb display and reset the plug if it has been accidentally loosened or pulled out. If the rgb animator is not making a connection, this will lock up or disconnect the robot

4) There may be a screen saver or power saver mode enabled on the PC set for 3 minutes. This could be why the disconnect is happening for that PC?

Those are the suggestions i have - because i cannot reproduce the issue, it leaves me to believe it's with the PC being used. That being said, the things to look for if the above suggestions do not help, is virus scanners, power saving modes, other running software, wifi saturation, etc..
#13  
1) The students are running the latest version of ARC as of last Wednesday.

2) They are using an RGB Display on Six, but I do not know if they have it connected to EZ-B during their dance routine. I will check with them on Tuesday when they return to school.

3) I will check this on Tuesday.

4) The PC power saver mode does not occur during the dance routine.

My best guess is that the RGB Display is not connected. If this is the case, then should the RGB Animator control be removed from the project?
PRO
Synthiam
#14  
If the rgb is not connected, the ezb will lock up because the rgb animator is setup and it is configured to be used in the dance routines.

Either connect the rgb or remove the animator AND references to it within the dance routine.

To be clear - attempting to connect to something that doesn't exist will result in, well, this.

For example, if you do not have a computer connected to the Internet, you cannot view websites. Just the same if you do not have a device connected to the robot. Another example is if you do not have a bulb in the light socket, the switch will do nothing.

Hope this makes sense - that you cannot communicate with something that doesn't exist :). If the rgb animator doesn't exist, it can't be communicated with.
#15  
Totally makes sense. Thanks DJ, I will have them try it out on Tuesday.
PRO
Synthiam
#16  
Excellent - i'll be on the forum as usual in case you run into other issues.
#17  
I checked with the students today and they did have their RGB display disconnected. I had them remove the RGB Animator control and re-run their dance routine. They again disconnected during the routine. I then had them connect the RGB display to see if anything different happens. Six disconnected again. They did save the error message they received. Here it is:

end of inner exception stack trace

at System.Net.Sockets.NetworkStream.Read(Bytw[] buffer, Int32 offset, Int32 size)
at EZ_B.EZB.YLCck4ZTnN(Int32 ,Byte[] cmdDATA)
BbytesToExpect: 2
| |
Received: 0 0
Disconnected
==================
PRO
Synthiam
#18  
The only thing I can consider is the PC being used is disconnecting from the robots wifi, as demonstrated in that error message.

This has never happened before - I'm at a loss of what could be causing the disconnect.

When the disconnect occurs, does the red light on the ezb stay lit?
#19  
I will have to check on this with the students tomorrow. I will also have them run their dance routine on another PC.
#20  
Sorry I haven't gotten back to this thread. Since 3 weeks ago, other events have come to light. Because of their frustration with their JD, the students decided to switch to a Roli. They have since been working with it. Also, the students were preparing for and taking their midterm exams, so they haven't been able to do anything with their Roli for the past weeks. And finally, when they were able to get back to their Roli yesterday, they discovered that their wifi adapter had been disabled. As a matter of fact, all of the wifi adapters in my classroom were disabled...mysteriously. Because of the IT Dept. control over the computers and the network, re-enabling the adapters was unsuccessful on my part. Apparently, they have this network set up in a way that enabling the wifi adapters requires a network admin level privilege. I will have to wait until IT comes in to resolve the problem.

As an aside, the IT Dept. installed older Dell Wireless 1505 adapters into our computers. It is comprised of an internal card and an external plug-in cable attached to what looks like a "box" of an antenna. Weird looking. This may be the root of the whole problem, but unfortunately I have no other types of wifi cards to compare results with.
PRO
Synthiam
#21  
That does sound like a challenging situation. Thanks for the update!
#22  
I tried closing this one yesterday, but did not leave a message. Thus it was not closed. Since there are so many variables that could be the root of the problem here (in particular, the Dell wifi cards), I will close this one for now.