Asked — Edited

Wifi Help

can anyone help me get ez hooked up to wifi? i got Uart-Wif but can not get it to work. I can't put a computer on robot to much weight.

is there another wifi that will work with ez? mad

Skip to comments


Upgrade to ARC Pro

ARC Pro will give you immediate updates and new features needed to unleash your robot's potential!


If you are talking about the TLG wifi DJ recommends then try following the guide (Link)

Make sure you download the divers (Link)

Do pay attention when running the software for setting up the device also remember the baud should be set to an EZ-B accessable rate, 9600

File Wifi Software

If the software can not recognize the wifi card it may be set to auto mode to release it follow the last steps in the guide using the +++ "AT" command to remove it from the state, using a serial terminal.

EDIT: credit to robotmaker Virtual Serial Port (Link)


i will check the last step


I recommend using arduino software for the terminal when I did it, hyperterminal and a custom c# applicaion did not work for some reason. There maybe more compatible serial terminals but I was going to use an atmega processor so arduino terminal was already going to be useful.


I just tried the AT command no good,did not work. I will try arduino but i don't have arduino wifi shield, do i need one? or can i just connect rx pin 0 tx pin1


first off you are programming the wifi card, so no need for an arduino sheild, using the usb ttl module that came with the wifi card rx-tx and tx-rx gnd-gnd and make sure your using the 3.3V jumper on the ttl module. the only thing the arduino serial terminal is used for is sending the command through the ttl module to the wifi card.


i wounder if i have a bad usb ttl module, i got it to program the wifi card one time (could not get it to work with ez)but now when i hook up the usb ttl module it can't find and the lights go dim after a minute. I read some that it might be in auto mode that is why i could not get it to work with ez. was going to try and use arduino uno to program wifi board don't know if it will work


I had problems with the wifi after getting it programmed the ez-b did not have enough current to source the wifi card, must use the 3.3V line and requires 300mA the ez-b could source around 220mA with my 7.4V LiPo. If your going to try and reprogram the wifi card via the UNO you will have to use the AT commands for setting up the cards registers.


on the ez program when you went to connect did you put the ip address in


if you are done programming the wifi module and have a sucessful supply to the wifi unit and the ez-b the ip address will be useful when you use a virtual serial driver for the wifi which will allow for you to connect via ARC through the com port to the wifi. However this is the furthest I could explain it to you. I do not have the virtual serial software to help you here.


thanks i think Dj needs to make a video on this that will solve all the problems


He has said about it, when he finds time I am sure he will get to it. Have you got the wifi to work?


working on it now,got virtual com port installed but no luck.Cant grt it out of auto tried using arduino


I am sure following the instructions should do it. Simply connect the wifi to the ttl usb then open arduino next set the serial port to the specified com that the ttl is on. open the serial monitor type in +++ and hit send. You should receive +ok as a response, this should remove it from auto mode. From there you can use the wifi software to programm the wifi card.


i tried and when i hit send no ok,i think my ttl usb is bad going to order another one. this is holding me back,need to get wifi working because it is going to use home wifi and 4g/3g for outside roaming


Ok, I can join it to the network, ping it, and access the internal web setup pages. It does not however, automatically join the wifi network. Is this what auto-work mode is for? Also looking for info on setting up the virtual com port. Physical connection to the EZ-B will be trivial, so this is the last piece of the puzzle, and then I'll document it all and post it.


can't wait,glad to see someone still trying


I'm wondering if this will work for the virtual com port: VSPE?

I'll give it a try tomorrow.


I'm also wondering if I shouldn't get a second TLG10UA03 (for the host computer) and run in transparent mode, on an adhoc network, and then bridge maybe? Just throwing out ideas here. Documentation on this thing is rather lacking.

Anyone know where (in English), to get FW updates?


Ok, auto-join solved. Check "Auto Mode Enable" in the www interface, (once they're talking) TCP for a protocol, and SERVER for the mode. You can now disconnect the module from the UART module and power it separately and access it via it's IP. Works a treat.

So I just need a virtual serial port to interface with ARC now and it should all work. I suspect the module's transparency mode options may be the key.

And I can see the UART-USB module being a very useful tool for other projects beyond robotics.


I'm thinking that this, although pricey, will work for the virtual comport: WiSnap


Same. But I need a virtual serial port. I think this will do the trick for the host computer end of things.


Question guys

Inside certain Linksys Routers they have serial ports. You can view one in the pic below. I built a project using one and connected it to a Arduino to control a RC car. Would it be possible to connect one of these to a EZ board?

Maybe this will help, maybe not, just thought I'd throw it out there.


User-inserted image


That would probably work fine, but I think the WiSnap would be smaller and require less power. I think I'm gonna get one and try it. I still have lots of serial devices like TNC's, so it's not like I couldn't find other uses for it. :D


i wounder i DJ has WiFi working


The WiSnap got me to thinking (unusual I know), so I've bought a second TLG starter kit. I plan to configure both on an adhoc network, and then use one (without the USB serial adapter) on the EZB, and the second one (with the USB serial adapter) as the com port on the host computer. I think this may just work.

I should be able to easily test the setup by using both modules (with the USB serial adapters connected) and running 2 terminal programs. Properly connected, typing in one term should result in identical output in the other.

After that, start ARC, run my sketch, and I should be able to see the serial commands it's sending in the other terminal window when I manipulate the controls.

Anybody see a reason my cunning plan won't work?


My second TLG starter kit arrived today. Once I can get the damned antenna connected I'll get them both configured to create an adhoc network named botnet, assign IP's in the same subnet, and set baud rate to 9600 8N1. Connect them both to USB ports, run 2 terminal programs, and I'm hoping that typing in one terminal will result in proper output in the other and vice-versa.


good luck i hope it workes


Its very easy use and free,and not a trial version


So... has someone succesfully connected his EZB through wifi ?


DJ, You should do something about that, seriously. This module just can't get redirected to allow ARC to control the EZB through Wi-fi. I bought it following your advice on your website... mad

United Kingdom

Are you saying it can't work? As that is incorrect. There are some who have been successful.

Both myself and Alan (thetechguru or something like that, I know him as Alan now sorry) have bought one and plan to provide some kind of tutorials for them. Mine has yet to arrive but if it turns up in the next week or so I will be covering it with full and easy to follow details.

Pitcom has connected but finds it slow. This is most probably due to being set up or installed incorrectly. This is half the reason I purchased mine so that I can hopefully solve his issues along with anyone else's (plus my robot doesn't quite make it around my kitchen without disconnecting).


Yep, I just found out in the community that some guys did connect it... I won't tell you what made me say that... it's too damn stupid... However, while trying different configs I changed the TCP port in the Http interface (in the Auto Mode section) and now I have the wifi board flashing like it is connected but it is not (I checked from the router directly) and can't access it anymore, neither from http nor from USB/COM... Do you know anyway to hard reset it ?


My apologies to DJ... I only got very frustrated now that I lost access to it...


Pfff... I'm too damn idiot... I just needed to exit transparent transmission mode...

United Kingdom

Stop, take a breath, make a coffee, read the manual and give it another go:) That usually helps me out when something frustrates me.


Can you refresh the router page that shows all ports in your network ? Then maybe the WiFi board will be identified when you re-power it.


What manual are you talking about ? All I found right now are tutos Arduino and I took all I can from them. The challenge now it to connect ARC to a virtual port forwarding data to the UART wifi IP address.


I got it to connect with router that has password on it but super slow.I tried new router with nothing on it and no password no luck.Reconfigured wifi back to router with password but would not connect,maby i put wrong password in. Tried to redo but would not let me in so took it out of auto mode with arduino and it said OK,but would not let me in(to reconfig card).

So i tried factory reset through arduino and no luck,have done factory reset with arduino before but would not let me now. confused

so time to give up for a little while and clear my head blush