Asked — Edited
Resolved Resolved by CochranRobotics!

Wifi Connection

i have a wifi connection whit a d-link. when i connect my nao whit wifi,the next day its gone. i ask this cause i will need a good wifi for using ez-b4

any idea's thank you


Upgrade to ARC Pro

Stay on the cutting edge of robotics with ARC Pro, guaranteeing that your robot is always ahead of the game.


sounds like your router is running on a low expiry date schedule. see if you can change it. Also, set nao and the v4 a static ip(an ip that doesn't change).


Ya, your going to have to get a better and newer router before the V4 arrives at your house. I had this same issue when I was setting up the V4 when I got it. Read through this thread of mine:

Connecting To Two V4 Ezb's

By the way, You Belgium's really kicked our USA butts in the World Cup race today.blush I really shouldn't be trying to help you now but it's only soccor. ;)


the router is just 1 year old.

dave maybe we where lucky.thats all.:)

can the flacher be worn out.i got this one for more then 5 years?


I think technopro is probably right on this one. @nomad18.08 are you using dynamic or Static IP addresses? I would use a static IP address instead of a dynamic address if you are keeping your robot in your house, but you need to make sure that it is assigned an IP address that is outside of your dynamic range of addresses.

All of the information will be available through the interface to your router. If the IP that is assigned to your robot is within the range of addresses that are assigned to your DHCP scope or range then it is going to be dynamic. You wont be able to use the normal commands in windows to tell, but there may be something in your NAO that allows you to set the IP to be a static IP address.

The thought is that the DHCP server is dropping your IP due to a very short expiry time. If you have a static IP, the DHCP server wont drop you because that will be the specific IP address that will always be used for that device and the DHCP server wont have anything to do with that address.

Your router could also be set to reboot on a nightly basis. I have my WIFI Access Point set to reboot weekly.


hi.this is a lot for me.the nao works great whit wifi in choreograph. so he's somehow connected whit the wifi. but to be able chown nao web page he dont. your right about wifi dropping out problably acery day. so this is all new to can i set that it will stay .


User-inserted image

is this i have to fill in?


I think what you are looking for is in the router itself. The router should have a web interface to manage it. This can get pretty complicated if you haven't seen it before, and unfortunately I cant read Belgium.

I wish I could help but it is going to be very hard to do so. you might set your router back to the default setting and see if that helps. By default, it shouldn't be issuing really short timeouts on for IP's. Does this happen at the same time every day or at random times throughout the day?


am not chore.but the web page off nao is avery day gone. the router has never changed .for the nao i just need to set ip in browser. it worked for tree times in a row,so its possible that aldebaran done some changes, i dont see now..


Do any other devices on your network go off on a daily basis?

Do you have a tablet, laptop or Cellphone that you could do some tests with? For example, you could connect your cell phone to your wifi. When you notice that the NAO web page goes off line, look at your cell phone and see if it is still connected to Wifi. I think what is happening is that when the device isnt used for a period of time, the DHCP server in the router kills the connection to the device. You would know if it is the router if your cell phone behaves the same way.

If it doesn't, then you could look to see if there are any setting in the NAO. I am dont really know anything about NAO other than the videos I have watched on him. This should give you a direction to start looking.


no none.but you mention dhcp,and i see that on nao web i gess there is some wrong. my cell phone is wifi and dont cutt off. okay this give me some direction.

thank you


DHCP allows the router to give your device a dynamic ip address. You may have a setting in NAO to set it to Static and then you would have to assign the IP Address, Subnet Mask, DNS servers... to the device. This would always stay with the NAO at that point. There are concerns with doing this, but it is a much more stable way to go.

You would have to make sure that the IP address you assing falls within your range of IP addresses for your network. Normally this is something like or

You would then need to make sure that your DHCP server on your router isnt going to assign an IP address to another device that would match the IP that you specified. This is called DHCP Scope and you would want to choose an IP address that falls outside of that scope.

You would want to choose an IP address that falls within the Subnet mask range. If you took the first 3 numbers of the IP address (called octets) and kept those the same, and then changed only the last octet, you would most likely be fine here.

You would have to set the subnet mask. Most home networks use

You would then need to set the DNS server IP address to that of your gateway or router. Normally this would be or

All of this is information that you should know before you start messing with the settings in NAO.

Most of this can be found by going to a command prompt and typing IPCONFIG /ALL

This will give you a list of information about your network. you wont find the DHCP scope though. For that, you will need to access the router. It will be listed as the gateway in the IPCONFIG /ALL command.


PS If you decide to assign a static IP, don't use 255 ( as your last octet in your IP address. This is bad for a network.


yes you are correct. isee numbers that is also on web page nao.i think i now where the problem is. nao has two ip 's ffirst i connect it whit cable an set in the browser his ip.he finds that. i also see his second ip the wifi whits is needed to download from aldebaran itself. there come a pop up page whit the numbers


All D-Link routers have what they call "Static DHCP" or something similar. You can tell the router to always assign the same IP address to the device based on its MAC address, so no need to mess with the device settings itself, typically much easier to do in the router.

Specifics of the feature name and instructions differ by model, so if you need help setting this up, post the model number of your router so I can pull the manual from D-links web site and talk you through it.



Found this also. It might help you out if you haven't already seen it.

NAO connection Documentation

Also, Alan is right. It has been a while since I have seen anything other than a BSD interface for a firewall.


also, should probably be, instead of


nao has his own ip ,he's say it when you puch his chest button. can a flach point from d-link worn out? i will make a video.


a network port can ware out on a router if that is what you are asking. (The place that you plug a cable into a router). Yes, they can go bad.


i think here the problem ,i dont know whats come here.

User-inserted image

you can be wright about the number 192.168 i put in 192.186


Teathering allows your robot to act as a router for other devices.

For example, your cell phone might be able to be teathered to. This would allow your laptop to connect to your phone via wifi, and use your phones cellular network to access the internet.

This shouldnt cause your device to become disconnected necessarily. It would more likely cause your device not to be able to connect at all.

I would see if there are any NAO owners on the internet that would be able to help on this. It sounds like it has multiple wifi radios in it to allow you to connect to a network, and then act as a wifi-hotspot type of a device to route traffic through it.

I just dont know anything about the NAO. I would consult someone who does and has one setup on their network correctly.


d.cochran you found was the ip adres i typ backwarst in. 192.168 is correct and i put in 192.186

thank you

thetechguru you to thank you ,learn some again


this is what you mean .

User-inserted image

whits ip comes here


From that screen, to assign a static IP address in the NAO, you would click on the drop-down that says DHCP. Another option should be "Static", and if you select it, you will have 3 new entry fields:

IP Address:



Since you have a Dlink router, it starts assigning DHCP addresses at, so choose something between 2 and 99, like

Netmask will be

Gateway will be

Then NAO will always connect with the same address.

However, since you also are getting an EZ-B, and EX-B can't (currently) assign a static IP, it is probably better to use the "static DHCP" feature of your D-Link to assign permanent addresses. If you learn it now with the NAO, you'll know how to do it when your EZ-B arrives.