Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by Dunning-Kruger!

Wifi Client Mode - No Go

I am having an issue with Wifi. I am able to connect without issue in AP mode. However, that is not really what I want. I would rather connect via client mode for various reasons. That's where I am having some problems. I enter the SSID and the Security key for my network in the config and hit the connect button and it reboots and actually says "I have successfully connected to your network"

I also am getting a green flashing light on the EZ-B as well. While any normal person would jump for joy at this point, sadly I would not be one of those people because it is lying.

It can not be found on my network. It can not be found using the scanner inside of ARC nor can I see the connection in my router from the EZ-B.

Any ideas?

Very frustrating!

- Paul

AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
#1  
Try rebooting everything... Router, modem, PC, ezb... That worked for me...
#2  
Check your router log. If your router starts handing out addresses at x.x.x.100 rather than x.x.x.2 it is possible the EZ-B refused the address and came up with one on its own. You should be able to see that address in the logs.

(there is a problem with the EZ-B in client mode, where it doesn't turn off its own DHCP server and can cause this and a few other issues, but I have only seen it cause a problem when trying to use 2 or more EZ-Bs. Haven't seen an acknowledgment of the problem from EZ-robots yet, but I also haven't started a thread specifically about it yet, just mentioned it when people were having issues).

Alan
#3  
One thing I noticed with mine in client mode, the default IP address is 192.168.1.1:32, which is fine but my default network devices end with 192.168.0.x, so by default if I click on search for IP address it uses the 1.1 range, unless I change it, that could be your issue. My router is a Dlink and when I log into my router I can see device and addresses connected to it and assigned. My EZbv4 came up as "Unknown"; I knew what my other devices where so I manually found the assigned IP address that way.

I found TechnoPro's tutorial the most helpful: here
#4  
Justin,

good point about the subnet of the search box. It does not change to match the subnet of the computer's network, so it could very well be searching the wrong network. Probably simpler to check and more likely cause than my previous answer (which, like I said, is more likely to cause an issue with multiple EZ-B's).

Alan
#5  
Wahoo after a router reboot it worked like a charm.

Thanks everyone for your assistance.


- Paul
#7  
I just received a Revolution JD robot for Christmas. I have been trying to get it in client mode on my home network.
When I started my home router was on 192.168.5.1 and handed out addresses 100 - 150. JD would not connect. It would fail right away.
I re configured my network to 192.168.1.1 and handed out addresses 100 - 150.
JD would go green and stay for about 2 minutes and then fail unable to connect.
I than changed my router to issue starting at 192.168.1.5 for 100 clients.
I put my Wire shark on line and captured the startup of JD.
JD sends from IP "o.o.o.o" a DHCP request.
It then ARP for 192.168.1.12 Who has this. several times
Then it sends ARP 192.168.1.12 curtesy ARP saying I am using this address.
JD connected and stayed connected. I Then started ARC and attempted to connect to 192.168.1.12. It immediately and said Not correct and offered to scan. I let it scan and it found it. It now works.

If you can't disable the DHCP in JD can you at least limit it's address to 5 thru 10 and let my router handle from 100 to 200 to eliminate conflicts.

That is what I learned since Christmas.
That and don't plug in a servo backwards. It WILL smoke.
*tired*EZtakingcontrolDHCP.zip
#8  
You mentioned that you you just got JD, but you are describing an issue that has been fixed for a very long time. Do you know if the JD was purchased directly from EZR recently, or maybe a reseller where it has been in stock for some time.?

The easiest fix would be to order the EZ-B v4/2 Comm Upgrade

More complex is reflashing the firmware, but it requires a special tool and is a little tricky. See https://synthiam.com/Products/ARC

Alan
#9  
This JD was purchased from amazon.
I will attempt to do the upgrade.
Thanks Alan.
#10  
Is there no warranty on this kind of problem?
I am getting a little disappointed in EZ-Robot.
#11  
The 4/2 upgrade is the superior way to go although more expensive than buying the programmer device.

I just realized I have a simple free solution for you though. I just upgraded my 4 EZ-B's, so I have 4 original EZ-B top halves that have been flashed with the latest build and don't have the issue and I have no need for them.

Send me your address (my email is in my profile) and I'll drop one in the mail for you.

Alan