Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Wi-Fi Help! Urgent!

Hi, I'm trying to build the Wall-E robot using wifi. I am using the UART-Wifi suggested.
Do I need an arduino to make this work with EZ-B?
And I tried downloading the wifi software from elechouse but it gives me a .rar file which tries opening with iTunes. I can't find the .exe file?
This project is due in a week as a CAPSTONE project for my school and I am pretty behind. If anyone can help I would appreciate it!

AI Support Bot
Related Content
Synthiam
United Kingdom
#6  
Don't bother with the virtual port until you need to update the firmware. You don't need a virtual port to connect to the wifi module in ARC.

Connect the Wifi Module to the USB module as the instructions.
Run the set up software for the wifi module
Set it up, details are in the other topic.
If set up correctly with the WiFi SSID, password and port number it should connect to the WiFi network - check your router to see what's attached via WiFi to confirm.
Open your internet browser
In the URL box type the WiFi modules IP then a : and then the port number (i.e. 192.168.0.3:80) - the password if you don't change it is 000000
Make any changes to the set up in the web based set up.
Restart the Wifi module
The red light should flash fast to indicate automatic connection to your wifi

Then, connect it to the EZB. Details are in the topic linked to.

It needs at least 300mA and 3.3v to power it, the EZB may not give it enough current (this is where mine is waiting).
Power up the EZB and the WiFi (if external 3.3v supply)
Red light should start flashing fast when connected to WiFi

In ARC connection don't select a com port but type in the IP of the wifi module then a : then the port set i.e. 192.168.0.3:6666
Hit connect
#7  
@CapriAdams, do you have a Wireless router set up ?
#8  
I am working at the school, off their wireless network.
Thanks @rich but on the Uart-wifi software I have not been able to select a port and set it because it won't find a device when I hit search. I have tried COM6 and AUTO with different baud rates and nothing is found.
And the software won't let me modify the other settings.
United Kingdom
#9  
What port was added when you installed the USB module on the PC? That is the port you need to choose. Don't use auto, all it did for me on auto was cause the program to hang.

Select the correct COM port (only you will know this) and search. When it finds one it'll probably give an error about reading the data, ignore that. Then set up the details, modify, reboot the module and it should auto connect.
#10  
I plugged it into a different USB port and it told me COM7.
So I chose that on the configuration and still nothing. I get a message when I click search that says:
Cannot find the device. The possible reasons are as follows: Com is invalid, device is not connected.

The red D2 light is on, yellow D1 is on, and Green D3 light is on on the USB board.
United Kingdom
#11  
Have you wired it up correctly?
Try swapping Rx and Tx over on one of the 2 boards

What are the lights on the WiFi module doing?
#12  
Yes, I have RX-TX and vice versa on the wifi module. On the wifi module itself no lights. but on the USB one those three lights are on. Do I need to have power plugged into the 3.3V, ground, and 5V on the USB board?
United Kingdom
#13  
You need to have the jumper set to either 3.3 or 5v. the jumper connect either the 3.3 or 5v pin to the centre pin.

Put it on 3.3
#15  
When the unit is shipped, the 5v or 3.3v jumper is connected to the TxRx pins and must be removed and reconnected to the 3.3v side of the power option pins. All 4 leads between the WiFi board and the USB/ttl board should run straight with no turnovers.


User-inserted image
#16  
Oh okay thank you! Sorry, I just assumed it wasn't necessary since it was plugged into my laptop
I do not have the jumper wires, I'll try to go by radio shack in the morning and let you know. If radioshack doesnt have them I'll rig something up with what I have.
#17  
Ok, so I applied the 3.3V from the EZ-B. I even checked with a multimeter. And still no lights on the wifi module. Is the wifi module really sensitive to touch?
United Kingdom
#18  
Assuming you managed to connect to PC then. How have you connected it to the EZ-B? Read the other topic linked to, it covers the problem with connecting it to the EZB.
#19  
All power and Rx, TX connections should be between the USB module and the WiFi board. Don't use the EZ-B yet.
#20  
No, I have not gotten it to connect to my PC. And I only used the EZ-B for the 3.3V power supply. See the Pic. The EZ-B did have power to it when I did this just not in the pic.
User-inserted image
#21  
The 3.3vdc power should be coming from the USB PCB not the EZ-B. The EZ-B board is not used at all during the initial setup of the WiFi board.
#22  
Well originally I was trying to do it with just the two wifi boards connected as they are with the EZ-B and nothing connected to the 3.3V?
United Kingdom
#23  
Set up the USB part like this

User-inserted image


Connect the USB and the WiFi together like this

User-inserted image


Connect the USB to the PC
Open up the configuration program
Select the COM port
Click search
User-inserted image
United Kingdom
#24  
Select the wifi module from the list.
Change the settings to your settings (don't copy mine from below)
Set Auto Workmode to on
Details as my picture below (you can change your port if you wish)
Click Modify
It'll ask if you want to restart now or later, choose restart now

User-inserted image


Open your web browser and type in the URL box the IP address of the WiFi module (if set static like I did you should know it, otherwise check your router's attached devices or use a network scanner to find it)

Log in, username is admin and password is 000000

User-inserted image


Make any further changes here, if needed (it's easier than in the wifi program)

Save if changes are made.

Only now are you ready to connect the WiFi module to the EZ-B
#25  
Okay thank you for the responses! I'm sorry for the confusion. I will let you know when I try again how it goes.