Welcome to Synthiam!

The easiest way to program the most powerful robots. Use technologies by leading industry experts. ARC is a free-to-use robot programming software that makes servo automation, computer vision, autonomous navigation, and artificial intelligence easy.

Get Started
France
Asked — Edited
Resolved Resolved by Rich!

Voice Recognition Question

Hello everyone,

It's been a while since I tried my wall-e project. I have now a new windows system (windows 8.1) and the last version of ez-builder. It appears that voice recognition don't work anymore:
When I launch the project, i have this error message : "Voice recogition was not able to start. There is either no listening device or the your operating system is not supported". I made a new fresh project and had the same message when i tried to add speech recognition (see screenshot).
User-inserted image

Microphone is setup and windows voice recognition is configured (and works ok: i can control windows by voice commands).
I tried to put the system language in US (even if it has never been a problem before), with no success.
So now i am out of options and any help is welcome.


ARC Pro

Upgrade to ARC Pro

Synthiam ARC Pro is a cool new tool that will help unleash your creativity with programming robots in just seconds!

United Kingdom
#1  
You need to set the language in Windows Speech Recognition to US for it to work. When you say you had no success with that, how come? What happened? What stopped you?
#3  
@Rich, I have try to put all the language settings of windows to US but still have the same error message.
However, in the voice recognition language setting, i have only UK and French language available... Is there a way to download the US language?
The strange thing is that I have always used the French settings before, when i was under Windows seven... so i don't know why i have now this error message *confused*
#4  
Ok, I have successfully download the US language pack and if I put every language settings to US, including voice recognition, it works now in ARC. So it seems that my problem is solved... Thanks to Rich.

Still, one question remains: why were I able to use voice recognition in french before ? Maybe I should try to reinstall windows 7 and see what happens....
United Kingdom
#5  
My PC is set to UK for everything as I need it for other applications. That said, ARC doesn't error when I try to add SR, but I haven't yet been successful in getting a voice command to work - this may be due to my current mic set up or may be something else, I just thought I would mention it.

Glad it's solved. I can only imagine something in the ARC code has changed. Which version were you running where french worked?