Welcome to Synthiam!

Program robots using technologies created from industry experts. EZ-Builder is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.
Get Started

Asked — Edited

Usb To Serial Connection Camera Option

With the option to use the EZB in serial to USB you lose the option for the camera since the connections use the camera port. Is it possible to add another EZB like the IO Tiny to connect the camera too, then hard wire both EZBs together? I can't use Wi-Fi on either EZB.

There is a very specific reason I want to use the EZB camera and not a usb webcam, but i still need the EZB wired to the computer.


Edit: Please visit post #37 for the update on the usb/serial cable I used, new wiring diagram and notes

#44  
Ok still working through this issue. I built another one of these and have the same issue. I’ve tried twisting pairs I’ve tried ferrite rings and even aluminum foil! Lol.

I finally tried going back to the old ez double board cameras and I get less full frame glitches. But still glitchy.

Finally I noticed the pop up from below as I had not checked always show and here are constant error messages I am getting.


User-inserted image
#45  
This could be latency and or interference issue with the UART because I had similar issue with a questionable UART with my Omron camera (I do realize it is not 100% the same, but the challenges are similar), but mine actually blacked out the image every couple of seconds. My problems went away with a new UART because my was cheap to begin with.

I believe yours is a little higher end so I assume it's probably good. You followed DJ's suggestions which were good ones to rule out the most common hardware interference.

Aiming for less common now, I'd probably want to check the solder joints of the UART cable to the camera and maybe try a different cable or different wires to rule out a bad wire/connections.

Software side what helped my Omron UART latency also was a tip (Omron) had for going into the Windows Device Manager for the virtual COM port of the UART and then Advanced settings and then under Latency Timer, setting the value to less than 16 because it might improve performance. But adjusting it lower is an incremental playing game, because going too low can disrupt other things. Think of it like tuning in an old radio station, starting at 16, then 15, then 14, etc to see if the interference goes away.
Synthiam
#46  
Oh I never thought of that. The usb to uart adapter might be dropping packets. That’s a smart observation, and the most probable cause.
#47  
Geesh I’m away for a day and came back to all these great forum reply’s and interesting posts. I will give that a try in the morning. Thanks!
#48  
...i'll add since this came up in the feed..my issue was with my USB ports on both my laptops. I purchased a new computer and the issue went away completely for both my robots. Both those laptops were old.