Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Singapore
Asked — Edited
Resolved Resolved by Nomad 6R!

Unable To Connect Multiple Ezbs

Hi guys,

I have asked this before but I am unable to connect multiple EZBs with one wifi connection. I have used the Wi-Fi client mode to connect the Six and Roli to my JD.
However, after I connected the JD to the network, I am able to find the Six but not the Roli in the radar. Hence, I am unable to connect all three robots through one network. I have resetted the connection, restart the robots and even configured it again and again but nothing seem to change. This problem never happened before so I am a little confused. Please help. Thanks in advance!

Best Regards,
Me

PRO
Belgium
#1  
mankental

i try this to ,same problem the one disconnect the other.
what i did and works for me is use connection 0
other robot excample connection 2
other robot connection 4
leave one connetion between open
United Kingdom
#2  
You say you "resetted the connection", but I'm not clear on what exactly you reset. Two things to try if you haven't done so already...

Reset the EZ-B's network connection by pressing the reset button on the EZ-B that won't connect (I think this is what you meant by "resetted").

Reset your router and try connecting all three EZ-B's in client mode again.

If you still have problems after trying the above, report back here.
#3  
See this bug report. http://www.ez-robot.com/Community/Forum/Thread?threadId=7229

It is a little deep in technical details, but post #9 offers a workaround.

Another workaround if you have a spare 802.11 G or N router is to plug the spare router into one of the ethernet connections of your primary (2nd router's wan port to one of the LAN ports of the primary), and configure it as a different SSID and different subnet in its DHCP settings (ie, if your primary is 192.168.1.1, set the second to 192.168.0.1). Only connect the EZ-Bs to that router and connect the computers to the original. Most routers should be able to pass traffic back and forth between the subnets, but devices on the second router may have issues with some internet services due to "double natting". This is the solution I am using until a fix for the issue is available.

Alan
Singapore
#4  
Thanks for the input guys! Tried some of your suggestions and I have a much stable connection now.
Thanks again!