Welcome to Synthiam!

The easiest way to program the most powerful robots. Use technologies by leading industry experts. ARC is a free-to-use robot programming software that makes servo automation, computer vision, autonomous navigation, and artificial intelligence easy.

Get Started
Australia
Asked

USB Camera Disabled

Since the MS LifeCam is not listed in the Product list, I had to chose the ESP32 Cam in order to submit the question.

Problem: Can not connect the MS LifeCam again.
Steps to reproduce:
1. Plug in the Cam
2. Open the ARC
3. Project->Add->Camera Device
User-inserted image

4. Start
User-inserted image

After playing around with the ARC Camera Features, closed the Camera Device without saving the Camera control to a project:
User-inserted image

5. Closed the ARC, switched off the PC.
6. Later on tried same as from the Step 1 and got the message:

User-inserted image


7. Closed Camera Device and ARC, removed the MS camera.
8.  Plugged in the camera again. Opened the ARC and started as from Step 1 and again same message: "Camera Disabled".
9. Switched off the PC. Switched on and tried again without success (same message).

What I have done wrong to stop camera working?

Note: Did not use any Windows app related to the camera before I run the ARC.
Later checked the camera with the Yawcam and VLC applications and camera worked fine.
The camera is brand new, just opened from the box.


Related Hardware ESP32 Cam

ARC Pro

Upgrade to ARC Pro

Synthiam ARC Pro is a cool new tool that will help unleash your creativity with programming robots in just seconds!

AI Support Bot
Related Content
Synthiam
PRO
Belgium
#16  
hi

i read ones that front usb are diff then  as the back usb ports .
maybe you can try one usb from the back op the pc ?
i would remove all info in the device manager from that camera on your pc ,reboot, install back .
also pull the usb cable out the pc from the camera before reboot pc and remove all info in device manager .
PRO
Synthiam
#17   — Edited
But you say it works with other software, just not arc? It was working with ARC and then stopped and hasn’t worked since? ARC uses the same drivers as any other webcam software so I’m confused of why it wouldn’t work. 

id like to figure it out but I’m not sure where to begin to debug. I’ll have to think about this one.
PRO
Synthiam
#18  
Is this the camera? We use these for our inmoov and a bunch of other stuff with no problems - that adds to the confusion as well of why it doesn’t work for you hmmmm

User-inserted image
PRO
Australia
#19  
Yes, it is that camera.
I am confused why it stopped.
I did not run any other Windows app except VLC and Yawcam afterwards.
Tried many things: disconnect/reconnect the camera, close/open the ARC, switch off/on the PC...
I suspect that something is in the Windows setup, or because I did not save project when my camera worked.
Could it be that some Windows services run at startup lock the camera access which prevent ARC to access it but not VLC and Yawcam.

As I said, it is not important for my project, but I am a bit worried it would happen with the Humanoid Head camera when I start using it. I will try it next week for the first time.
So, D(R)J do not spend much time to resolve it for me.
I wish one day to see the following book in the bookshops:

User-inserted image
PRO
Belgium
#20  
hi

maybe the camera is just broken .
PRO
Australia
#21  
The camera works with other apps.
PRO
Synthiam
#22  
Haha I love the book idea! Might have to do that one day. 

I ordered one of those cameras to see if we can replicate it. Should get it sometime this week. Stay tuned:)
PRO
Australia
#23  
I have one with ROS instead of ARC in the title.
Very practical book, but the ROS is more complex than the ARC.:D
That is why a book about ARC is really desirable.
PRO
Synthiam
#24  
Hey Gale, my Microsoft cam arrived and I tested it with arc. Unfortunately, it works consistently and I can’t get it to crash. Even at low and high resolutions there are no problems. I’m not certain why it’s behaving strangely on your computer. 

Are there any programs that could be using the camera in the background? Maybe even a virus?
PRO
Australia
#25  
Hi Sures,

Thank you for the reply.
As I suspected, the problem is in the Windows 10.
I've checked briefly all apps running in the background, but could not find any that use the camera. I need time to check the Win services. I'll do it sometimes later.
I do not have much apps installed in my Windows 10. It is dedicated to the robotics with ARC, OpenVINO, MS Visual C++, Python and Java. Plus antivirus app and some Win tools for maintenance. Do not surf the Internet for anything but robotics.
The ARC works well with EZ-R humanoid head camera and I am spending most of time on it.
Regards
#26   — Edited
This issue has been gone over by better brains then I. However I have a couple "Shots in the Dark" if your are still up for it. I think it may help to try these in order: 

*Try turning off your antivirus protection. See if that helps. Keep it disconnected when testing ARC for now. I know, dont worry. Just don't visit any unknown web sites while you have it turned off. ;) If you find this to be the issue try using Windows Defender for your antivirus needs. It's free, fast and stays updated. I switched a couple years ago due to DJ's suggestions and have never looked back. 
*Make sure your project is saved and in a safe folder, then uninstall and reinstall ARC.
*Reboot your computer.
*With a new and empty project after the reinstall and reboot, try installing just the camera control in the empty project and try to connect to your camera.
*Try different USB port on your computer.
*If you are brave enough you can go into Device manager and uninstall and then reinstall the driver for the camera. With the camera plugged in you may be able to find it under the Universal Serial Bus Controllers. Here's a tutorial that seems knowledgeable on how to easily do this: 
https://www.addictivetips.com/windows-tips/uninstall-a-usb-device-windows-10/
*Start at step one again and try everything one more time. Ugh.:(
*Try using ARC and this camera on another computer. 

Let us know if you try any of this and it helps. Have fun and happy building!
PRO
Canada
#27  
try and plug camera into another computer and install ARC
PRO
Australia
#28  
Thanks guys for the suggestions.
I already tried with antivirus disabled, did not work.
I installed Windows 10 on new HDD.
Did not update it. Installed .NET and ARC.
The USB camera worked fine.:D
Updated the Windows.
The camera still working fine.:D
Some other app installed on previous Windows is the "culprit".
Will find it.
PRO
Synthiam
#29  
Phew - that’s good to know. Thanks for the deep dive to resolve the issue, Gale. We were a little panicked on this end wondering what could be the culprit. I was slightly concerned ARC was doing something wrong but none of our tests could replicate the issue. 

We are relieved over here:)
#30   — Edited
I vaguely remember years ago in the deep recesses of my bad memory that ARC (then EZ Builder) was having connection issues when VLC was installed also. I may be totally wrong about VLC being the culprit back then. It may have been some other program entirely but it was a video editing program if I remember correctly. 

If you are able perhaps you can uninstall VLC and see if that make a difference.
PRO
Belgium
#31  
dave

i remember that you have to delete averything from that camera .
files are in diff places then reboot . folder on C : files in dowloads page .
all files in device manager from that cam .
PRO
Australia
#32  
The culprit has been found!xD
As it is written: the culprit is the list suspicious!
It was the KeyScrambler Personal app ( protects everything you type from keyloggers by encrypting your keystrokes at the keyboard driver level, deep within the operating system).
Spent a lot of time uninstalling apps and checking the camera until I noticed the KeyScrambler "hiding in the corner":D
When I removed it, the ARC was happy with my USB camera.

I could not select all of you from the "This was resolved by:" because all of you helped me to fix the problem.
Thank you very much to all of you.
I am very happy to be with you!:D
PRO
Australia
#33  
Typing error: not list suspicious but least suspicious.
PRO
Canada
#34  
Wow that is interesting.  Did you know it doesn’t matter if you have a keyscrambler that anyone with a microphone still knows what you are typing based on the sound of your key strokes.  I did some work around this in the 90s even filed a patent  to prevent this. 

alexa is listening.
PRO
Australia
#35  
Didi not know Nink. That is unbelievable and awesome.
Big brother Alexa!:)