United Kingdom
Asked — Edited

Tutorial On Fixing Voice Synthesis Question With Windows 8.1

Tutorial On Fixing Voice Synthesis issue With Windows 8.1 and Windows 10.

User-inserted image

This is a tutorial to help those of you having issues with speech synthesis working within ARC on a Windows 8.1 or 10 computer. Hopefully this will help you if your a seasoned ARC user, or if your just starting out. This issue doesn't effect every Windows 8.1 user, as it seems to be limited to computers that have "Microsoft Hazel Desktop - English (Great Britain)" installed in the text to speech properties of Windows 8.1. In North America there has also been reports of MS David causing the same issue. In this case the en-US directory for the Microsoft David voice needs to be deleted which is the same process explained below. This tutorial is focused to solve the problem of "MS Hazel" being the only voice heard when using ARC's speech synthesis, no matter what voice is selected or settings that are changed. These can be third party voices from companies such as Cepstral, Ivona, and Cereproc, and even Microsofts own "MS Herra" and "MS Zira" voices. So before we begin please take note of the following...

Although the following information are not Registry changes, you will effectively be deleting system files, so you may want to back them up to a separate drive which is explained, just in case. I take no responsibility if things go pear shaped, and you do this at your own risk.

Now that's out of the way, let's start.

From your Charm bar or Windows Start, go to "Search" and type in the following...


Click on this folder.

User-inserted image

Or in windows 10, Simply copy and paste C:\Windows\Speech\Engines\TTS\en-GB in to the "Cortana" taskbar search.

This will now show the four files for Microsoft Hazel. Right click on each file and delete these files one by one. These files will now go to your "Recycle Bin". It's up to you if you empty the bin or keep the files there for a while, it won't make any difference either way to get your voices working. If you want you can make a copy of these files and save them to an external drive such as a thumb drive or memory card.

These are the four files that should show up, and the should be deleted...

M2057HAZ.Keyboard.NUS M2057HAZ MSTTSLocENGB.dat M2057HAZ.APM

User-inserted image

Now exit the system files and go back to your "Home screen" or "Desktop". Time to test if the changes have worked. Open ARC and do the following...

Click on "Project"

Click on "Add Controls"

Click on "Audio"

Click on "Speech Synthesis Settings" and select the Cepstral voice you want to use from the drop down menu.

User-inserted image

Now click "Add Control"

Click on "Scripting"

Click on "EZ-Script"

Open the EZ-Script configuration menu (click on the little gear icon), rename the script control to "Voice Test" (this is optional), and enter the following script...

Say("Hello. You are listening to my new voice.")

and click "Save".

User-inserted image

Now when you click "Start" on the script control, you should hear the script being read with the voice you have chosen. You should now also be able to use "MS Herra" and "MS Zira" voices as well. If you hear a different voice you may need to change some of the voice settings within "Speech Synthesis Settings" to change the gender and/or age. If you hear nothing, insure the computer volume is turned up and not muted.

Cepstral Voice Effects

For anyone who uses or wants to use "Cepstral" voices, you may be aware that they also supply sound effects with the voices they offer. These are great to have your robot sound, well, like a robot and not so human. Downloading a Cepstral voice and selecting a sound effect to use such as "Old Robot" will work fine with Windows Narrator, but won't work straight away with ARC, only the non effect voice will be heard. But there is a way to achieve this. Here I will use "Cepstral Lawrence" as an example but the setup is the same whatever voice you purchase. So to get the Cepstral effects working on ARC, do the following....

Open your (c: ) drive,

Click on "Program files",

Click on "Cepstral",

Click on "Sfx",

Select and Copy the effect you want to use,

User-inserted image

Go back to "Cepstral" again,

Click on "Voices",

Click on the "Lawrence (or whatever voice you have)" file,

Paste the sfx file you copied in to the folder,

Rename the effect to "default.sfx"

User-inserted image

And that should be it. Open ARC, select the Cepstral voice you changed the effect for, and give it a try. You should hear the effect that you have chosen. If you don't hear the voice straight away you will need to change some of the "Voice Synthesis Settings" in that control. I have "Lawrence" working on "Male" in "Gender" and "Senior" in "Age".

So hopefully these changes will help those of you having Issues using the voices you want to with your EZ-Robot projects, and hopefully Microsoft will sharpen up on their SAPI voice engine in their Windows 10 release regarding Text to Speech voices, so nobody will face these problems in the future. We can only hope.

A HUGE thanks to D Cochran, Richard R, The tech guru, also DJ, Jeremie, and Aislinn at EZ-Robot for their help and support when I initially had this issue.

Windows 8 Speech Synthesis And Ez Builder Question

Good luck, and happy building.

Steve G.:)


Upgrade to ARC Pro

Experience the transformation – subscribe to Synthiam ARC Pro and watch your robot evolve into a marvel of innovation and intelligence.



quick note: the directory will be C:\Windows\Speech\Engines\TTS\en-GB

not C:\Windows\Speech\Engines\TTS\en-GB_Backup

You changed the directory name to _Backup during the troubleshooting.

Also note: In North America, it is the en-US directory and the Microsoft David voice that needs to be deleted.


United Kingdom


Lol, oops, thanks for the heads up. Not even sure where that came from confused. It's been edited now thanks. And thanks for noting the North America settings. Hopefully someone will find that useful.:)

@Dj Sures.

If your checking this out, would it be possible for you to change the title a little bit? I wrote it to say "issue" but when I pressed reply it was saved as "question". It wrote "issue" in another thread title and it did the same thing. Thanks buddy.;)


Anybody have a fix for the same issue in Windows 7. I have an Ivona voice installed works fine outside of ARC, but will not work inside. I've tried every possible combo. I think Anna is the only windows voice that came with my win7 pro 64 bit version. I have purchased Brian from Ivona and they tried helping me at length with no solution. This is the first time I've come across this thread and looks like if i could figure it out I'd be able to use my voices. I tried looking for the same folder but i get two: Lexicon and SR, no TTS.

I would be in great debt to anyone to get these other voices working.

United Kingdom


I just saw your post and sorry to hear you're having issues. I'm not going to be of much help but figured I'd bump your post up a bit. I never had a problem with Windows 7 and third party voices. I also had MS Anna (I think that's all Win 7 came with) used Cepsteal and Ivona within ARC with no problems.

I spent the past hour or so going through my old Win 7 laptop to see what could be causing your issue. I have the same C:\ files as you do (Lexicon and SR) but couldn't see anything realaed to Anna. So I did a bit of web searching and found this...


The location of the Microsoft Anna in windows is as follows: C:\Program files\Common files\SpeechEngines\Microsoft\TTS20\en-US\enu-dsk

       The location of the Microsoft Anna in registry is as follows:

so I had a look at this, but apparently my "enu-dsk" folder is empty, even though I still have Anna installed, and working confused. The only thing I can suggest is (if you haven't already) go to the control panel, speech recognition, text to speech, and set Ivona as the default voice the restart ARC.

Sorry I can't be of much help, and hopefully someone else might have some ideas.



Thanks, Steve. Yeah the problem is with all three machines i have running win7 64 bit. I have indeed gone to the control panel and enabled Brian from Ivona and set as default. The name shows up in ARC, but only plays Anna even when Brian is selected. I've tried every possibility of combinations with gender, etc. but still plays Anna. The problem seems to be with Ivona only. I've read others having same kinda troubles with win 7 pro 64 bit. Seems that 64 bit only voices will work, even tho the Ivona people said that the Brian voice was 64 bit. I'm going to purchase a CereProc voice I like and give it a try. The android head needs to have something other than ANNA voice, lol. Worst case I can install a multiple boot and add another OS to the boot sector and install win 8.1 and follow your guide above to fix. BTW are you using win 32 or 64 bit?

United Kingdom


What a pain in the butt. Three computers having the same problem. Curious though, when I said Ivona worked on my Windows 7 laptop, I forgot to say that it's a 64 bit machine as well.

Something you could try before paying out for another voice... try a free demo Cepstral voice. When you use it, you will get a "This voice is not licenced..." message before it reads any text, but at least you can find out wheather this will work, and narrow down wheather Ivona is the problem, or if its Windows.

Just a thought.;)


Great Idea. Will do.

United Kingdom


I just did a bit more web searching and found this...


To configure the windows default voice for 32 bit voices, click your Start button, then click Computer. Copy and paste the following into the address field in Windows Explorer:


This control panel will display your 32 bit voices, and all third party voices such as AT&T should appear in this control panel. So you can then set Crystal as the default voice, but only for 32 bit applications.

I haven't played with this so I don't know much about it, but maybe it will help you.



I did try the wow64 fix, but did not work . BUT, you gave an obvious choice to try, , going with another company...lol. I so liked Brain's voice. But I tried Paul with the Cepstral and worked out great. So it is the Ivona voices. I sprung for William and I'm happy to say it works very well. I also liked the American voice, Adam. Thanks for suggesting the obvious. I think I need a holiday:)

United Kingdom

No worries buddy. I'm glad you got something working, and something your happy with. Now, get down to your travel agent. I here Spain is nice this time of year.:P


@ Steve G I'm running windows 8.1 64 bit and have followed every step in this guide but still can't get Ivonas Brian's voice to work. My question is do i need to delete the 4 files in en-GB prior to installing Ivona? Been banging my head on a wall trying to figure it out


Since you are in the US, it is probably the default US voices that are interfering. See this note from post 2 on the thread:


Also note: In North America, it is the en-US directory and the Microsoft David voice that needs to be deleted.


United Kingdom


When I went through the process, I already had the 3rd party voices installed before I deleted the MS Hazel directory which worked for me. I guess you could try.

Just to note, I see you're from the U.S. Do you have a en-US directory as well as en-GB? If so, I believe that's what you need to delete. I'm not 100% sure on that so I'd thought I ask, as @thetechguru mentioned about the North America directory, and en-US directory and the Microsoft David voice that needs to be deleted. What MS voice takes over when trying to use Ivona Brian?

Also, have you tried different setting variations in the voice synthesis control in ARC? (Changing Gender, Age ect.)


I just saw that Alan replied while I was writing. That's probably what's causing the issue.


@ thetechguru and Steve G You guys are awesome! I went back and backed up my en-US folder and deleted the files. Fired up ARC and Brian is now working

United Kingdom


That's great. Pleased to hear it (as I bet you are).:)