Asked — Edited

Trying To Get Connected

brand new laptop with windows 8....

error message;

Attempting connection to COM3 Comm Err: The operation has timed out. BbytesToExpect: 1

Received: Disconnected Connection Failed: System.Exception: Controller Not Responding at EZ_B.EZB.Connect(String hostname, String tcpPassword) Disconnected

I'm a Chef and a DIY'er. not much of a computer tech so i need some help!

suggestions?

Ray


ARC Pro

Upgrade to ARC Pro

ARC Pro is your gateway to a community of like-minded robot enthusiasts and professionals, all united by a passion for advanced robot programming.

United Kingdom
#1  

It looks like it's not COM3 that you need to connect to. When you pair the EZ-B with the PC it will add 2 COM ports, the higher one is for firmware updating and the lower one for ARC connection. Edit: correction, the higher one is not to be used, the lower one does both ARC and Firmware as DJs post below.

Check the COM port, if in doubt, try them all.

PRO
Synthiam
#2  

RichMR2, the lower is for both Firmware and ARC. The higher is not to be used at all:)

More information can be found here: https://synthiam.com/Tutorials/Default.aspx?id=5

Raybot, I would recommend reviewing the tutorial section from the beginning. Follow each step - it should not take longer than an hour:)

#3  

i will do that tomorrow morning again. i was doing so, watching the tutorials and making progress along the way. I'm still getting used to my new computer with widows 8 confused

PRO
Synthiam
#4  

Windows 8 isn't a fun learning experience, is it?:( I am using it right now also - it's very unproductive I find.

#6  

I' not sure if the computer is running the correct Bluetooth driver?

Intel(R) Centrino(R) Wireless Bluetooth(R) 4.0 + High Speed Adapter

I believe this is the program that is running?

any suggestions. i did watch all the tutorials that DJ so painstakingly has made;)

initially i removed the device (Bluetooth Linvor) and re-installed it. tried all comports with no luck tired

sorry to be a nuance.....

Ray

#7  

trying everything, uninstalled, re-installed. lights are steady. more comports showed up. tried all comports. the only one that gave me a response was com5 with the following result;

Attempting connection on COM5 EZ-B reports EZ-B Firmware V2 Connected

Welcome to EZ-Robot!

This is the first time you have used this EZ-B. We recommend you also take a moment to view the tutorials at www.ez-robot.com/Tutorials. Nearly every question you have regarding EZ-Robot is answered in the Tutorials.

Press the HELP menu option to watch a video about this Firmware Upgrade process. Starting Boot Loader...

sending ping sending ping sending bootloader Failed to load bootloader!

Have you selected the correct EZ-B COM port? Use the Help menu option to view the online help and watch a video demonstration.

If you are considering contacting us, ensure you have followed the tutorial first. You may find the tutorial by pressing HELP from the menu. If you still feel necessary to Contact Us or post on the forum, we will require a copy of the debug message by pressing Edit and pasting it to us.

Nearly every issue is resolved by properly following the tutorial and ensuring you have the Microsoft Native Bluetooth Stack. This software is not supported in a Virtual Machine. I am EZ-B BootLoader. Gimmie Firmware!

United Kingdom
#10  

Use COM4 not COM5

#12  

I'm about to pull my hair out........ stress

#13  

Ok, it took a while. EZ-B is working now. (com5)

not sure what and why but i have control, firmware upgraded to.