Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Smtp Client Questions

Hey DJ, I have the SMTP plugin a go (really looking forward to using this), I seem to have it configured correctly to use my gmail account for SMTP, but when I run a script to send an email, I get this:

Error on line 1: Failure sending mail.

This what I'm using:

Code:


ControlCommand("SMTP Client", Send, "Weyoun7ster@gmail.com", "Bob Smith", "Test", "This is a test message")


Does anything look wrong to you?

AI Support Bot
Related Content
Synthiam
#7  
@DJ, lol...sorry for the confusion, I changed the password for purpose of taking the screen shot only. My real password is in the config.

Good thought on the account setting. I know there is a setting for POP, I never saw one for smtp, I'll double check.
#8  
Worked fine for me on my google apps account. I think you do need to have either POP or IMAP enabled on your account in order to send through Googles SMTP servers. (settings | forwarding and pop/imap).

Alan
#9  
Glad it works for you Alan. IMAP is enabled, google support page also said that it need to be enabled.

Port 587 per the google support page says it is for TLS and 465 is for SSL. 587 with gmail errors right off the bat for me. 465 just returns Failure sending Mail after a few seconds.

I can telnet connect to smtp.gmail.com 465 from my PC. Something is off but I can't pinpoint what or where it is. It's got to be related to my account settings, I don't think it's an issue with the plug in.

On a brighter note, I did get smpt.mail.yahoo.com to work with port 587 with my Yahoo email. The plugin does work (many Thanks DJ!) Gmail is just being a meany pants to me. :P
#10  
One more observation DJ but I can't right click on the plug in to move to another desktop. And evertime I open a project with this plug in it, it tends to hide from me, behind other items and even "smart arrange" does not bring it to the front. It's like hide and go seek.

Anyone else see that behavior?
#11  
Another cool thing you do with this is use it to send messages to your cell phone (if your phone provider give you that options, which I think most do). In America the carrier I have is Verizon, their email address for phones are: YouPhoneNumber@vtext.com, if you send an email there in any app (not just ARC), it comes through as a regular text message.

You'll need to check with your carrier and your messaging rates would apply if you have that. I know Sprint and ATT in the US have the email to phone as a text messaging option.
#12  
Trying to set this up but I get this error;

Code:


Start
1: ControlCommand("SMTP Client", Send, "houston5913@hotmail.com";, "Bob Houston", "Test", "This is a test message")
> Error on line 1: Failure sending mail.


New to windows 10 and can't find where to check smtp, pop or the imap to see if they are configured properly.
I have the Control configured like this:

User-inserted image


Also tried changing the SMTP to smtp.outlook.com and got this error;

Code:


1: ControlCommand("SMTP Client", Send, "houston5913@hotmail.com";, "Bob Houston", "Test", "This is a test message")
> Error on line 1: The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.7.57 SMTP; Client was not authenticated to send anonymous mail during MAIL FROM
PRO
Synthiam
#13  
I would start by reading the information in the plugin. The link is here: https://synthiam.com/redirect/legacy?table=plugin&id=128

The settings are not on your computer. They are on your google gmail settings. You will have to use a web browser to login to your google gmail account and configure the settings. The web browser is the same program that you use to check your email or use this forum. Once you are in your email on gmail google, you will have to locate the pop3/smtp access settings.

I do not know where the settings are located in the gmail google website. I do not have a gmail account. Or a hotmail account. Or a yahoo account. Or any email account:)

If anyone who does have those accounts can share information, that would be useful. I'm pretty much useless to answer any questions about third party email servers.
#14  
That set me on the right track, thanks DJ,
For the Hotmail account i needed;
SMTP Server Address - smtp-mail.outlook.com
Got it working now, I wish I hadn't spent all that money on a Nest Camera!
#15  
@JustinRatliff

If you still want to try to get Gmail working, I would suggest setting up a thick IMAP client like Outlook or another email client. If it works, you know there is an issue with the plugin or you have a typo in the config. If it doesn't work, you know it is your gmail account, but the error message may be more verbose and lead to a solution.

On another note, the phone#@vtext.com wasn't working for me. I did some research and remembered that years ago I had turned on spam blocking to prevent web and email to my phone. If others have a problem, it can be updated here: https://wbillpay.verizonwireless.com/vzw/secure/messageIntercept/messageInterceptHomeSpam.action (you'll need your VZW account logon info) or you can instead send to phone#@vzwpix.com which is really for sending picture messages but also works for text and is not blocked by the VZW spam controls.

I have heard, but have no way to test, that phone#@vtext.com actually works to non Verizon cell phones too.

Alan
#16  
@Alan, That is cool, I had not heard about vzwpix.com.

Thanks everyone for your suggestions. I've read all the related documentation and everything is configured correctly and working with my Yahoo account now. I'm good to go.

Other than the SMTP Client can't be moved to another Desktop and it seems to set to be behind other controls (if I attempt to drag it overtop of another control). Anyone else see this behavior?

I give up on gmail, it's not worth fighting with (for me).
#17  
Justin, the desktop 1 issue is common to all plugins. It is on DJ's todo list. Not sure about the issue of it hiding behind other controls.

Alan
#18  
@Alan, (Thank you) do you know the specific thread where that is discussed? I tried to find it but didn't have much luck.

Because I removed the control and added it back and now the plugin control is on my 2nd desktop (which I want) but it is still set to be behind all the other controls still. - This is not a compliant and it's not causing me any problems, I just wanted to share what I observed.

Happy early Memorial Day, for all those in the US. :)
#19  
I don't recall which thread, just that it was discussed... Sorry.

Alan
#20  
That is a pretty cool plug in. I have an ATT yahoo account, took a few tries with the settings and getting the script proper but was successful in sending myself a camera image of myself. :-)

Now I am thinking about using CY as a simple cheap security system since I've added a PIR sensor to it. Hmmmm, the possibilities...:D
PRO
Canada
#21  
Hello Gentlemen,

I am updating the SMTP Client documentation and I was wondering if anyone has figured out how to successfully use the client with gmail yet?

It seems that Alan did, @thetechguru would you mind sharing your settings if they are different than the example here?

Maybe you had some settings configured properly on the Gmail settings side, would you mind sharing those as well?
#22  
@Jeremie, 

I'll need to see if I can find the project and see if it still works.  Google made a change a while ago that disables less secure clients unless you specifically allow them in your account, and by this time, they may have removed that option.   They use OAUTH for authentication now rather than user name and password that transmits in plain text.

I'll take a look after work and get back to you.

Alan
#23  
Took a quick look and I think the plugin needs to be updated to use TLS/STARTTLS instead of SSL, but you can try just SSL by changing the port to 465 (instead of 587).

I am pretty sure even though you are only doing outbound that you also need to enable IMAP on your account, which is in the account settings in the GMAIL web page.

Also, be sure you don't send more than 500MB a day to avoid having your account locked out.  You should only send large attachments or lots of email when using the Gmail web client, not Imap/smtp.

Alan
PRO
Canada
#24   — Edited
Thanks for looking into it Alan,

Yeah, you're right, I did have to enable access for less secure devices on the Gmail side.

I did try 465 with SSL, it seems to try but in the end I didn't receive the email on my gmail account.

I believe you're right about the TLS, I have no idea what that is but it seems port 587 is associated with it and not SSL.
PRO
USA
#25  

Quote:

Also, be sure you don't send more than 500MB a day to avoid having your account locked out.
Interesting I didn't know that, I google and found this:

Quote:

The daily limit sending via POP/IMAP connections (using a mail client such as Live Mail, Outlook, Thunderbird etc.) is 100 messages per rolling 24 hours. (NOT per day).

Quote:

New or recent accounts will usually have lesser limits imposed, until their reputation over time is established.
https://support.google.com/mail/thread/47871468

It makes sense for google, free product for consumers.

Quote:

Yeah, you're right, I did have to enable access for less secure devices on the Gmail side.
I read somewhere in some cases google can trigger an additional account verification through the web interface, the stmp stops working (stmp error with details) and you need to logon via web client.

It's all related to "less secure devices"
#26  
PTP, I have a Gsuite account, so may have higher limits (even though it is a legacy free account, not a commercial account).  The limit was listed in a link on the pop/imap settings page.

Jeramie, TLS is a type of encryption.

Alab