United Kingdom
Asked — Edited

Slight Question With Cereproc Voices

The title SHOULD read "Slight 'issue' with Cereproc voices.

I ordered and downloaded a new voice from Cereproc for a new project, but have encountered I slight issue. Whenever it says a sentence, it never finishes the last word of that "senten". Another example, when asking the time, the Ivona and Cepstral voices would say

"It is 8 32 pm.",

but the Cereproc voice says

"It is 8 32 p"

missing off the "m" completely. And this happens with everything it says which is a real pain, and only happens in ARC. Outside of it, and the voice is okay.

I tried restarting the project but it makes no difference. Has anyone else had this issue using Cereproc voices on ARC?


Upgrade to ARC Pro

With ARC Pro, your robot is not just a machine; it's your creative partner in the journey of technological exploration.


Sounds like it could be something is interrupting the Say command. If it is not a Say-Wait type this can easily happen. Possibly even with a Say-Wait type as well, I'm not sure. But that's all just a guess (yeah, I seem to be full of them:D ). I have not used voices from Cereproc.

BTW, I have, at your suggestion, used the "Robin" voice from Cepstral and it's fine, though the setup in ARC to get it to work is strange. Anyway, only $10, can't beat that deal.

EDIT Why do I think of these things just after I post? Mind you, I haven't ruled out stupidity.

I wondered if adding a space or two after the string you wish to have the computer say would help. That way the last character would not be one you wished to have spoken and might make it through. If not maybe a space then a period. Something like that.


I've had similar issues with Alan. I found the SAYWAIT resolved my problems.

United Kingdom


Well, writing a test script like the following...

SayEZB("Hello. How are you today.  .")

has improved it, but my problem is my AIML codes for pandorabots... all 5000 plus of them, would need to be changed to incorperate the new voice as well as all of the phrases saved in ARC which I don't really want or should have to do.

Thanks anyway. I just wonder if it's an ARC bug that could be easily fixed, or is it a Cereproc issue (although as mentioned, it works fine outside of ARC when using a screen reader.


I just saw your post Will. I did try the SayWait but didn't help. Thanks anyway.


It might be better to remove the existing period at the end of the sentence, then add the extra space or space-period combination. But, as you say, that means changing all of them either way and that would be a pain and a half.

Regardless of that, did adding just extra spaces at the end work, or was it necessary to put in the second period as well to get it to say the phrase properly?

The reason I ask is that maybe we could get DJ to just add a space or two to the sentence before sending it to the speech processor in all the Say type commands. I don't think that would interfere with the usual operation of them and might solve this problem for now.

Of course the best route would be for DJ to find the root cause and address that, but that could take a while and I doubt he has time for that any time soon.

United Kingdom

I tried the space/period and adding a few spaces before the single period, but they were not recognised so unfortunately made no difference. The only way was period/space (or two)/period.