Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by Dunning-Kruger!

Servo Causes Ez-B V4 To Reboot

I just started working with my ez-b v4 developers kit. I got the camera working and mounted it atop two hitec HS-422 servos to provide pan and tilt capability. The two servos work fine with the ez-b. The problem is when I connect just one of the servos that came with it the kit and make it move. I briefly hear the servo move and then the ez-b reboots every time. I don't have any load on these servos, just testing one. I am powering the ez-b with a regulated 12v 1.5 amp power supply. Could it be that the servos included in the v4 kit draw more power than the board can handle? If so, then why use them. I tried each of the four included servos (not the continuous rotation servos) one by one and each time the same result, reboot. Any thoughts. Suggestions. Advice?

AI Support Bot
Related Content
Synthiam
#1  
You will need to get a power supply with a lot more than 1.5 amps to run your servos with the EZB(4) Look for something around 10 amps.

Also I think those servos are 6 or 7 volt servos, 12 volts is way too much voltage. You will want to consider a dc to dc switching regulator to supply less voltage to your servos.
#2  
@peter982014 You have a power supply problem and it's not the ezb. It's your 1.5 power supply... It can't provide enough power for running things like servos... DO NOT USE 12v to power your servos you'll eventually burn them up I recommend using 7.4v rechargeable batteries like lipos or NiMh or a power supply of at least 10amps....
PRO
Synthiam
#3  
12v is too much power for your servos. I notice you have not completed any lessons for the EZ-B v4 developers kit. Please press the LEARN button from the top menu of this website and scroll to find the Developers Kit Course.

We are unable to assist you if you do not complete the Developers Kit Course on how to use your robot.

In short, here is a summary to help you with your problem:

1) do not use 12v to power servos. They will be damaged

2) 1.5 amps is not enough for powering the servos, so your EZ-B v4 is browning out due to lack of power. Please use the battery pack that is included, or review the tutorials on recommended ac/dc power adapter

3) review the Developer Kit Course and complete the lessons for the course. Specifically, you need to read this course: Powering Your EZ-B v4. Also complete the other courses that are relevant to the EZ-Robot Developers Kit
#4  
Thanks for the replies gents. Remember I said it was just a test. I guessed that there probably was not enough power for the servo causing the voltage to drop low enough for the ez-b to reboot. I now run the servos from a separate power supply which shares a common ground with the ez-b. A 6 volt 12 amp power supply. Now the all servos are alive and functioning , all 16 at one time.
#5  
Just another note... EZ Robot servos have no issues with 7.4v, but in my experience Hitecs don't like anything over 6v... I had a HS422 fail while using 7.4V... not sure if it was just a coincidence, but my other Hitecs would chatter and fail to position properly when I tried using more than 6V....
#7  
@peter... You're welcome... Enjoy your ez robot stuff... :)