Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Hong Kong
Asked — Edited
Resolved Resolved by DJ Sures!

Servo And Sound Being Stuck(Or Slow Reaction)

Hello everyone.

Why my roli gets stuck while making an action or speaking out words?

This issue seems random. For example, when I instruct my roli to do "clap" action again and again in ez-builder, the robot may finish the action very slow one time, but normally the other time.

I suspect this problem may be caused by the connection issue. I made the flood protection value from 0 to 1. However, it did not seem to help.

Moreover, I also suspect that the stability of the robot's performance is strongly related to the robot's battery. When the battery is about to die, the robot has a bigger probability of getting stuck while performing an action or sound.

I hope I can have a clear understanding of this issue's causes, and effectively improve the stability and smoothness of my robot. So, anyone can help?:)

Best regards.

AI Support Bot
Related Content
Synthiam
PRO
Synthiam
#1  
Hi!

1) network saturation is most likely the cause to jerky animation. The FAQ page is important and here is the relevant faq: http://www.ez-robot.com/Tutorials/FAQ.aspx#5

2) flood protection does not apply to a revolution robot. set back to 0 and do not change the value. there is a help bubble next to the flood protection setting for information on it's use. additionally, the benchmark utility would be required, as specified in the help. however, do not bother with it because it does not apply to a JD revolution robot.

3) when a battery begins to die, there may be a very slight chance of jerky movements. however, that is incredibly slim because the low voltage warning is configured at the optimal value.

in short, verify and resolve network saturation as that is the cause to the jerky servo movements and skipping audio.
Hong Kong
#2  
Thanks. @DJ Sures. I've carefully selected and changed the wifi channel, and the movement has got smooth again.