Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Roomba Can Not Be Controlled By Ez-Board

I don't know what happened to my post. I posted this already.

I waited for the mail to run today. I was so excited to get my PS2 connectors. I wired them up just like in the video. Pin2 was Signal and Pin6 was ground. I hooked up the roomba and turned it on. I had previously connected it to D0.

Nothing. No control.

The I-Robot makes three types of THESE type robots.

The first is sthe 4XXX and 4XX. They usually need to have their firmware zapped. You would select OLD protocol.

Then, there is the 5XX which would be 115k baud rate.

The Create was made to be an experimental robot base for your robots. I has a baud rate that is 57,600.

I can not get it to work. I am sooo close.

sorry for so many problems.

:-(

Did Anyone else get the Create to work with this setup?

Thanks,

Mel

AI Support Bot
Related Content
Synthiam
PRO
Synthiam
#1  
One of my roomba's has a permenant EZ-B mounted on it 24 hours a day:) No troubles.

Usual people experience issues by hooking the D0 to the wrong port on the ps/2 plug and frying the port. The only fix is a chip replacement, if that's what happened. There is a disclaimer in bold in the Roomba tutorials to check for voltages before connecting to D0

But, if you did check and there are no voltages - you should be okay.

Does your D0 work with servos? Plug a servo in and check to see if your D0 is still okay
#3  
OK, I placed a servo on D0 and I could completely control it fine.
You said that you have a Roomba all the time. But, it is NOT a Create. But, the Create SHOULD be the same as long as you give it 57,600 baud rate.

Now what do I do?

thanks!
PRO
Synthiam
#4  
You wonder if your Create is broken, or the plug is incorrect. We have 4 roomba's here, none are Create - but we have schools that use Create with EZ-B.

Like everything in life, once you figure it out you'll say "oooh, right"

One of the roomba's i use is 115,200. And the other is 57,600

Both work great - I used the 57,600 in yesterday's video @ 3:12 mark

#5  
The Create is Brand spanking NEw Just out of warranty while I tried to figure up what kind of computer and microcontroller I was going to use.

When I asked you about the cable, I NEVER got a straight answer. I needed to be sure that the pins were on the Second pin from the bottom on the left White, or signal. the lower bottom pin on the right Ground or black. The picture was not clear enough to be certain.

Please advise.
#6  
I have some NEW information for YOu.\

I checked the D0 port and it was good.

I hooked up the Create to the PC through the SCSI cable -An I-Robot Factory cable.
It controlled the robot fine.

Now - IT HAS TO BE THE STUPID CABLE.

I made it correctly. So, please give me MORE information than simply giving me a video or picture where the pin and cable are not EXACTLY clear to what is what.

On the seven pin, it should be pin 3 and 7.

i have a SIX pin so I would be JUST LIKE THE PICTURE as I understand it.

So, WHAT could be wrong????

Thanks,

:-(
#7  
I DO remember that the same software that I use to operate the Create will NOT work on the roombas that I have. They are the same baud rate, but Something evidently is not the same.

I have this whole robot put together and I used a Brand new Create so I would not have any problems.

I know that you are very busy. But, could you talk to I-robot about that? They may give you a simple answer.

Thanks,

Mel
#8  
OK, Good News!!!! I made up a fourth cable. The first two I did not like. But, the third one was nice. But, it was from China and it was a cheap cable. I can't see where I went wrong on it. I had to use my LAST PS2 cable and adapter, But, it worked this time!!!!


So, that narrows me down to the soundboard. I can't put Mp3 on there, can I.

Thanks for baring with me through my hard times. It was a misurable day. But, it came out ok. By answering my posts , you stimulate my thinking. It is an OLD brain and take a lot of work to get it Kick started.

I will keep you informed. And, please let me know if you find something on the soundboard. I will keep Experimenting.

Thanks, D.J. !! I have a son about your age. Heck, I have also a Grandson about your age.

Cheers!!