Asked — Edited
Resolved Resolved by Andy Roid!

Roli Won'T Power On

Battery fully charged showing 8.4 v on my voltmeter, checked connections several times, but brain not powering up. Need help as my kids are anxious to start programming the bot.


ARC Pro

Upgrade to ARC Pro

ARC Pro is more than a tool; it's a creative playground for robot enthusiasts, where you can turn your wildest ideas into reality.

PRO
Synthiam
#1  

Due to being a hobby robot platform, there is the very small chance that the power is not connected inside the robot.

  1. Consult this tutorial: https://synthiam.com/Tutorials/Lesson/69?courseId=3

  2. Let us know if you see any plugs or wires disconnected from inside the robot

And welcome to the forum!

United Kingdom
#2  

Welcome @Lind12950.

Further to what DJ has mentioned above, one possible cause for now power could be that the fuse needs replacing. The tutorial for fuse reacement in below...

Roli Fuse Replacement

#3  

Cool will check it out tonight, thanks for the info

United Kingdom
#4  

No problem. If you still have problems, post back here with what you tried and we'll try to help you further.

#5  

Unfortunately neither fix worked...I checked connection with my multimeter and it appears the switch is bad. It appears to be crimped or soldered very well and is difficult to remove. I connected the two wires to bypass the bad switch and the robot quickly turned on, but then immediately stopped because the fuse blew! So I may have 2 issues a bad switch and then something else that blew the fuse. Also will somebody send me a switch and fuse since it is still under warranty? Is there something else going on with the robot? My kids are getting impatient and so am I, ready to start programming and seeing robot move.

#6  

There is obviously something else going on. The fuse is a simple standard automotive fuse so that would be easy and cheap to replace from any automotive supply place or most stores like Walmart. Of course it would likely just blow again. It takes a good bit of current to blow that fuse so it looks like there may be a short someplace. Anyway, that's what I would look for first in the wiring. See if there is any obvious place where the wires are touching and causing a short circuit. This, as opposed to the open circuit you have been looking for.

Maybe you could take a few pictures of it so we could see the wiring for ourselves. Often experienced eyes can catch details the new user can miss. A good shot of the EZB4 (brain) where all the wires plug in would be very helpful. If you already have the body open, some shots inside of it would be good as well. That's what's great about the internet, instant visual communications. :)

EDIT I just recalled that the Roli also contains an HBridge device. This is a higher current device for driving the tread wheel motors. A good, close up shot of it would also be helpful.

Also, is it possible that, when you placed a jumper across the switch you may have touched something else as well? I don't have a Roli so I don't know how likely that would be, but I thought I would ask.

#7  

I agree with WBS. Some close up pics of the H-Bridge would be useful. Several came mis-wired from the factory, and that could potentially cause the fuse to blow.

Where are you located? If you are in the DC/Baltimore megalopolis, I could arrange to meet you Sunday and help troubleshoot in person (I really wish the forum displayed more than just country for location).

Alan

#8  

Here are the pics...if it keeps blowing fuses will ez robot warranty the fixes? it has never worked since I got out of box and would like to start using it soon User-inserted image

User-inserted image

User-inserted image

#9  

Double check some of the wiring. In the picture I see a servo wire incorrectly connected. Be SURE the black wire on all the servos and other device connections matches up with the black terminal on the board. In the picture the lowest wire looks wrong. Meanwhile we will continue to try to resolve your issue.

Ron R

#10  

Double check the bottom row also. It is hard to see but there may be errors there also.

Ron R

#11  

I don't know your abilities, but if you disconnect the H bridge and confirm all servos and other wires are connected correctly, you could try to power up again. If the switch is bad I would want you to contact the EZB office to see the next step, possibly a warranty issue?

I would like to know if the EZB is ok. The heavy current draw could be from the H Bridge and by disconnecting it that concern is eliminated.

Ron R

#12  

Go to the learn section and type in Roli H Bridge wiring. It will show you the wiring and information. Your problem may be here. Check well.

I am sorry you are having a problem. This is not a normal issue with the EZB products. I know DJ's staff and the Community will help you get the issues resolved.

Ron R

#13  

By the way I assumed you purchased a replacement fuse and installed it. Automotive or Walmart stores carries them.

Ron R

#14  

As Ron pointed out, at least one of your servos is plugged in backwards. That shouldn't bow the fuse at power up, but will either burn up the servo or blow the fuse as soon as you try to move that servo. H-bridge appears to be wired properly. I suspect the bad switch may be the issue.

Alan

#15  

My only other concern is if the heavy power wires to the H Bridge is connected correctly. Please also check this wiring. let us know how you make out.

We all hope it is just a bad switch.

Ron R

#16  

I am going to disagree somewhat with Alan... Plugging in a servo backwards which I have done many, many times won't blow a fuse and won't burn up your servo either... Even if you try to move it with servo commands... Nothing will happen at all.... As mentioned I have accidently done this many times... most recently with my inmoov's wrist servo.... Had it plugged in backwards for 20 minutes all the while trying to move it with servo commands... Eventually I figured out the dumb move, plugged it in properly and it functioned normally after that....

#17  

@Richard R, was that an EZ-B Servo? I was pretty sure that sime if the smoked servos people have had were from reverse polarity and not just from over-stress. Maybe the one you were using has a protection diode? Or maybe I am just thinking about reverse wired H-bridges....

Alan

#19  

@Alan, I have done this with Hitecs, MG996 and an MG946.... These are the servos I use most often... If you plug in a servo backwards you are effectively reversing ground and signal.... not really reversing polarity in the true sense of the word (meaning + and - )..... I have many ez robot servos maybe I should throw one in backwards and see what happens....:) You have to consider that if the ez robot servos were to indeed smoke and quit if you plugged them in backwards, wouldn't we have a crap load of posts from people that accidently plugged servos in backwards and smoked their servos?

#20  

@Lind 12950

If there are no definite shorts seen, wiring is correct, the fuse is good and the switch is good it may be a bad H Bridge. let us know how you make out. You should then Contact EZ Robot and refer to this thread.

Regards, Ron R

We will continue to monitor your threads.

#21  

Since you seem to know your way around a VOM, you could do a test that would check the entire wiring harness at once for shorts.

To do this, however, you would have to disconnect the wires going to the HBridge and EZB4. Perhaps some others as well. I can't say for sure since I don't have a Roli to check with. In any event, once done you could check out the wiring harness for a short using the wires on the switch. Be sure the switch is set to OFF. Yes, I know it's open anyway, but just to be sure. One wire from the switch should go to the battery and the other to the circuitry. What you want to measure across is the switch wire NOT going to the battery and the OTHER end of the battery. Be sure to measure those points with the Volt-Meter first to be certain there is no voltage between the two points. If there is, that alone could indicate a short. and you would not do any ohm-meter test of course. If there is zero volts, then use a low ohm-meter scale, measuring across the same points. That should at least tell you if there is a short.

#22  

I have hotwired the faulty power switch and the robot is now working, seems the backward servo was the problem, fuse no longer blowing, but I still need to get a replacement switch for the bad switch. Is this something ez-robot handles under warranty?

#23  

Did you send a request through the Contact Us page? When your there make sure you click on the Product Warranty box at the top. It will give you a form to fill out and send in to EZ Robot. Good luck and I'm glad your bot is now working with only a bad switch to replace. Contact Us linky

#24  

The fuse is an auto store or maybe even a Walmart part. Installing a fuse of a close value can help prevent a future problem. Use the Contact Us page to make a Warranty claim.

Ron R

#26  

I hope you and Roli are having a good time..

Ron R