Asked — Edited
Resolved Resolved by Dunning-Kruger!

Roli Won'T Do Anything

Roli stopped working. He got tipped over on his side but he responded fine after that. He worked fine when I brought him home and played with him. This was wednesday. Friday I took him to the other school and he made the chime but his battery was low. I put him on the charger but when it turned green and I turned him back on. Nothing happened. He wouldn't make noise or move. I don't know what happened, I have followed every video I could find to make him work but nothing is working.


Upgrade to ARC Pro

Join the ARC Pro community and gain access to a wealth of resources and support, ensuring your robot's success.


Is the ezb fitted securely in the chassis? It may have come loose and disconnected. Press it back in.

When the power switch is moved to the on position, and the ezb is getting power, the audiable chime will be heard. Also the ezb will flash its led based on the wifi mode.

If the ezb is not getting power, perhaps it is not securely inserted into its compartment in the chassis.


Where do I buy a new fuse for him? Also it didn't show any signs it was blown. Also DJ Sures what am checking? The EZB? Where is that


The roli robot was assembled using ezbits. The instructions to build the robot would have been viewed in the learn section of this website. That can be accessed by pressing the learn menu option at the top of this website.

It may be important to revisit the build instructions to refresh your memory of what you learned during building the robot.

The ezb is the computer that all the wires connect to. You would have inserted the ezb into its place in the chassis during the build process.

The ezb gets its power from a connector at the bottom of its unit. That connector makes a connection with the matching connector in the roli chassis.

If the ezb is loose (which may happen over time and during transport), you will have to gently press it securely into place.

Here is a direct link to the ezb overview within the roli learn course for convenience:


Thank you all I got him fixed it was the fuse. I just need to get his servo motors working