Asked — Edited

Roli Not Rolling

My roli is not rolling. All arm and camera servos work fine, camera visual is fine. The robot can do the dance, left/right-wave, and clap sequences. Robot plays music and shows camera video on ARC screen. I just can't get the tracks to move. Robot is not responding at all to the HBridge PWM arrow controls.

  1. I checked the H-Bridge wiring to the EZ-B v4 at least six times.

  2. I checked the internal H-Bridge wiring. It is exactly as shown in the tutorial photo. Push button is in the down position, VCC and ground are wired properly and the 20A fuse is fine (checked continuity-good)

  3. Wifi connection to ARC is fine

Totally stumped now. Need help!


Upgrade to ARC Pro

Don't limit your robot's potential – subscribe to ARC Pro and transform it into a dynamic, intelligent machine.


Eak! Now that isn't fun at all. Although, I like the title of your thread:). This sounds like a need for the expert, James. Can you use the Contact Us and paste the url of this thread for reference? James will contact you and get you operating. It might be a damaged hbridge if everything has been checked.


When you start Roli, the lights on the h-bridge do turn on correct? And roli's tracks can move freely?


The internal H-Bridge wiring tutorial reads that the push button should be in the down position and of course the robot did not work in that switch position. Out of curiosity, I tried the push button switch in the up position and it worked. Now my Roli is rolling just fine.

Either the tutorial is wrong about describing the push button switch needing to be in the down position, or the push button switch in my robot is reverse acting. Not sure which. But it works now so I don't care. Thank you very much for taking the time to send me a response!

This cost me hours of troubleshooting. Whew, glad that's over. Maybe this will help someone else with the same problem.


I noticed this as well, as some of my h-bridges work this way, and others the other way. A bit odd. But the red light on the left is the key to whether it works or not.


mine doing exact same thing, how can I get fixed?