Asked — Edited
Resolved Resolved by DJ Sures!

Rgb Animator Display Scripts Work In ARC Pc But Not In Phone Mobile App -


I have two buttons in the mobile app that are programmed to run an RGB Animator Display (one button) and to clear the RGB Animator Display (2nd Button). Both of these worked in the mobile app on my Android phone before upgrading ARC. Here is the script code associated with the buttons:

ControlCommand("RGB Animator",AutoPositionAction, "RicksAnimation1") Sleep(300)

ControlCommand("RGB Animator", AutoPositionAction, "Clear RGB Display") Sleep(300)

These commands work in the PC ARC and PC ARC Mobile App Creator. They don't work any longer in the phone app. Again they used to work. Any help would be much appreciated. I have the lattest ARC version installed.

Thanks Much for your help ! Rick



Upgrade to ARC Pro

Stay on the cutting edge of robotics with ARC Pro, guaranteeing that your robot is always ahead of the game.


Verify the project is the same on the cloud as on your PC.


Hi DJ,

Would I do this by loading the project from the cloud back to the PC? Would this be done from the PC ARC menu bar ? Is it just the mobile app that we are comparing? Thanks Much ! Rick:)


Yeah - exactly.

Also, if your project is public, I can test it for you tonight. Otherwise if it isn't public, provide me the ezcloud filename and I will test it tonight as well.


Thanks DJ,

I will make it public and also let you know what the file name is. Thanks again. Rick:)


Hello DJ

I decided to not make the app public at this time. I have some IP addresses and username and passwords in some of the scripts.

I did check the cloud version compared to the version on my laptop and they appear to be exactly the same.

The file that you can check is: AdventureBot1.ezb

It is looking to me like there is a problem with the RGB Animator Display Control in the latest versions of the ARC PC Mobile App Creator? Only a guess and probably not correct but will be interested to see what you find.

Thanks for checking this out for me. I am at a loss at the moment as the RGB Animator Display buttons worked fine in the mobile app in previous versions of ARC. Rick :)


Thanks! I'll take a look tonight - I'm in San Francisco for the next few days and won't be at the hotel until this evening


Hi DJ,

Just wondering if you had a chance to check out my AdventureBot1.ezb file in the lattest version of ARC. Interested in seeing if RGB Animator Display works in Mobile App on phone. Also you might try looking at history file for this file and maybe load an earlier version that uses an earlier version of ARC. I could do this also, but didn't want to load to the cloud until you have a chance to check it out first. Thanks Much DJ ! Rick B. :)



I went to the cloud and downloaded a previous version of my file AdventureBot1.ezb that I know worked and the RGB Animation Display buttons don't work.

When downloading a previous version of the file from the history section of the file name, does it load the PC ARC version that the file was created in or does it download the file into the current latest version of the ARC Software that is installed on ones PC or Laptop?

If it loads the previous version (selected from history files) of AdventureBot1.ezb into the current version of ARC that is installed on my Laptop then it does point I think, to something broken in the RGB Animator Display Control for the Mobile App.

With the latest version of ARC downloaded on the computer I can go to the mobile app creator and activate the Animation Display button and the Clear Animation Display buttons and they work fine. When I upload the app to the cloud using current ARC version and download it to my Android Phone these two buttons for the animator do not work. Again they used to work.

Looking forward to hearing your thoughts on this issue? Thank again for all your help. Hope your trip to San Francisco was successful ! Rick B.:)


Apologies I haven't had a moment to look at your project yet:)


Hello DJ,

Here are two files you can look at in the cloud:

Latest - Adventure_Robot.ezb2.EZB Earlier Version - AdventureBot1.ezb

Everything works fine in the Mobile App except anything having to do with the RGB Animator Display Control with the current version of PC ARC Mobile Control. Something appears to be wrong with the current ARC RGB Animator Display Control? Thanks again for all your help !:):)



I tried making a new project with just the basics. I have two buttons on it and the camera view and uploaded it to the cloud and ran it on my mobile device. Everything worked again except the RGB Animator Control. I also tried using the RGB Animator Display in Scratch and when it got to the RGB Animator Block it didn't highlight it yellow and went right over it to the next step with no display on the RGB Animator Display. Seems to work o.k. in ARC on the PC. Hope this helps in your analysis. Looking forward to hear what you find out !

Is it possible you broke something with the RGB Animator Display when you created the software for the new 8X8 display you have been working on?

Thanks Again for all your help as always ! Rick B. :):)


Use the latest ARC Mobile Android update and you're issue is resolved:)


Hello DJ,

Did you put a new android app in the store very recently? I loaded the android EZ- Builder app on my wife's phone yesterday morning thinking it was my phone, but didn't work either. You must of put a new version of app in app store a few hours ago? Is it the ARC App in the Android App Store? I would assume so. Thanks for your reply ! Rick :)


Hello DJ,

I uninstalled ARC on phone as it said I didn't have enough memory to update it. I deleted some programs I don't use and have 277 megabyte free now and it says I don't have enough memory again to load ARC. How big is the new app? Thanks again. Rick :)


It reads 25,282 KB file size. It should certainly not be 277 megabytes.

I know that Android is a little strange regarding where the Apps are installed (storage vs internal). Can you verify that there is enough internal memory available, and not just storage?

Because not all Android UI's are the same, i'm not certain where to look on your device. Android gives me a headache some times:D


I have seen this before (other apps, not ARC). Often a reboot, or clearing the Google Play Cache will resolve it an allow the app to install.

For what it is worth, I had no issues upgrading to the latest on my Galaxy 6 Edge (Android 6.01).



Thanks DJ and The TechGuru,

Everything is working now. Thanks for all your help and QUICK responses ! Rick:):)