Welcome to Synthiam!

Program robots using technologies created by industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation, and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by DJ Sures!

Question With Bluetooth Windows 8

Hello to all!

Got the EZ-Robot and after following all the steps of the tutorial I'm not getting to the connection between the hardware and the program ARC nor the firmware update. My OS is Windows 8 ultrabook is my Sony Vaio with native bluetooth. The bluetooth pairing and I can not see him as "linvor" in the list of devices, but it appears as offline and can not connect with the above programs. I already removed all other bluetooth devices leaving only the "linvor" Duracell batteries are new, the blue light blinked a few times and then got access without blinking red and sometimes blinks and pauses and continues to flash. I checked the solder connectors and did the test with the multimeter and everything is OK, I still can not connect.
Could help me!
Below is the message that appears.

Attempting connection on COM3
Comm Err: The operation has timed October
BbytesToExpect 1

received:
Disconnected
Connection Failed: System.Exception: Controller Not Responding
at EZ_B.EZB.Connect (String hostname, String tcpPassword, Int32 baudRate)
Disconnected
6/30/2013 10:59:30 AM - Connection attempt error

Available Ports:
- COM3
- COM4

Have you selected the correct EZ-B COM port? Use the Help menu option to view the online help and watch a video demonstration.

If you are considering contacting us, Ensure you have Followed the tutorial first. You may find the tutorial by pressing HELP from the menu. If you still feel Necessary to Contact Us or post on the forum, we will require a copy of the debug message by pressing the Edit menu option and pasting the debug window contents to us.

Nearly every issue is resolved by enquiry.c Following the tutorial and Ensuring you have the Microsoft Bluetooth Stack Native. This software is not supported in a Virtual Machine.
User-inserted image

AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
United Kingdom
#1  
Showing as offline is normal since it is not connected even when paired (It's only connected once the connection has happened in ARC or the firmware updater).

Double check the com port is always the first thing I do if I have problems. Easy way to do this is to go to the desktop, open explorer and navigate to Control Panel (it's better than the Windows 8 devices panel you showed)

Under Hardware and Sound click on Devices and Printers.
Right click on Linvor and choose properties
Click on the Hardware tab
You should see under Device Functions Standard Serial over Bluetooth link (COM#)

Whatever COM# is is the port to use.

Try that (it may take a few attempts, power cycling the EZ-B between attempts).

Post any debug messages that come up when trying to connect.


It does look like you are using the correct COM port if Windows has behaved as it should (not always guaranteed). The other things to check are.

1) Are you using the microsoft bluetooth stack? Or have Sony pre-loaded with something like the broadcom one?
2) Have you got any third party bluetooth software running? Sony software for managing bluetooth, something like that?
3) Check power - even fresh batteries can cause problems. When possible I personally use an old 12v AC power supply from an old router to give a constant 12v 2A supply.
#2  
Hello Rich thanks for the reply but I think you're not talking about Windows 8 as the paths you are indicating are other versions of Windows XP or maybe 7 and my case is specific about Windows 8.
But let the answers to your questions:

1) Are you using the microsoft bluetooth stack? Or have Sony pre-loaded with something like the broadcom one?

Yes, I am using the only option that comes with windows 8.

2) Have you got any third party bluetooth software running? Sony bluetooth software for managing, something like that?

No, there is no third party software running only Windows 8 even.

3) Check power - even fresh batteries can cause problems. When possible I personally use an old 12v AC power supply from an old router to give a constant 12v 2A supply.

I'm using new batteries and the power supply that came with the kit EZ-Robot.


I tested on another laptop and gave the same result there is no connection between the kit and the EZ-Robot Builder software, or with the firmware update.
I have also removed all other devices and just let the linvor and yet he appears to OFFLINE (Detail importantly it is the only device that aperece OFFLINE as all others do not show this message)
I repeat my OS is Windows 8 and the orientation of the other systems unfortunately do not work for this version of Windows


User-inserted image


User-inserted image


User-inserted image


User-inserted image
PRO
Synthiam
#3  
Did you have another post with this issue? Where you mentioned it connected once, started firmware, then "locked up"? If so, your chip needs to be reprogrammed because the firmware was interrupted at the volatile point. When the message "copying from temp" happens, the program is being overwritten from the buffer. That is the only volatile point of the firmware upload process.

You will need to Contact Us to have your ez-b serviced. We also run a quick diagnostic to see if there are any other issues. The chip logs and records connectivity successes and failures, as well as other things. We can read that information back:)
#4  
Hello DJ Sures thanks for answering my question!
No this is the first time I'm posting on this connection problem with Windows 8 and Bluetooth. DJ Sures has so far not been possible to make any kind of connection or to update the firmware and not to connect the EZ Robot Builder software.
I think the problem is in Windows 8.

Thank you!

Verinaldo Dantas

Follows screen log:

User-inserted image
United Kingdom
#5  
It should show as offline, that is totally normal.
User-inserted image


ARC and the firmware update work fine in Windows 8 so we know it is not an OS issue.

Since you have successfully paired with the EZ-B it shouldn't be an issue with the EZ-B either.

Check your drivers. The only item under bluetooth I have on my Windows 8 laptop (other than the 2 EZ-Bs) is Microsoft Bluetooth Enumerator. You may find removing the low energy enumerator may solve it (that microsoft Bluetooth LE Enumerator), also the Qualcomm Atheros adaptor (you may need to uninstall and use microsoft generic drivers). In fact, everything except linvor and Microsoft Bluetooth Enumerator (disable the others rather than delete to see if it helps).

It all seems like it should work. COM3 is the correct port (unless Windows has done something not normal - which happens) and you found it to pair it so it should work. We know that most issues are based on third party drivers and/or software.
PRO
Synthiam
#6  
Have you tried both COm ports? 3 and 4?

I've seen windows do funny things with them.

If so, it may have been a chip damaged by static during shipping. Out of a few thousand units, it happens on occasion. We would need to service it and send it back to you. Contact Us and we can set that up:)

Keep in mind that myself and Alan are both on holidays until July 10th. Even though we check email, we are not at the office to physically see your board until we are back.
#7  
Rich and DJ Sures, Thanks for the help!

Thanks for your help it was possible to connect the EZ-Robot and update the firmware can now start developing my project robot!
Valuable tip: The determining factor for the bluetooth to connect was to remove and reinstall the drivers with updated drivers and port that appeared was to COM 4.


Below successful connection message!


Loaded firmware. Reboot EZ-B
6/30/2013 4:46:17 PM - Please cycle the power on your EZ-B and close this EZ-Robot OS Update Application.

It's time to build an EZ-Robot!:)

Thank you!:)
United Kingdom
#8  
It just goes to show how funny Windows can be at times.

Glad you sorted it.
PRO
Synthiam
#9  
Glad to hear:)

You wouldn't believe how much money we spend on windows issues.:(