Asked — Edited

Odd Ezb4 Question. D14 And D15 Seem To Be Linked?

Ok, so one of my EZB4 seems to have an odd problem... I have 2 servos connected... one on D14 and the other on D15. If I send a servo move command on D14, D15 also moves to the same position. Likewise, if I send a servo command to D15, D14 moves in parallel... I tested 2 other ezbs and they seem to work fine... Also seems to be only D14 and D15 that are affected

Fault or?


Upgrade to ARC Pro

With Synthiam ARC Pro, you're not just programming a robot; you're shaping the future of automation, one innovative idea at a time.


Interesting. One of my EZ--B's port D15 died. I hadn't reported it yet since I have 3 others (thanks to getting 2 from Moviemaker for a bargain price).

I assume you tested all with the same project? It is possible to link multiple servos to one servo control in ARC.



yep and when I swapped out ezbs everything was fine with the project that I noticed the problem on... I even cycled the power and tested it with a new project... same thing... I might try a factory reset and see if that does anything...


Well, factory reset didn't work... same thing in AP mode.....

United Kingdom

Is it a new project? If not, check if you have any multi servo set up on any controls.

It could be as simple as a short between the two signal pins since they are next to each other, with it turned off is there continuity between the two signal pins?


@Rich, way ahead of you... just one script in the new project... sweeping the servo from 1 to 180... both D14 and D15 sweep even though the command was issued for D14 only... Vice versa by the way, if the command is issued for D15 , D14 parallels it... I will check the continuity in a bit.... thanks.... :)


Ok... just checked the continuity... As expected there is continuity between the power pins and the ground pins, but not the signal pins of D14 and D15... Which is strange because there is also no continuality between any of the signal pins on all the ports... That is to be expected, however. None of the signal pins should have continuity... I say it's strange because I was (as Rich noted) expecting the signal pin of D14 and D15 to have continuity which would explain my problem... but it doesn't (which is just like the rest of the signal pins).... Hmmm


May be a stupid question but have you rebooted your computer to see if that helps?

How about starting a new product?

Is this a new behavior with these two ports? Have they ever worked before?

Try looking close at the header pins where you plug in the cable. Can you see any solder that may be shorting the two circuits out? Try to follow the traces to see if there are any spot where the two short together. If you can't see anything then it's probably a shorted latch in a chip or it's shorted under the headder. tired


@Dave... already tried it on another computer... besides I tried 2 other ezbs on the same computer and they work perfectly...

This was the first time I have used this particular ezb... (yes, I have bought quite a few from ez robot...:) ) No biggie, I can live with it.... Was hoping a factory reset would have fixed it.... oh well, I can still use it with many other projects....

United Kingdom

I'm out of ideas. I don't know enough about the circuits and processor though, but I know a man who does... Hopefully Jeremie or DJ will have an idea.


@Rich... As good as EZ Robot is with warrantees it's just not worth the hassle of returning it... The only 2 ports affected are 14 and 15... I can live with it... However, any thoughts from Jeremie would be welcomed...

Thanks for letting me bounce this off of you guys...

Cheers Richard


OK, your trouble shooting show it's on the EZB and not the computer. I guess you started a new project on the new computer? Did you look at the traces and header pins on the EZB like I suggested? It may be as simple as a sloppy soldering job and there might be a spot of solder somewhere shorting the two signal pins together. I've seen this a few times. Heck, I've done it myself to board repairs. Sometimes you cant even see it. Just a simple brushing and cleaning with some spray Flux Cleaner can clear this up. If it's under the header pins then the only way to clear that up is to desolder the header, clean it up and resolder it. However this may be going farther then you want to go.

If a simple visual check doesn't show anything you may want to send it backfor a new one before spraying it with flux cleaner. That may void your warranty.


Hey @Richard R,

It sounds like a manufacturing defect to me, likely a solder bridge on the chip itself. There's current limiting resistors in series with each digital pin so they could be masking the short on the digital pin side, hence why it doesn't look to be a D14/D15 short circuit. This a very rare occurrence but it can happen. We could definitely warranty it.

But since you mentioned that you don't want to deal with the hassle of returning it, you could always take a magnifying glass to look at chip you might be able to see a solder bridge. Wish I was in your neck of the woods, then I could fix er' up with the swipe of a soldering iron. Do you have a hackerspace near you with some people with SMD soldering skills?


Lol, I was writing my post at the same time as @Dave. Great minds think alike.

@Richard R, great troubleshooting by the way


Thanks for the complement @Jeremie. It's good to be validated. :)


Thanks @Jeremie and @Dave.... Going to pop the plastics off and have a close look at it for a "solder bridge".... LOL... Jeremie, you're a young guy with better eyes (and soldering skills) than me... I'll take a crack at it..... What's the worst that can happen?... create another solder bridge on 2 other ports....:P :P


You could try carefully dragging the tip of an exacto knife between the feet of the chip or where ever you find the bridge.