Welcome to Synthiam!

The easiest way to program the most powerful robots. Use technologies by leading industry experts. ARC is a free-to-use robot programming software that makes servo automation, computer vision, autonomous navigation, and artificial intelligence easy.

Get Started
Asked
Resolved Resolved by Synthiam Support!

My Computer Has Trouble With Windows 11

Hello,

On my Windows 11 machine I cannot get anything but the EZ-Robot camera to work. Any other cameras that I plug into the computer are recognized but cannot connect. I am not able to select a resolution and then I get an error when I click "Start." The computer's built-in camera doesn't work either. (I just today updated ARC.) Am I doing something wrong? Is there a special setting for Windows 11? 

My Windows 10 machine has no issues with any camera. 

Thomas Messerschmidt


ARC Pro

Upgrade to ARC Pro

ARC Early Access will give you immediate updates and new features needed to unleash your robot's potential!

AI Support Bot
Related Content
Synthiam
#1  
Given the other issues you are experiencing with Windows 11, we recommend visiting a Microsoft location to review your computer. Synthiam does not make Windows 11, as it is a product by Microsoft. Unfortunately, we cannot support your PC's misconfigured hardware or missing drivers. You may also use Microsoft's website (the creators of Windows 11) for additional upgrade information.

Please note that we have moved your question into its thread. The hardware/driver issues you are experiencing with your PC do not relate to the Camera Device robot skill where the original question was posted.
#2   — Edited
Really? You don't make Microsoft Windows? And all this time I thought it was Bill Gates who invented EZ-Robot and DJ who invented Windows. Boy did I have that wrong! :) -:p -xD

No, it seems to be a problem with ARC. I have three different cameras. All of them work with Zoom, "Camera" (by Microsoft), and several other applications. None of them work with ARC. It couldn't be the drivers. The only camera that works with ARC is the EZ-Robot camera.

Have you tried using ARC and a 3rd party camera on Windows 11?
#3  
I haven't used a lot of cameras with ARC so I may not be a good source. However in the past when others have had the problem with cameras not working with ARK it's been an issue with entering the proper port or address that the camera is attached to. I'm sure you already have but perhaps you could re-read the camera skill manual to recheck your setup.
PRO
Synthiam
#6  
Here’s a video I found that might be easier for you to follow. Like the support response said, we don’t make Windows, so it’s tough to diagnose your computer issues. 

#7   — Edited
Yes, Windows 11's privacy settings were blocking it. I did not know that windows blocked non-Microsoft applications by default. This is the first time I have ever encountered that issue. I did not know that one could block or unblock applications from using a camera. Then again, I am very new to Windows 11.
Interesting. One more reason to dislike Win 11.

The fix was to turn on the soft switch at:  Settings/Privacy & Security/ Camera/ Let desktop apps access your camera.  

Thanks again DJ!:)


Thomas
PRO
Synthiam
#8  
I wouldn't say I like Windows 11. I don't think the privacy settings are disabled by default because it hasn't done that on any of our computers. Some schools have had issues, which is why we had to create a document to support a product we didn't even make. It's very distracting for the team when people have problems with something we didn't make. Takes away from bug fixes and new feature development.
#9  
The added security must have come in a recent Microsoft upgrade. It affected both Win 10 and 11. With my Win 10 machine, after having no issues for years, all of a sudden it started having camera issues a few days after the Win 11 machine started giving me headaches. What really perplexed me was that the EZ-Robot camera worked just fine, but all of the third party cameras were blocked.
PRO
Synthiam
#10  
The EZ-Robot camera connects through an EZB, not a USB. Their connections are considerably different.