Asked — Edited

Latest Update Wont Let Me Past Tos Agreement


I'm not able to install the latest version of the software.

I'm on Windows 8 and can't get past the Terms of Service agreement.

Here's a video example of the problem:

I didn't matter whether or not the computer was wifi connected with the board.

Thanks much,


Skip to comments


Upgrade to ARC Pro

With ARC Pro, your robot is not just a machine; it's your creative partner in the journey of technological exploration.


Just resolved my own issue. I restarted the computer which also resets my screen resolution to 800x600 (long story). And the OK button became visible. I'm not sure which of the variables caused the work around.

I think the resolution prior to that was 1024x768 which may have auto scaled that little GUI to not show the button.




If anyone else has the issue with the OK button not appearing, after checking the "I agree" box, hit your right arrow once and the (hidden) button will be selected, then hit Enter.



Hehe, someone didn't even read the first page of the agreement:) it's for your safety!


Hi Alan,

I actually tried clicking in the place of the hidden button but that didn't make it appear. My guess is that's it's was related to an atypical resolution I had previously selected combined with my non-default font size settings that threw off the auto scaling of the GUI.





I actually tried clicking in the place of the hidden button but that didn't make it appear
That is why I gave instructions for finding it with keyboard controls, just in case someone else encounters the issue.

I agree, it is probably a resolution scaling issue.



ARC Version 2015.07.13.00 Latest release shows Release notes 2012.09.07 ? New version somewhat different installation, but it installed ok and worked ok for me. No issues. Windows 8.1