United Kingdom
Asked — Edited

Jd Robot Servo Failures

Having received a JD Humanoid Robot (in U.K, via RobotShop, Paris, France) in August 2017 I have had two complete servo failures and I am suspicious of the design of other servos in this JD.

Both the Left Ankle and the Left Knee servo failed, by "jittering" backwards & forward uncontrollably. Obviously JD could not stand up with this problem.

While driven by a steady mid-range servo pulse (approximating to 90 degrees, or straight leg) The servos jittered, with occasional excursions to fully forward (which would have been commanded with the minimum pulse width of approx 0.55mS, except the pulse was stable and not calling for an extreme position).

The servo drive pulse was stable and constant at about 1.3 mS, and it was a very clean signal with no "noise".

I have examined a couple of other servos from JD which do not have this problem, but they both show features which I have never seen on other servo makes.

When being driven, by a slowly varying pulse train,  from limit to limit, both Servos performed ok, moving smoothly,  but I noticed two "odd" things.  When being driven both Servos took about 0.25 ~ 0.45 Amps (at 5V) while moving, which dropped to Zero Amps when the commanded position was reached - as normal & expected.

However, when either servo was driven to the Maximum Pulse width Extreme limit, i.e. nominally 180 degrees  (approx 2.4 mS pulse width) the current suddenly rose to 1.2 Amps (overloading my PSU) and stayed there as long as this extreme position was held.  Needless to say I did not hold this "very unhealthy" position for long !

Also, quite often, as the servo reached this (max-pulse-width) extreme position it started to "jitter" back to the other extreme position (min pulse width) even though this was un-commanded.   The servo control pulse width stayed constant and "clean" so the servo should just have stayed at the max-pulse-width extreme position as was commanded.            
I have never had any of this behaviour from any other servos and, in fact, over several years, I have never had a servo fail me.

I have now arranged with RobotShop to return this JD Robot and they will send a completely new model - I hope this works O.K.


Upgrade to ARC Pro

Join the ARC Pro community and gain access to a wealth of resources and support, ensuring your robot's success.


If the servos read HDD, then the jittering has nothing to do with the pwm. It is a defective POT inside the servo. Enjoy your replacement jd! And apologies for the servo issue.

If the servos read HD, they were discontinued and old stock.

United Kingdom

My replacement EZ-Robot JD has failed in the same way as the first one !

Apparently all the servos were QC checked before delivery.

I assembled him as per the Ez-Robot website information and videos.

I checked, where possible, that the servos were at mid range of their travel when in the "straight arm or leg" positions, so they did not need  manual alignment  as-delivered they were very well positioned.

He was then powered up and connected to the laptop wifi.

He straightened up very well.

I then clicked on "Configure" to fine tune the ankle and leg servos.

After minimal tuning he stood up well.  I was about to try a Bow or Wave.

Then, suddenly, his Right Upper Leg servo (Which had been randomly chosen during assembly) drove the leg fully forward and the Right Knee servo (attached to the ankle) also drove fully forward.  Thus his Right toe was touching his chest.

I switched off and tried again from scratch - same result.

I tried to bring the legs back straight with "Configure" but this did not work and I noticed that the servos and their cables were getting hot (probably the same high current issue mentioned in my first post, above), so I stopped !

I then stripped JD down and tried a "good" servo on it's own, connected singly to the EZ-B On-board computer.  The servo worked OK when driven from D4 and from D16 & D17, thus the fault is definitely in the failed servos.

Driving the "good" servo, with a "scope" in circuit and using "Configure", I found the following (which all looks satisfactory) :-
    Full Over one way : +84 : Pulse 2.1 mS
    Central           : +0  : Pulse 1.35 mS
    Full other way    : -94 : Pulse 0.56mS
However, the "dud" servos were driven to Full deflection with the initial (straight-leg) "Configure" pulse width of 1.35 mS and responded very irregularly to "Configure" inputs.  

I must come to the conclusion that, in spite of the QC checks before delivery, the faulty servos can suddenly fail while in early use.  These two lasted less than 10 - 15 minutes from initial switch-on.  The servos on the earlier JD lasted about 20 mins and about 1 hour before failing.

With the First JD I was able to demonstrate him walking, talking, bowing & waving to some school-children and to a couple of toddlers (who were fascinated) and he, mercifully, did not let me down in public.

However, I bought JD primarily to demonstrate to schools and children and he does not reliably fulfill that role.

Sadly, since I am very impressed with JD when he behaves, I shall have to look elsewhere for a humanoid robot.

JD is being returned to RobotShop, for a full refund.



seems like you did not the calibration off all servo's first?

United Kingdom

The servos were very well set up on delivery - as I said above :-

<< I checked, where possible, that the servos were at mid range of their travel when in the "straight arm or leg" positions, so they did not need manual alignment as-delivered they were very well positioned. >>

With the first JD one or two servos needed manual setting to the "90 Degree" position, but with the second one the alignment was very good after "Connecting" - at which point he "jumps" into mid position.

Then after clicking "Configure" , and then "Reset" he aligned very well and needed minimal adjustments to get his feet flat, etc. He was standing very well when the two servos suddenly moved.

As also noted above, I then found that the two "dud" servos could not be driven properly through their range of movement, while a "good" servo could. The "dud" servo characteristics had certainly changed and they performed totally different compared to the many other servos I have used.


Man, that's terrible to hear the replacement servo was suffering from the same issue. With a few other similar responses, as per my previous email, the pots in the servo are defective. This is happening at the manufacturer level and our support team is handling it with them.

thanks for your patience! The woes of pushing technology:)


each computer is diff.you need always calibrate all your servo's on your pc. its not good to calibrate only two servo's,you only chift the problem to , another part of the robot.

United Kingdom

I wonder if it is really the Pots.

When the FIRST JD played up I replaced a "dud" HDD servo with a similar ModelCraft servo which I had spare. This worked fine, until another HDD servo elsewhere in JD died and I hadn't any more compatible spares..

I then dismantled one of the "dud" HDD servo and isolated the pot, because I thought that was the problem. I found that the pot seemed OK, with progressive resistance throughout it's range, and no obvious "noise".

On re-assembly the servo was still "dud", in that the "90 degree" signal still sent it to full "90 degree" travel and the current went through the roof.

Inside the servo was an IC, maybe two, I can't remember and I wonder if this had died rather than the pot.

Even the "good" servos worked differently from other servos I have used - in that when approaching 180 degrees they often started to jitter all the way back to 0 degrees, and if held at full traverse they suddenly pulled a high current. You can see this "jittering" on the videos I sent to RobotShop Paris (France)

It is all a great shame since I think JD and his software is superb - but not reliable. He's going back to Gay Paree.


Hi @RogerR,

I was part of the HDD servo investigation and I can definitively say that the potentiometer is the cause of the issue that you are seeing. You likely will not see this issue by simply doing an resistance measurement as you sweep the servo, it is a bit more difficult to isolate then that. As @DJ mentioned we are working very hard with our manufacturer to remedy this quality issue that affects certain servos in our last batch of HDD servos.


@Jeremie... Oh Lord... I bought 20 HDD servos a month or so ago from Robotshop.ca.... I haven't tested all of them but here's hoping they weren't part of your last batch... eek


I have purchased the upgrade kits (HDD Servos) for my JD and Six. I only tested the 2 NEW HDD JD Shoulder Servos, one jitters, and one is fine. Will try to test the others this coming week.


Contact us and we'll make sure your jittery or self moving servos are taken care of