Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Introduction And First Question

Hi my name is Dani, I'm from spain and I'm studding for a degree on electronics, but I always love robots, and now I'm trying this amazing board. I just build my first robot whit this board. I'm controlling 4 motors whit the H-bridge, 2 servos X and Y axis for camera. Just and easy and fast build. I'm also controlling the robot from a joystick. But when I add the servo for de ultrasonic sensor and the ultrasonic sensor, the boards start failing, now when I connect the ez-board whit the computer and start de radar scan, the led on the board stop working, and auto disconnect from de computer, I don't know what I'm doing wrong, pls help.
The servo for the ultrasonic sensor is connected on the D7, and work whit the horizontal servo (it moves nice). The trigger port on D19, the echo port on D18, and vcc on a vcc port, and ground on a grout port
Thx for the help.
If you need more pics or info pls ask

User-inserted image

AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
United Kingdom
#1  
Sounds like a brownout. Is your power supply man enough for the demand? Are the regulators getting hot?
#2  
Thx for the reply, it's the first I thought, but I recharge the batteries and try again and nothing, I'm using a 6 x 1.2V batters and each battery have 2100mAh I thing should be enough, but I'm not sure, better try to buy more batteries?
#3  
Still sounds like a brownout. All of the items are drawing too much power from the board. Is your H-bridge getting it's power to drive the motors from the board or directly from the batteries? They should be getting it from the batteries. Likewise, I would recommend powering your servos from the batteries rather than the board.
#4  
Thx to all, yes the h-bidge is getting power from the batteries, but the servos from the board, but there are just 3 servos, ok I will try that

If I power the servos from the batter directly, the batteries must power 5V, not more?
Spain
#5  
Dani Greetings and welcome, I too would that sound to a power failure, the same happened to me when trying to run a high torque servo directly from ez-b, once independent supplies power to servo the problem was resolved. Try feeding ez-b with a 12V battery or power supply to see if the problem is the battery. You could also have a servo to consume more than usual and causing the problem.
Certainly we are neighbors! area that you live? I am in Palma de Mallorca.
#6  
Ok, I will try that, and post when I finally get the problem, yes I'm from spain-cataluña-tarragona so more or less yea we are neighbors!
#7  
hi again, I have try to disconnect everything from the EZ-B, then connect only the servo for the ultrasonic sensor(is a mini servo, so not a lot of power) and the ultrasonic sensor, at happens the same, when I turn on the Radar scan, auto disconnect and led turn off.
Not working the Ultrasonic sensor? Connections are bad? Or what happens?
Thanks for the help
Spain
#8  
Have you checked if the ultrasonic sensor is heated? I have one that is broken is very hot high consumption, although, is not raised off ez-b because when I disconnect it immediately proven.
You can try to start the radar if not servo assigned to your port or disconnected from ez-b, so we can dismiss the error between the servo and the sensor.
#9  
Ok I have tried to start radar whit no servo, and same error, so error between servo and ultrasonic discarded. And no, the ultrasonic sensor is not hot, but he don't have no time to heated, because turn off in no time.
But likely ultrasonic sensor is broken? It's new.
I try to buy a new ultrasonic sensor?
A lot of thanks for the help
#10  
Dandelion,
You may want to check the wires going to the sensor. The terminals might have bent and they are shorting out, or it might just be wired incorrectly.
Spain
#11  
If you have checked that the connections are correct, and that the sensor is not touching metal anywhere, then it could be a faulty sensor. I found this offer very cheap sensor:HCSR04
United Kingdom
#12  
I too would say to check the connections on the sensor.

User-inserted image


Ensure no shorts. Most do this by using heat shrink sleeving over the pins on the sensor.
#13  
ok finally work, I check the wires connections and they are correct, but I changes the echo and trig port, and works now, for what I see in the tester, the D18 and D19 pin don't works correct, but I'm not sure of that.
Thanks to all for the help
I hope I can put a video of the robot son
United Kingdom
#14  
Ensure you had D18 and D19 connected correctly. Ground (darkest wire, black or brown) towards the chip, Signal (white or orange) towards the edge of the board.

Also ensure you haven't shorted the underside of the board on anything.

D18 and D19 should work fine.
#15  
Sensor is working great thanks to all, and don't understand why doesn't work when I use D19 and D18, but if I use D15 and D17 yes, I try de D19 and D18 5 timesXD

Really thanks to all