Welcome to Synthiam!

The easiest way to program the most powerful robots. Use technologies by leading industry experts. ARC is a free-to-use robot programming software that makes servo automation, computer vision, autonomous navigation, and artificial intelligence easy.

Get Started
Asked — Edited

I Resolved The Problem

can't upload code to Arduino

Ever since I used the esp32 (and it worked well)  this is what I get when I try to upload a file to my Arduino:

Keeps saying I am using the esp32 when I have the Arduino plugged in the usb.

Arduino: 1.8.13 (Windows 10), Board: "DOIT ESP32 DEVKIT V1, 40MHz, 115200, Info"

Has this happened to anyone?

Related Hardware Esp32 DevKit v1


Upgrade to ARC Pro

ARC Early Access will give you immediate updates and new features needed to unleash your robot's potential!

AI Support Bot
Related Content
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
The manual here says sometimes you have to hold the boot button for some reason. I recall something like that happening with the esp32 before. 

User-inserted image
#2   — Edited
I believe I fixed it, working now

for Arduino, just upload an empty file, the click the reset button to restart the Arduino

might work for other controller that get plugged and don't work :-)