Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by DJ Sures!

Help On Recovering From A Stupid Moment On The Ezb

I got my head all back together and the neck, etc. I have a battery going through a 640 ohm resistor to a female extention plug. I plug this in to test the LEDs. Each one worked very good but one did not. I checked reverse polarity on the circuit and the LED worked. I did not want to take the head all apart again (hassel). So , I simply turned the plug around not realizing if i were hurting something or not. But, it did not seem that it would damage the EZB because I was simply swapping ground and signal. I can't see very well, I may have plugged a plug in shifting one pin over. that would connect ground to hot or signal to hot.

Anyway, boiling it down, All of my digital pins do not work anymore.

Any ideas? I am thinking voltage regulator blown, I hope it is not the cpu. I am going to run the test that D.J. has and try to figure it out. The lights blink red and blue and it connects up. So , the bluetooth is working.

Wish me luck.

AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
#37  
@mel go ahead and replace the regulator. Testing components that are going bad or are damaged can result in erratic malfunctions. Do the suggested repairs then go from there:)
#38  
Thanks, Josh. The factory has said that they would repair it and will give me an RMA. I am affraid that if I try to fix it, they will not work on it after that. But, there is the waiting thing. I hate to wait. I am the worlds most impatient man. I can help it. I am wired this way.
#39  
I just found out something else. The cheapest shipping with a tracking # =$25.17. I am not going to pay over $50 to have it repaired. I may try those regulators.
#40  
Hi Mel,
Totally up to you, however we will not repair the board after someone else has altered it in any way. If you are confident in your abilities, that would be the cheaper way to go.
#41  
@mel that's why you should keep a spare board ! Lol I'm impatient to the max so I understood. I would suggest you let mark ( or appropriate representative) get the board repaired for you. This way there is no guessing and you know it's 100 percent repaired.
#42  
@jstarne1 Ha ha, no way I will be touching that board! The goal is to get it fixed, not turned into a permanent paper weight!
#43  
@ Mark , Sorry! Lol I haven't had much interaction with you since you came aboard EZ-Robot so I wasn't sure of you role. Epic soldering skills might not be on the resume :).

@mel I mean if you can send it in the the factory I would do that.
#44  
It costs too much. Unless you want to put a downpayment on your turtlebot.
#45  
@jstarne1 Im strictly on the business side... more then likely it would be Jeremie.
PRO
Canada
#46  
Ohhhhh noooooo, don't tell them my real name.....my secret identity will be revealed!:D
#47  
@mel have you already ordered/ purchased the voltage regulator?
#48  
I have ordered the new version4. I plan to get the regulators at radioshack today. I hope they have both of them.
#49  
OK, I ordered the Lm1084 IT 5.0/NoPB.

When I do a search for the %A LDO POS REG, it puls up the LM1084. Am I missing something? or are they the same chip. It seems like they have a different pinout. I need the part # to the VR2.

Thanks,

Mel
#50  
Nevermind. i got the numbers mixed up. I do that a lot now.
#51  
OK, we can close this thread because EVERY Port is working now. As it turns out, after replacing the two rectifiers and the diode that all I needed was to take the cpu out and put it back. I am SO Happy. I was getting EZB withdrawals.
:D
#52  
Yeah, but did you not do that once already and it only worked briefly?
#53  
Yes, that is true. But I did not completely remove the cpu. When I did, I felt something like metal fall out of the socket area and fall to the floor. But, I couldn't find it. You have a good memory. Better than mine.
:D
#54  
Well, cross your fingers and lets hope it works permanently for you this time...;)