Asked — Edited

Help Needed With Cognitive Emotion Plugin

I have downloaded and installed the new Cognitive Emotion plugin and configured it as per the instructions. How do I use it? I have the camera on, should the camera image be in the control? When I click on the 'Describe Image" tab I get a popup that says 'The camera is not active'. This is what my control looks like with the camera on and working.

User-inserted image



Upgrade to ARC Pro

Stay at the forefront of robot programming innovation with ARC Pro, ensuring your robot is always equipped with the latest advancements.


Activate the camera. The control works with the first camera it finds. How many cameras do you have.


I have 2 cameras, I need the control to use the one I had activated.


I had a similar issue and i had to actually deactivate my internal camera which i did through the bios at startup Not even sure why that is but it worked. I imagine there is a more elegant solution but quick and dirty worked :)


By internal i mean laptop built in cam.:D


Could you give an example of the code you used for that. Thanks


Sorry i think maybe i explained that badly. It didnt require any code. What i did was a reboot of my pc into my startup bios or basic input output system(usually by pressing F2 when computer first powers on and if you have a built in cam then you should be able to disable it in there before even starting windoze. Now when you log into winblows that camera will not be usable. You can easily re-enable it the same way if needed. After that it just worked by automatically attaching to the 1 camera i still had enabled. The reason i say its quick and dirty is because its a bit annoying if you want to use the disabled camera for other work then you will have to repeat the process to enable it again. It only takes a few seconds but you will have to do a reboot each time you turn it on and off. You may even be able to simply disable the camera you dont want to use through Windoze device manager but i just like using the bios option when i can because it ensures windows will not somehow load or enable the device.


Have you worked with or are familiar with your pc bios? I should have asked that first. :)


Thanks for you help but it turns out that there is something wrong with one of the cameras on my robot. I delete that camera control and this control is working now. It would be great if the user could select the camera for the control to use. In my case it use attempting to connect to a camera mounted on the back of my robot and I needed it to attach to the one on the front.


Interesting, it seems we are having a similiar problem but for different reasons... my solution was probably overkill if i simply needed to remove the control lol im certainly no ARC expert so you may have actually helped me :D and yeah being able to choose the camera would be super convenient. Very cool updates though , my inmoov is an apparent genius now with these latest microsoft plugins :) completely blowing the minds of friends and family.


Yes, these new controls are great. I've also been playing around with the Vision one as well. Lots of fun.