Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Firmware Update Question

Hi DJ & EZ-Robot community,

I have a problem with the firmware update. I got back the following error message below:

Attempting connection on COM6
Connection Failed: System.IO.IOException: The semaphore timeout period has expired.

at System.IO.Ports.InternalResources.WinIOError(Int32 errorCode, String str)
at System.IO.Ports.SerialStream..ctor(String portName, Int32 baudRate, Parity parity, Int32 dataBits, StopBits stopBits, Int32 readTimeout, Int32 writeTimeout, Handshake handshake, Boolean dtrEnable, Boolean rtsEnable, Boolean discardNull, Byte parityReplace)
at System.IO.Ports.SerialPort.Open()
at EZ_B.EZB.Connect(String hostname, String tcpPassword)
Disconnected

My system is a Windows 7 / 64 bit PC, I'm using latest ARC version 2013.01.05.00. I changed my bluetooth to windows bluetooth stack.

Please help me because this kit is a christmas gift to my stepson.
Thanks from Norway

AI Support Bot
Related Content
Synthiam
United Kingdom
#1  
Have you followed the tutorial?

All we can really tell you is what's been repeated in previous firmware related posts.

If none of that solves the problem, copy the debug message from the firmware upgrader and use the Contact Us page to send it to EZ-Robots.
#2  
Hi RichMR2, Of course... I followed the tutorials. I tried to fix it, but I couldn't do that.
#3  
Rich is correct, the tutorials are explicit. you need to check battery voltage first. as in the tutorial check blinking lights...it seems the com ports are NOT connecting....and reboot.....persevere
#4  
Hi irobot58 and RichMR2,

My test results are the following:

- Battery voltage 9,1 V (6 x 1,5V AA Varta)
- I have tested the EZ-B v3 Bluetooth Robot Controller with Digital Multimeter according to the tutorial video and everything was ok!
- Blinking lights are working good (blue light fast pulsing, red also pulsing fast)
- I have changed my Bluetooth stack from Broadcom to Microsoft Generic Bluetooth Adapter.
- The com port is the 6
- I have changed the COMPORT many times, but not worked
- I have reinstalled the device, but not worked

I have Microsoft.NET Framework 4.5

What can I do now?
#5  
Dang!....unless someone else comes up with another suggestion ...it may be time to http://www.ez-robot.com/About/Contact-Us.aspx "Contact us" as per RichMr2...at the moment I too have an email into support , regarding a defective continuous servo( black and red wire shorted inside) ....but meanwhile you can do a lot of preprogrammng regarding VoiceRecognition! Before my EZ kit arrived a put in 4 weeks of VR chat script! 7 days after ordering, it arrived!:)
#6  
Contact us is meant for hardware related issues where an exchange is needed. Help with software installation and bugs is here in the live forum. ;) fast blink on red led with Bluetooth sounds like its not connected to the Bluetooth dongle. That would explain why you cant connect the port. Which dongle are you using?
#7  
Hi Jstarne1,

I am using a Samsung RV520 laptop. Inbuilt bluetooth adapter.
#8  
The built in Bluetooth probably has a custom driver installed from samsung. You can try uninstalling the factory drivers and let windows use the default Bluetooth stack and drivers. This is not the first time ive seen built in Bluetooth modules have connection problems. - Josh S
#9  
Ok Josh, I try to follow your suggestion... I will report you couple of minutes later...
United Kingdom
#10  
as Josh said, flashing red bluetooth light means it's not connected. Once it's solid red it's connected.

Also, I believe DJ updated the firmware upgrader today to fix an issue some were having that hadn't cropped up before, download and install the update and see if that's of any help.
#11  
Hi Rich and Josh,

Thank you for your efforts. I was lucky because today I have checked Kalinox posts. He posted in yesterday. DJ Sures solved the problem. Just I realised in Kalinox posts. He is Canadian-French. I am Hungarian, but I live in Norway. We also use comma insted of . in our culture as the french culture. And DJ Sures posted in a print screen how can we change this setting. Holy Ghost... Update sucessfull. Everybody is happy after 3-4 frustrating days.

Thank you again in my stepson name. He can turn his energy to build up a robot. :-)
PRO
Synthiam
#12  
Awesome to hear! Thanks everyone for helping him out:D

The latest release will warn if the decimal digit is not correct.