Welcome to Synthiam!

Program robots using technologies created by industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation, and artificial intelligence easy.

Get Started
Asked — Edited

Error Message - System.Exception: Cannot Find Frame With Guid:

What do I do about the following error message?

System.Exception: Cannot find Frame with GUID:

at EZ_B.Classes.AutoPositionConfig.GetFrameByGUID(String GUID)

at EZ_Builder.UCForms.FormAutoPositionerOptions.p4d9pryZSTg(Object , EventArgs )

at System.Windows.Forms.Control.OnClick(EventArgs e)

at System.Windows.Forms.Button.OnClick(EventArgs e)

at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)

at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)

at System.Windows.Forms.Control.WndProc(Message& m)

at System.Windows.Forms.ButtonBase.WndProc(Message& m)

at System.Windows.Forms.Button.WndProc(Message& m)

at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)

at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)

at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

PRO
Synthiam
#1  
We need more information
#2  
What information do you need? My students are trying to create new Frames and Actions for the JD robot. When they click on the Gear icon to create new frames and actions, that error message pops up and won't let them. We have tried restarting the software to no avail.
PRO
Synthiam
#3  
Can you post the JD project that you're using which causes the error? Because this error doesn't appear for the standard JD project, or any of our test projects, we need more information to diagnose and assist.

Use the ATTACH FILE button when responding to this message to attach the .EZB project which creates the error. I'll take a look right away.

In the meantime, are you having the same challenge with the official JD Example Project files?
PRO
Synthiam
#4  
Wait - someone came to me and explained that you might be pressing "NEW FRAME" without actually selecting a frame.

Is this the case? Are you pressing "NEW FRAME" without having a frame selected?

I'll have the message updated for a future release. In the meantime, you need to select a frame from the list before pressing new frame button. That way, the frame is built off the current frame selected.

Here's a great tutorial for your class - where they can teach JD to dab. This way, you also learn how to use the Auto Position at the same time. Check it out here: https://www.ez-robot.com/Tutorials/Lesson/97
#5  
We tried it with a frame selected and without a frame selected. Got the same error message. I am attaching the file that went with this error message. It is happening on another computer, as well. I'll send it separately if need be.jd4-problem1.EZB
PRO
Synthiam
#6  
I'm having trouble reproducing the error by clicking and selecting a frame before editing. See this video and verify these are the same steps you're taking?

#7  
Yes. These are the same steps we’re taking. That’s exactly how I teach the process. Is it possible the software is corrupted somehow? Should I uninstall and reinstall the software?
PRO
Synthiam
#9  
Can you verify the software version is the same as my example? 2018.11.18.01
#11  
Yes. Confirmed version 2018.11.18.01
PRO
Synthiam
#12  
I'm struggling with this - because I can reproduce the error if i don't select a frame from the list before pressing New Frame. But I can't reproduce this if I select the frame from the list first. See this video..