Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.
Get Started

Asked — Edited

Emic Text To Speech

I just got the Emic text to speech and I was trying to use the command SendSerial to communicate with it but with not luck. Can somebody help to figure this out?

Thanks

User-inserted image




Documentation

AI Support Bot
Related Content
Synthiam
Synthiam
#1  
It works great, but there is a bug in SendSerial that is fixed for the next release. So, it may not work for you until the next release. The Example Project called Robot K-9 includes an EMIC 1 module.

Here is an example of EZ-Script for the EMIC 1 speech module.. I'm unsure of the difference between the EMIC 2 and EMIC 1, but the Documentation you posted should tell you how to use it:)

Code:


sendserial(d0, 9600, 0x00, "Hello Master!", 0xaa)
#2  
@DJ, I am trying to use sendserial today and it's just not working. I have tried both an EMIC and EMIC 2, when I use the following in a EZ-Script sendserial(d0, 9600, 0x00, "Hello Master!", 0xaa)

the ez-controller resets itself, I have also tried 2 EZ-controllers as well as different power supplies.

Same thing is happening with my LCD now too since the last update.

Any ideas?

Thanks
#3  
@DJ some testing and I think there's an issue when you use for example "Hello World", it seems if you use more than a few characters eg "D1" for example works, but anything longer it seems to crash the ez controller.
Canada
#4  
@Charleybot In your above example are you sending the text "D1" or are you referring to the digital port number?

Also, how are you powering the EMIC? I see it takes 5v, but if you are powering it directly off the EZ-B then any EMIC issues or longer power drains feeding a speaker may be causing a brownout on the EZ-B.

Of course, this is just a guess based on the little info listed here.
#5  
@Gunner Sorry the exact commands I am using are:
SendSerial(d0, 9600, "sHello World")
and
SendSerial(d0, 9600, "sD1", 9600)

anything with quotes with the exception of the letter s is what is supposed to be spoken(s means say the following)

The specs on the EMic2 which is what I am now testing with
Power requirements: +5 VDC, 30 mA idle, 46-220 mA active

I also tried a separate power supply with the same results, even though the drain shouldn't even phase the EZ-B, even re-checked wiring, grounds, and there's nothing else hooked up to the EZ-B with this testing.

The same issue happens with a serial LCD.
#6  
I have created an interface, in c#, for the EMIC 2 a while back. The problem I ran into is that sending full length strings can actually create problems on the Emic's processing. I fixed it by chopping longer lengthed strings into their chars and sending them seperately. I have no problems and have had it working for a long time. However, now a days I just pop in and read about. You can find it on page two : Click Here
Canada
#7  
I'm having issues with sendserial myself.

I can only send short phrases to my LCD, then it get's all garbly and
then the EZ-B resets and I have to re-connect.

Spent hours trying to figure out what I was going wrong.

Hopefully this gets fixed soon. I'm shining my DJ spotlight into the sky
now.
#8  
@orwnic82 - I Like the #C interface you built! Thank you for the idea but unfortunately it's something with the EZ software. I cannot basically send more than one word at a time and in testing both of my EZ-B's will crash, sometimes where I have to even power them down because it seems like they get stuck in a loop or just lockup. I also program other MCU'S, both PIC and Parallax Propeller, using either the EMIC2 works great with them.

Using a Parallax serial LCD, same problem, more than one word and the EZ-B locks up.
Canada
#9  
Here is a shot in the dark:P It almost sounds like issue with the SPACE character code... try just punctuation with no space, like a comma perhaps?
#10  
Gunner - LOL! I spent like 6 hours trying different combinations, that was one of them, I can use one word like "hello" but "hello world" locks up the EZ-B, even "helloworld" or "hello,world", I started thinking it was the length of words, but there's no pattern with that, something with the sendserial strings in ARC.

Even the LCD like I mentioned before has the same issue, i'm sure it's a simple bug that DJ will have a fix for in notime, but for now I had to resort to another MCU for the time being...
Canada
#11  
Possibly just hates multiple syllables so I guess "supercalafragalisticexpialadoshus" probably won't work either:P
#12  
LOL that could be it, i'm suprised I missed it though last week with the LCD module...