Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Down, But Not Out-Bing Question

Down, but not out-Bing question
Missed a step carrying a box to the basement, broke my Tibia and Fibula bones, later developed severe Gout in both feet, twice. Titanium plates and screws.
Maybe the pain pills are affecting me, but I can't get the Bing plugin loaded to my project.
The cognitive vison and emotion plugins load ok on my project.
I enabled the Bing Speech, but can't get the plugin to load enough to even load the key.

"Error loading the DLL required for this assembly plugin", DDL Assembly Resolve plugin Error.
System , IO, FileNot FoundException: Could not load file or assembly Speech Client.dll'
Error loading Control: Microsoft Bing Speech Recognition
---------------------------
System.IO.FileNotFoundException: Could not load file or assembly 'SpeechClient, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The specified module could not be found.File name: 'SpeechClient, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null' ---> System.IO.FileNotFoundException: Could not load file or assembly 'SpeechClient.dll' or one of its dependencies. The specified module could not be found.File name: 'SpeechClient.dll' at EZ_Builder.FormMain.FNYobvl9GJ(Object , ResolveEventArgs ) at System.AppDomain.OnAssemblyResolveEvent(RuntimeAssembly assembly, String assemblyFullName) at Microsoft.Cognitive.Recognition.FormMain.SetConfiguration(PluginV1 cf) at EZ_Builder.FormMain.tZZoICNBwo(ConfigurationFormV2[] )

I have made sure the Bing plugin was associated with the plugin loader as mentioned in another thread.
I have uninstalled EZ Robot and reinstalled, rebooted laptop several times, maybe I am missing something, latest version of EZ Builder.

User-inserted image

:(

PRO
Synthiam
#1  
Ouch man - that's terrible! Glad you're still in good spirits though.

I guess you have time to upgrade your computer to an operating system from this decade:D Windows 7 is not supported by microsoft for the plugin you mentioned. Upgrade to Windows 10, it rocks

Heal up! If you need a robot body replacement, let me know:D

Also, due to the number of issues with Windows 7 support, we're discontinuing support for it in the next release of ARC. You can still run ARC, but there will be a message stating that it isn't directly supported and not guaranteed to be stable. Time flies man!
PRO
USA
#2  
D.J.
Thank you, I need a body replacement for sure.
I think my laptop was Windows 8.1 prior to update.

User-inserted image
#3  
I am getting a error too.
Hope I'm not making a silly mistake somewhere?

Windows 10 Pro here.
Latest version EZB.



User-inserted image
PRO
USA
#4  
I was on windows 7 64 bit and upgraded to 10 home edition on one laptop and error went away.
PRO
USA
#5  
Will,
Thank you for responding, maybe I will try on my windows 8 little Acer W3 tomorrow.
Your video was great with Alan, made me want to try it!
Australia
#6  
I had the same issue on windows 10 Pro, managed to get it working by installing Visual Studio 2015
#7  
WOW Steve, Not a good landing !

I will get my 3D printer set up and take care of your issue.... Just send me the .stl files..

I am hoping Win 10 Home will do the job. I have to buy it then install it too.

Heal quickly,

Ron
#8  
I think @nick777 may have hit on something. If installing VS2015 fixes it, there must be a missing dependency for the DLL that is included in VS2015. I already had VS installed on the machine that I was testing with last night, but I will install on a Windows 10 machine that doesn't have it tonight or tomorrow night and see if I can duplicate the issue.

Alan
#9  
Solved!

Just loaded Visual Studio 2015 and all is good :).

Thanks nick777
#10  
Edited to remove fix that didn't fix....

Alan
PRO
USA
#11  
Fob,
Looks like same error, glad to hear nick777 's idea adding Visual Studio 2015 worked for you.
nick777,
Thank you sharing how you overcame the error.
Ron,
I will ask Doc for .stl files tomorrow, thank you for your comments.
Alan,
Thank you for trying things on your other windows 10 machine.
I will eventually try adding Visual Studio 2015 or Visual c++ Redistributable Package if I have too.
Today I tried updating Netframe and it said I have 4.6.1 or newer, update not required.
I also installed ARC on my wife's Lenova ThinkPad that came new with windows 10 already on it, but I realized same error.
Thank you everyone for trying to assist me.
I agree that Bing Speech, Emotion, and Vision features will be a game changer, and improve our robot projects immensely!
Steve S
;)
#12  
I am not able to load the plugin on my Win 10 Home ,Toshiba laptop. I have Visual Studio C++ Redistributable Package installed. I will check for C++ again anyway. I will wait until you guys figure out the problem.

Ron
#13  
Ron, when you loaded the redistrutables, did you do the right packafe for your system? Use the x86 for 32 bit machine x64 for 64 bit machine.

If that doesn't solve it, install Visual Studio 2015 Community Edition. It is free

That absolutely will fix it.
#14  
I used x64. OK, I will try Vis Studio '15. I will let you know how I make out.

Thanks,

Ron
Australia
#15  
Fob,
great to hear it worked out for you

Steve S,
just happy to be able to contribute something to such a great community

Andy,
as Ron suggested try installing VS 2015, I originally tried the C redistributable package first with no success
#16  
Ok, I loaded Visual Studio and the plugin is loaded and works fine.

Thanks to all who helped.

Ron
#17  
I edited my earlier post. The VS redistributeabkes got me past the first error, but the error on closing was not microphone related, so fix for now is to install Visual Studio. Hopefully DJ will figure out the missing dependency and issue a fix because I don't think I have space on my tablet for VS.