Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Controls Missing From Projects.

Can anyone tell me why I am losing controls from my project when I save it. I have created the same project 3 times now and each time I save it to both my hard drive as well as to the Cloud, some of the controls seem to vanish.

I created the project for the third time yesterday and it had mp3 Trigger and 6 of the servo contols and I saved it to both my hard drive using the save as and gave it a new name and saved it to the cloud as well.

When I opened it this morning, the only thing in the project was the mp3 trigger and one of the servo controls.

Can someone tell me whats happening to the rest of the controls.

Dan S.

AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
United Kingdom
#1  
Can you post your project file or make it public on the cloud? It'll make more sense if I/we can see it.
#2  
Rich: I will have to recreate it again, as the only two of the controls left are the MP3 Trigger and one of the servo controls. Once I get it rfecreated I will save it to the cloud.

Dan
PRO
Synthiam
#3  
After you modify a project, you still have to save it.:) Remember that when a project is altered after it has been saved, it needs to be saved again. Watch for any errors or messages after the saving process - just in case it didn't save. It would be impossible for controls to not reload after saving. Good luck!:D

PS, remember to save locally also. Always a good idea to have a backup
#4  
Rich: I just saved the File to the cloud. It is called "Mind Munchie Rev4" for the Children's Museum of Houston.

It should have the MP3 Trigger, Robo Claw H-Bridge Movement control, Modified servo Controls for Right Arm, Left Arm,arms center, Open/close Eyes, and Move Antenna.

Thats what should be in the file that I saved.

I still need to add the wrist controls but that requires a second H-Bridge which is the 4-Wire H-Bridge listed in the controls, plus I need to add the viceo camera controls.

Dan S.
United Kingdom
#5  
In fact, after you save it but before you close ARC, open up explorer and find the save (my documents, ARC) Right click on the save and choose properties. And make sure the modified date and time match when you last saved.

User-inserted image


If they don't it hasn't saved it.
#6  
DJ: I have saved it both to my local Hard drive as well as to the cloud several times and when I closed down ARC is asks if I want to save the file and I say yes, and still all of the controls are not in the file when I reopen it.

Dan S.
#7  
Rich: I did as you suggested and saved it again using the save as and then went to check the file. It saved it, but it is only 7KB in size. It should be larger than that I would think.

Dan S.
#8  
Rich: I opened a new Windows screen and started a second ARC and opend the saved file and only three of the controls show up. Robo Claw, Center Arms and Right arm. The rest have vanished.

Dan S.
#9  
DJ and Rich: I have saved the file 3 times now, Once to my Hard drive, One to the Cloud, and once to a Thumb Drive. Each time when I open the file for any one of those locations, It still only shows three of the controls and the rest have vanished. The file size is only listed at 7KB when it should be much larger.

Should I delete ARC and re-install it?

Dan S.
United Kingdom
#10  
You're right, you have a problem...

DJ may need to look at it since it's beyond me. But;

The file only shows the controls you mentioned.
When trying to merge it with a new file all controls are listed but selecting all only imports the ones previously mentioned that load on open.
All controls are in the save and the XML looks ok to me but I haven't much clue what to look out for (all I know is that saves are XML based - because I'm nosey like that).

@droidmech2002, what happens if you open a project from the cloud, save it locally, close ARC and then try to open it from your hard drive? There are a few projects on the cloud from me (click user details below my name/pic on the left), the Dagu one has a lot of controls... make it easier, click here to download it

I'm probably going the long way about it, have you tried re-installing ARC? Something somewhere is screwing up the save files...
#11  
Rich: I opened up a second ARC program, downloaded your Dagu file by clicking on your link above. It loaded fine I think. It has a lot of controls for 4 wheel drive, plus flux capacitor, custom movement, Port summary. I then saved it to my Thumb Drive Then closed down the second ARC. I then open a new ARC and loaded your file and it looks like everything is there.

This really has be baffled as to why it is not saving my files.

I think I am going to uninstall ARC and re-install it and see if that takes care of the problem.

Dan S.
United Kingdom
#12  
I'll tell you what... it's a glitch.

I just started a new project. Added the sabertooth hbridge, a few modified servos, a couple of horizontal servos and the mp3 trigger. Saved, closed and opened it and half the controls don't show...
United Kingdom
#13  
OK, solved... kinda... Cause found more to the point.

Adding more than 1 modified servo control will cause the project not to load correctly after saving.


In the meantime, set up the project without the modified servo controls.

What do they do? Chances are there is a work around the problem.
#15  
Rich: glad to know it is not just me, as I un-installed ARC, then re-installed it. Loaded up one of the old versions of my program. added the missing controls and then saved it. Closed down ARC and the re-opened it, loaded the file I saved and the controls are missing again.

What do the modified servo controls going to do. I was going to use them to move the arms up and down, Open and close the Eyes , rotate the antenna and rotate the wrists, just to start. These are the features that the museum wants the robot to have along with driving it around using the Robo Claw 2x30 motor controller, which is basically that same as the Sabretooth controller. The Mp3 trigger will operate the sound files and they want the video camera installed along with voive recognistion.

So if I can use more than one modified servo control, I have no idea how I am going to get everything to work. The scripting is beyond what I can do, and meet the deadline to have this thing operational. Myabe if I had a year to play with the program and study all of the scripting, I might be able to write the script, if it is simular to the PICAXE basic.

Dan S.
United Kingdom
#16  
Scripting is very easy, especially for modified servos. To move a modified servo you use the Move(servoport,forward/reverse/left/right/stop) command. And that's it. A couple of examples to show how simple it is;

Code:


# Move servo D19 forwards
Move(D19,forward)

Code:


# Move servo D19 reverse
Move(D19,reverse)

Code:


# Stop servo D19
Move(D19,stop)


If it gets a Move command it will continue that move until it receives another move command.

What you could do is add the Key Control and assign movement forward, movement reverse and stop to 3 keys on the keyboard, or assign them to a joystick button. Or even have the 3 scripts above on the project for each servo.

What is your deadline? I'm pretty much always around and will guide you on scripting or any of the controls as much as I can.
#17  
Rich: I see what you mean about the code: Looks easy. But my main issue is how to get all of the controls to work off of a tablet which won't have a keyboard. I think that they pan on using a Microsoft Surface tablet, so all of the controls need to be in the form of sliders or some sort of touch spot on the screen. To drive it they will need to use the touch 4 arrows to drive it and it will only run when they are touching the arrows otherwise the robot will be stopped. I can not have this thing running all the time when the operator is not sliding something or pressing something on the tablet in case they get distracted by the children.

I hope I have not bitten off more than I can handle with this using the EZ-B. I had this thing working pretty good using the old R/C system with a 12 Channel RF relay board to control the sounds, but they wanted to have to switched over to be able to use a tablet for control.

My deadline is sometime in the middle of May, don't know the exact date yet.

Dan S.
PRO
Synthiam
#18  
Is this what your project is supposed to look like?


User-inserted image
United Kingdom
#19  
Thats my one DJ for a different topic, used as an example to see he had problems saving.

Edit: This is his here

P.S. Nice leak;)
#20  
DJ: Thats what Rich's looks like. Mine is in the cloud and is called mmv6. I am still trying to figure out how to control everything using a Windows Tablet, using slide or touch controls. It is hard to do when I don't have the tablet to work from yet. I am still waiting on them to get me one, so in the mean time I am trying to work everything out on a laptop.



Dan S.