Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by DJ Sures!

Control Ar Drone From A Desktop Pc

Hello;

STILL waiting for my robot. They tell me now it won't ship until the week of the 22nd. To quote Charlie Brown ... AUUUUUUGH! *stress*

Anyway, I was just going through the AR Drone video concerning controlling it via EZ Builder. At least I have one of those. I was trying to do that via a desktop PC instead of a laptop as shown in the tutorial, and I was not able to see the Drone AP under my list of devices under the Network listing. I do have a home network with a wireless router, but I'm pretty sure that does not function as a pickup device for other wireless devices that are in server mode, as is the Drone. Is there some sort of other device I must have attached to the PC to see wireless access points? This sort of thing seems to be built into laptops, and of course, tablets and smart phones (which I usually use to control the drone). I'm assuming that is why all the videos show someone using a laptop as opposed to a desktop. Nonetheless, I would like to use a desktop to do it as I intend to do some experimenting with that mode when JD finally arrives and using the Drone in the meantime would be good experience. Not to mention relieving some of my angst over the extended wait for the little mechanical critter. Thanks

WBS

AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
#1  
Your desktop or laptop needs wifi access to connect to the drone directly. If you don't have that a wifi usb adaptor will solve that.
#2  
You'll need the same to set up your EZ-B robot, but it can be taught to connect to your router.

Technically the ARDrone can too, but they reset to default on reboot and have some other limitations, so probably not a great option.

Alan
PRO
Synthiam
#3  
Hi! Yeah, apology with the shipping times - you're not alone:) We're at this strange threshold of receiving lots of orders but not enough orders to pay for a larger manufacturing. It's this middle ground area where we can't keep up but can' t do anything about it. They say it's a "good problem to have" - thanks for your patience! It'll be worth it:D

As everyone had mentioned, the computer itself will need a WiFi connection - not the router. The router indeed will accept other connections, but that's not how the AR Drone works. you will need to connect "AD-HOC" which is when a computer/laptop connects directly to the device.

This is also how the EZ-Robot will work out of the box. Meaning, you will need a USB WifI dongle for your PC to use the EZ-Robot as well. They're really cheap on eBay (if you're willing to wait), otherwise Best Buy or Microcenter, etc...
#4  
Thank you for your replies.

@JustinRatliff
Yes, that's what I thought. I have tried 2 such units thus far, a Netgear and a Linksys. I took the Netgear back when it wouldn't install. The Linksys (AE6000) is doing the same. It loads a driver as soon as I plug it in, but the install program cannot find it. I followed the directions for a manual install and that seems to be OK. Looking at it directly everything seems to be fine (latest driver and everything). The Device Manager says it's working properly and I can get to the AE6000 wireless icon via the Network and Sharing Center/Change Adaptor settings. I don't think that is the same icon as is supposed to be in the tray however. Clicking that icon brings up a window that shows it seems to be OK. But nothing I know to do shows any list of wireless APs. There is no wireless icon in the tray and I can't find anything on how to make it appear. I looked in the Custom setup but there was no such icon there either. Maybe it's my computer, I don't know. Perhaps I should just get a laptop and be done with it.
PRO
Synthiam
#5  
1) have you rebooted after connecting the USB WiFi device and it detecting/installing the drivers? This may be necessary because your computer did not have the WiFi services running if it did not have WiFi before. A reboot may be necessary for the icon to show up

2) If the icon still does not show up, that may be because the WiFi will use a different icon when connected to Ethernet (as in your case). So when the Ethernet is connected, the icon will appear different. If you click on that Ethernet icon in the system tray, the WiFi network list will appear. I know it's strange, but that's how Microsoft decided to do it... by giving icon priority to Ethernet
#6  
@DJ Sures ... Thank you for your suggestions. Unfortunately rebooting does not seem to help. I have placed a post in the MS Community and received a response from a tech so we'll see how that goes.

On a separate point, how does one go about "closing" a thread as is required? I see no "Close This Thread" button. Though I may leave this thread open a while longer so that I may post a resolution to the problem here before closing it. That, of course, assumes a miracle occurs.
PRO
Synthiam
#7  
its beside the reply button:)
#8  
The only thing next to the reply button, as far as I can see, is the Cancel button. So I click Cancel to close the thread? Sorry to be so thick about this but I want to be sure I understand.

BTW, I finally am able to get to a window that shows potential wireless connections for the AE6000 but still nothing shows up. Even Linksys' own utility doesn't show anything. I think it comes down to a Linksys problem more than an MS problem.
#9  
At the top (I think it is at the top, if not it's at the bottom near the save button) of the page in a drop down list you pick the person who you believe helped you the most... then replay again to the thread... say thanks for your help or whatever you want to say... Hit reply and the person who you chose that helped you will get the credit for the help... the thread will be closed after that...
#11  
I received an email saying I needed to close this thread, so I am. Thanks very much to everyone who responded. Still no real resolution but I'm working with Linksys to see if anything can be done. Tried a Belkin unit as well, with exactely the same results. Maybe my computer is just too old, who knows. Looks more and more like I'll just need to get a laptop and move on. Thanks again. (JD should be shipping this week ... Yaaayyyy! :))