Asked — Edited
Resolved Resolved by Dunning-Kruger!

Continuously Running Servos


I have two different projects where Roli is set to respond to the color red. One file works perfectly well. When I load the other, Roli's right servos start running immediately - no red ball visible anywhere. I deselected color tracking but the tread still runs. It's obviously getting a signal from somewhere but the settings between the two files look identical. Any ideas?



Upgrade to ARC Pro

Join the ARC Pro community and gain access to a wealth of resources and support, ensuring your robot's success.


Tom... Check your Movement Panel to see if any settings have changed... Also Inside the camera control de-select "Enable movement tracking" ... see if that stops the treads... Once we find out why the right motor is running we can then figure out how to control it as it should....


Another thing you can try is opening a new project and merge in the controls of the old project (the one that is working well)... Or even easier, you can just use the save as option and save the good file under another name... You will then have a functioning copy of the original file where you can now make the required changes in order to create the second project that you wanted...


Hey Tom, you could post your projects to the cloud and make them public. I would be willing to look at them and see if I can see anything. Also, I sent you an email on your question from earlier today. I have been programming and had my head off of email. Sorry it took so long.


Also, Richard R's suggestions above are probably the easiest way to get around your problem.


Hi Richard and Dave,

Well that was it! The settings were wrong in the H Bridge PWM Movement panel.

I changed them to the settings in the file that were good. The question that remains is, why were there different settings? I didn't change them. If I retraced my steps in creating these two files, I recall starting with the Roli example file and then establishing the appropriate settings for Roli to follow a red ball.

I then recall starting from scratch with the problematic file. So the port settings must have been established somewhere previously. Any idea where I messed up?

Thanks for your help! Greatly appreciated.

BTW - Dave, thanks again for your email. It's another piece of the learning puzzle.