Asked
Resolved Resolved by Athena AI!

Chatgpt Not Functioning

Hi Athena,

Do you know what happened with ChatGPT not functioning in the ARC software this week? My robot hasn't been chatting with me this week, and I've tried using the latest version of ARC. Everything else is processing normally, but only ChatGPT isn't working!


Related Hardware EZ-B v4
Related Control OpenAI ChatGPT

ARC Pro

Upgrade to ARC Pro

Harnessing the power of ARC Pro, your robot can be more than just a simple automated machine.

PRO
Canada
#1  

Hello! I'm sorry to hear that you're experiencing issues with the OpenAI ChatGPT robot skill in your ARC project. Let's troubleshoot this together to get your robot chatting again.

Here are a few steps you can take to diagnose and potentially resolve the issue:

  1. Check OpenAI Server Status: Sometimes, the issue might be on OpenAI's end. You can check the OpenAI server status to see if there are any ongoing issues that might be affecting the ChatGPT service. Visit the OpenAI status page here: OpenAI Status.

  2. API Key Verification: Ensure that your API key for OpenAI is correctly configured in the ChatGPT robot skill settings. An invalid or expired API key could be the reason why the ChatGPT skill isn't functioning. You can verify your API key and regenerate it if necessary by visiting your account on the OpenAI website.

  3. Internet Connection: Since the ChatGPT robot skill relies on an internet connection to communicate with OpenAI's servers, make sure your internet connection is stable and that your network allows connections to OpenAI's services.

  4. Configuration Settings: Double-check the configuration settings of the ChatGPT robot skill in ARC. Ensure that all required fields are correctly filled out, including the API key, and that there are no errors in the configuration.

  5. ARC Software Update: Although you mentioned using the latest version of ARC, it's good to double-check that you are indeed on the latest version. Sometimes, a reinstallation of the software might resolve unexpected issues.

  6. Error Messages: Look for any error messages in ARC when trying to use the ChatGPT skill. These messages can provide clues on what might be going wrong.

  7. Firewall and Security Settings: Check if your firewall or security settings on your computer are blocking ARC or specifically the ChatGPT skill from accessing the internet.

If after these steps the ChatGPT robot skill still isn't functioning, you might consider reaching out to the Synthiam community or checking the support section for more specific guidance related to the OpenAI ChatGPT skill.

Let me know if any of these steps help or if you need further assistance!


I am a customer support GPT-powered AI and still learning. If you have doubts about my response, please use the support documentation to verify my answer.
#2  

Thank you Athena, But still isn't functioning after follow your suggestions! Does anyone have same situation or only my computer issue?

PRO
Canada
#3  

Hello,

I tried my project that I hadn't used for several days... Everything is functional with ChatGPT. I also use the most recent version of Sythiam. Do you have credits left with OpenAI (Credit Balance in Billing Overview under Personnal Settings)?

#4  

Hi Taubore,

Thanks for your help! I just opened the new project and used the ChatGPT default (not using my OpenAI account). But it isn't functioning!

User-inserted image

PRO
Canada
#5  

it used to be free (they gave everyone a bunch of free token) but now only works if you put money in the slot.   You can use groq for free with llama 3 for the time being and it is super fast.

PRO
Synthiam
#6   — Edited

Can you use groq or others by changing the url base domain endpoint? I don't have any experience with what services are compatible with the open ai request format. There doesn't seem to be any standard across llm services and programs.

#7  

Hi DJ and Nink,

Thank you for your assistance! I'm unsure about the solutions. Does this mean I need to open an account with Liama or Groq, and then use their API key instead of the existing one? Or can I still use my OpenAI billing account for this feature?

User-inserted image

However, the key doesn't seem to be functioning when I use the OpenAI API key for the ChatGPT features.

User-inserted image

Thanks for your help in advance.

#8  

When I use the 'groq' API Keys, it shows the following information:(

User-inserted image

PRO
Canada
#10  

Hello @rickymahk2013,

It sounds like you're experiencing issues with the OpenAI ChatGPT robot skill in your ARC project. Let's address your concerns step by step.

  1. OpenAI ChatGPT Functionality: If the ChatGPT robot skill isn't functioning, the first thing to check is the API key and server status. OpenAI may have service interruptions, or there might be issues with your API key or account billing. You can check the OpenAI server status here.

  2. Using Groq or Llama 3: As DJ_Sures mentioned, changing the base domain in the OpenAI ChatGPT robot skill settings allows you to point the skill to a different server that is compatible with the OpenAI API format. However, it's important to note that there is no standardization across different LLM (Large Language Models) services, which means that while you can change the base domain, the service you point to must be compatible with the API requests made by the OpenAI ChatGPT skill in ARC.

  3. API Key and Billing: If you're using OpenAI's API, ensure that your billing information is up to date and that you have sufficient credits to use the service. If you switch to another service like Groq or Llama 3, you will need to obtain an API key from them and ensure their API is compatible with the requests made by the ChatGPT skill.

  4. Base Domain Setting: The Base Domain setting in the OpenAI ChatGPT robot skill allows you to specify the base URL for API requests. This is useful for directing the robot's AI interactions to different server environments or third-party-compatible API endpoints. If you're considering using a service like Groq, you would replace the default OpenAI base domain with the endpoint provided by Groq, assuming their API is compatible.

If you're still having trouble after checking these areas, it might be helpful to revisit the configuration settings of the OpenAI ChatGPT skill in ARC. Make sure the API key is correctly entered and that the base domain (if modified) points to a compatible service.

Let me know if you need further assistance or specific steps to adjust these settings!


I am a customer support GPT-powered AI and still learning. If you have doubts about my response, please use the support documentation to verify my answer.
#11  

;)Thank you, everyone, for your assistance! I have finally resolved the issue!

PRO
Synthiam
#12  

That's good to hear - can you share what the resolution was?

#13  

Hi DJ,

I apologize for the oversightit's my fault. I missed the OpenAI notification regarding the change in payment policy. It appears that billing is now prepaid. Additionally, could you please share the settings for Groq? I've attempted to replace the API Key and base domain with "groq.com", but it doesn't seem to be working.

PRO
Canada
#14  

Here is my details for Groq. I am using the llama 3 70b model but there are a lot of other models depending on what you want to do.  Note this is only free for a short time while they get their billing system in place

User-inserted image

If you want to use another model copy and paste the model ID into the model name.   https://console.groq.com/docs/models

#15  

Hi Nink, thank you for your sharing! You saved my life!;)

PRO
Canada
#16  

The way DJ built this tool is great as there is really only a couple of customizations you need to get it to work with OpenAI compatible LLM tools as a lot have now standardized on OpenAI API.  There are also some local ones you can run direct on your robot that are quite fast and will work without a GPU (slow) or a small GPU (quite fast) like TinyLama and Phi 3.