Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Denmark
Asked — Edited
Resolved Resolved by Nomad 6R!

Charger

Hi,

I am having great success with the Roli on the software side where I have integrated the EmguCV libraries with the SDK and doing a lot of experiments.

However, I got a sudden problem with the charger. The green light does not come on when attaching the charger to the Roli by with the charger cable hanging below its belly. I have always had this problem, but I the charger always managed to recognize the empty battery by carefully inserting the cable. My problem is now there constantly.

Could you assist ? Do I need a new charger ?

Sincerely

Jan

AI Support Bot
Related Content
Synthiam
PRO
Belgium
#1  
jop

can you messure howmany volts you have when charging.
use the contact form to ask for a replacement.
Denmark
#2  
Hi nomad18.08,

thanks for help on this. I don't have a volt meter or any other measurement tools, so I have to use ad hoc methods. The charger does not get hot, so I don't think I am charging.

sincerely

Jan
PRO
Belgium
#3  
jop

see that you can messure it and make a pic.send the pic along whit the contact form.you can also contact ez direct.
Denmark
#4  
Thanks nomad,

Will a picture be enough of the charger connected with no green led glowing ?

I can buy a volt meter but it will cost me some, I am mostly a software guy.

/Jan
Denmark
#5  
I have a picture of the situation with a Roli with empty battery and attached charger
User-inserted image
Denmark
#6  
Difficult to see because of the blitz, here is a closeup from an another angle
User-inserted image
Denmark
#8  
Cool, thanks. I hope to get a replacement so I can continue my programming.
Denmark
#9  
I don't know how to close this thread but nomad answered my question so the issue can be resolved
PRO
Belgium
#10  
jop

you close this by checking who solved the problem.
Denmark
#11  
Yes, but the menu suddenly disappeared. It must be an error on the web site.
Denmark
#12  
I will close the thread when the menu appears again.
PRO
Belgium
#13  
its enough that you check who solved the error for you.
you can always talk further if you want.
also its good to mention if you have a problem what kind off device,
you use,post pics or video,that gives you better and faster respons.
Denmark
#14  
Ok, then I think the issue is resolved. Thanks nomad.
Denmark
#15  
I just got the charger from the DHL carrier a few minutes ago, looks very good. The green light is on in a flick of a moment and the Rovi is charging.

I will continue my software project now. From making it see (done) to making it navigate ...
#17  
I'm trying to NOT make another post on this subject, but there are so many.
I have read several threads pertaining to the charger "Green" LED not coming on. Both LEDs stay RED. There were at least a dozen articles, (solved help requests) up to three-years old, on this help area in the community. In this, particular post, a plaque at the top said it was resolved. I don't see any answer to the problem and I don't find any information about why the LED might not turn green as everyone tells you it will.
My first EZrobot was the SIX. I was unable to use it because the battery had spoiled while the Six was on the shelf at my local Brookstone store. Impressed by the EZ-BITs ruggedness, I purchased several other EZrobot components, including the wheeled Adventurebot, JD-body, Roli body, many servos, as well as additional batteries.
Eventually, I tried to charge different batteries with a single charger. Since the LED stayed RED, I expected the worst...thinking a dedicated charger was required for each battery, I purchased five (5) chargers ($125+), one for each battery.
I recognize that the "Overlord" used the same charger for different robots in his videos, but no one answered (satisfactorily) when I asked why the LED did not turn green. There's a lot of information here that didn't say what I needed to know. It takes hours to go through several dozen (or more) threads without finding what I needed to know. I even asked if China had replaced the LED with a RED one, no answer.
Alas, now I have five and have used and tested all five. Two of the five do not turn green. All of the chargers work, I think, but how can I know they are balanced? How can I know they work correctly if they don't work as advertised?
I can measure the output. I can measure the current draw. I can use the APP from other EZrobot designs to add the meter to my projects. I still don't know that my batteries are charged and will stop when fully charged. Will I have a fire? I don't know. I've learned I only need one charger, one wall-transformer, and all the others are spares.
Of the five transformers, one had a broken connection where the 120-volt common prong connected to a wire that served the PCB. That was an easy fix and before I repaired it I found six (6) volts output at the battery connector. After I soldered it, It's same as the others...works well. That particular transformer works with any of my chargers or batteries. But, like I said, I have several extras now...so I don't use that one.
The PCB has a circuit on it with a dual-color LED. I don't find any problems with the circuit, in fact, it's quite simple but the circuit path to turn it green is within the chip. I don't know the pin-out, so I can't trace it to find why it doesn't turn on.
Bottom line here is that sometimes the green LED wont work. It is a China problem, not the EZrobot people. That charger shipped from China, isn't made by EZrobot. Their stuff seems, rather great, actually...but the charger, from China, is a toss-up.
good luck ya'll.
User-inserted image
PRO
Belgium
#18  
hi doron

the solving of the problem is to use the contact form,and ask for warenty ,
if the charger is faulty.i dont now if he got one do?

if the charger does not work properly,you chould not use it and ask for,
a replacement.

90% off all devices are made in china.so alot can go wrong.
PRO
Canada
#19  
Hi Doron,

For the version of charger you have the LED labelled "charger" will turn from red to green after 1.5hrs of charging a low battery.

If the charger LED doesn't turn Green after 1.5hrs it is likely that the charger cannot reach the full battery voltage because the battery has been ran too low at some point in time and now has diminished capacity. The charger will keep trying to charge the battery to full voltage as long as the battery can't reach full voltage the LED will stay red.

If this is the case you have a couple options:

1. Continue to use the battery with diminished capacity, but be mindful to take it off the charger after 1.5hrs. If the charger continues to charge after this time (LED stays Red) it's not a big deal the charger is designed for this, it will happily continue trying to charge without consequence. The only consequence is unnecessary power draw which would effect your power bill slightly.

2. Purchase a new battery.