Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Thailand
Asked — Edited

Cannot Control To A Board.

Here is what I found in EZ-Builder: 2013.03.09.00 with my new board which just arrives today.
I've used Debug to see it.

Attempting connection on COM40
Connected to COM40 at 9600
EZ-B reports EZ-B Firmware V2 <-------------It asks me to update FW to V16, then disconnected.

Connection Failed: System.Exception: Welcome to EZ-Robot! You need to upgrade your firmware before you can begin.
You will be upgraded to v16.

Would you like to view the help tutorial with instructions on how to upgrade the firmware?
at EZ_B.EZB.Connect(String hostname, String tcpPassword, Int32 baudRate)
Disconnected
-------------------------------------------------------------

Hence, I updated FW to V16. <---------It seems work fine

3/9/2013 1:48:46 AM - Sending bootloader
Starting Boot Loader...

3/9/2013 1:48:52 AM - sending ping
3/9/2013 1:48:53 AM - sending ping
3/9/2013 1:48:54 AM - Sending bootloader
I am EZ-B BootLoader. Gimmie Firmware!


3/9/2013 1:48:59 AM - Step 1 of 2) This process will take 2 minutes. The status bar will display progress.

3/9/2013 1:48:59 AM - Updating... (22,656 Bytes)
3/9/2013 1:49:21 AM - Uploaded
-------------------------------------------------------------

However, when I've tried to connect a board again through EZ-builder, still got a problem as below.

Attempting connection on COM40
Connection Failed: System.UnauthorizedAccessException: Access to the port 'COM40' is denied.
at System.IO.Ports.InternalResources.WinIOError(Int32 errorCode, String str)
at System.IO.Ports.SerialStream..ctor(String portName, Int32 baudRate, Parity parity, Int32 dataBits, StopBits stopBits, Int32 readTimeout, Int32 writeTimeout, Handshake handshake, Boolean dtrEnable, Boolean rtsEnable, Boolean discardNull, Byte parityReplace)
at System.IO.Ports.SerialPort.Open()
at EZ_B.EZB.Connect(String hostname, String tcpPassword, Int32 baudRate)
Disconnected

Another matter, it seems after FW is updated to v16. Then, turn off battery and turn on, the v16 gone. it returns to v2.



Please help to fix it.

BJ

PRO
Synthiam
#1  
You must use the Microsoft native Bluetooth stack.:)

It's in as much documentation as we can put it in. Third party Bluetooth stacks are faulty and rarely support custom features - like robots:)

Also, please please please please watch the tutorial video. Use the help option. That will help you understand what the updating process looks like. We spend thousands of hours filming hundreds of tutorial videos:D put them to use.
Thailand
#2  
Yep, it works now. My wife helps me, she is genius. *eek*
#3  
Ha ha ha , awesome you have a wife willing to help. I'm convinced my ambitions and hobbies keep me single. :). - Josh
#4  
Um...HELP! The video doesn't help me because my computer is windows 8 and it doesn't react the same as windows 7 to Bluetooth and i need help quickthe science fair is coming up in april! *stress*
United Kingdom
#5  
Windows 8 is a leaning experience for the best of us. I assume you are looking to use ms Bluetooth stack?

Access the old control panel by going to desktop, opening explorer and typing control panel for the path.

Hopefully that's more familiar for you?
#6  
Search for " windows 7 shell for win 8" I had to install it to give me the win 7 controls and navigation etc. Win 8 is a completely new monster.