Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Can't Seem To Connect Ezb 3 Up With More Than 9600 Baud

I have finished most all of my main ports in Sally.

But, it is running turtle slow. When it comes up and says connected, it is 9600 baud. I am running a W3 which has an I5 quad cpus and it should be faster than that.

I have almost ALL of the ports filled up. I am not even running any scripts, just checking each port to see if it works.

The graphix is slow to regenerate when you change windows.

I am sure that some of you have run into this before. I feel like if I could raise the baud rate it would be a tad faster. I had it set for 57K on the ports.

thanks!

PRO
Synthiam
#1  
The ezb v3 runs at 9600 baud, which is fast enough. The Bluetooth is not capable of anything faster.

You can use the diagnostic control and see how many commands your computer can process per second.
#2  
MovieMaker, Do you have and ADC monitors running in ARC watching your ADC ports? If so these will slow your system down to a crawl. Remove them or pause them and see if that makes a difference.

Up load your project so we can have a look.
#3  
I have most all of the ports filled up. and, yes I am monitoring all of the ports with showing both the voltages and graphs for all ADC ports.

Thanks D.J.

Thanks Dave!

:-)
#4  
What if I took off the bluetooth and put a wi-fi adapter on the V3? would that give me more speed?
#5  
Several of us have tried to convert the V3 to Wifi all with limited success and no improvement in speed. 9600 bps is as fast as the V3 can handle anyway. If you are using WaitForChange on the ADC, I would suggest changing to ReadADC and increase the sleep increments in your loops to reduce the load on the ARC app. It isn't the speed of hte EZ-B, but the workload of constant monitoring of ADCs that is probably causing your slowdowns.

Alan
United Kingdom
#7  
WiFi made my V3 slower than Bluetooth.

Run a benchmark as suggested and write scripts/adjust controls so that it does not exceed the maximum number of commands sent/received than it can handle.
#8  
Rich, which benchmark are you talking about?
#9  
It's ok, I found it. It is INSIDE of ARC (God Bless D.J.!)

I will run it.

:-)
#10  
If you have the ADC monitors installed like I asked and confirmed by you, than you will have to remove or pause them and follow Alan's advice to get your system back up to speed. I had this same problem when I first started with the V3 and the only way I could get my system back up to speed was to pause the monitoring. There's a little box to check right on the monitor window that will pause it.
If you're still having problems please post your project so we can look it over and help.
#11  
I have seen this before. I stopped using the adc meters and only used adc charts and adc digital displays. Also I don't fiddle with the adc digital display multiplier, I leave it on the default. I can't say for certain that this was my fix, but I think it was. It was a while ago. Give it a try and good luck.