Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.
Get Started

Asked — Edited

Camera Tracking Glitch With All Cameras

I noticed lately when I use the Camera, tracking only last "one" time, whether it is face, color or whatever.

How can I deleted the camera and re-install it?


EzAng


Related Hardware EZ-Robot EZ-B v4
Related Control Cognitive Face
AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
Synthiam
#1  
Hmmm I haven't been experiencing this. What seems to happen? With any tracking type once the object is detected the camera skill crashes?

I don't think you need to uninstall the camera. Is it a camera that you have just installed or have you been using it for a while? I'm just trying to determine if anything has changed with your setup.

Do you have the latest version of ARC installed?
#2  
I have the latest version of ARC - later I can try another camera

I tried my computer camera and Ez B Camera
thanks

EzAng
#3  
So Jeremie, I just got back, what should I do?


EzAng
Synthiam
#4  
If you could answer the first few questions I had in my first post that’d help me out:D 

I need more info on what’s happening actually happening.
#5   — Edited
Wish we can speck, I will try the JD robot next.

ok, when I use the EZ-B v4 Camera, tracking,   with an IoTiny

User-inserted image



it only tracks once, then all the tracking boxes are empty - look below, I had it on face, then color, same thing happens, this just started.

User-inserted image



I use DJ code:

User-inserted image


here is the debug info:
2020/09/03 16:00:27 -05:00 - Attempting connection on 192.168.1.12:23
2020/09/03 16:00:27 -05:00 - Connected to 192.168.1.12:23
2020/09/03 16:00:27 -05:00 - Reports EZB v4 OS IoTiny
2020/09/03 16:00:27 -05:00 - Firmware 'EZ-Robot IoTiny standard firmware' on 'EZ-Robot EZ-B IoTiny' supports the following capabilities:
- ADC with 12 bit Resolution
- Can stream Audio v4 codec
- Reports battery voltage
- Reports CPU temperature
- Read/Write Digital I/O Ports
- I2C Master
- LIPO battery protection & shutdown
- PWM Duty on digital ports
- PWM servos on digital ports
- PWM servos on digital ports can release their position
- servo speed for PWM servos on digital ports
- Has NVRam configuration and can be restored to default settings
- Transmit Uart TX on all digital ports
- Adjustable I2C clock speed
- Ultrasonic Ping distance sensor support
- 12 Byte Unique Identifier
- Can stream video v4 codec
- Native WiFi Connectivity from ARC
- Broadcasts to ARC's PnP network scanner

Broadcasts to ARC's PnP network scanner
2020/09/03 16:00:27 -05:00 - EZ-Robot IoTiny standard firmware ID: 222-222-222-222-222-222-222-222-222-222-222-222
2020/09/03 16:00:27 -05:00 - Setting battery monitor voltage: 7
2020/09/03 16:00:27 -05:00 - Setting battery protection: True
2020/09/03 16:00:27 -05:00 - Setting i2c rate: 100000
2020/09/03 16:00:27 -05:00 - EZ-B voltage is 8.211534684
2020/09/03 16:00:27 -05:00 - EZ-B temperature is 25.02440624839843800C
2020/09/03 16:00:27 -05:00 - Connected
2020/09/03 16:00:36 -05:00 - Camera Initialized: EZB://192.168.1.12:24 @ 320x240


I downloaded ARC again, did repair, no luck

Like I said,  I will try the JD robot next., Tested JD robot, same thing happens,

I deleted Arc, fresh install - same thing

any ideas?

thanks
EzAng
#6   — Edited
@Ezang:

this:
User-inserted image


translates to:

Code:

// Wait until the camera detects a face
controlCommand("Camera", "CameraMovementTrackDisable");
controlCommand("Camera", "CameraUseTrackingScripts", false);
controlCommand("Camera", "CameraFaceTracking");
while (getVar("$CameraIsTracking") == 0);
controlCommand("Camera", "CameraDisableTracking");
controlCommand("Camera", "CameraUseTrackingScripts", true);

Audio.sayWait("I see a Face");
Basically WaitForFace blocky enables the cameraFaceTracking and then disables cameraFaceTracking

you can store the previous state i.e. before the WaitForFace and then set after the block
User-inserted image


I believe is a design choice.
#7   — Edited
I assumed CameraTrackingType was the configuration setting but is not.
So I believe the solution is to have a global variable to set/store the tracking state and then restore the state after the WaitForFace.
#8   — Edited
I tried it, no luck

User-inserted image


EzAng
#10   — Edited
Ptp, I re-arranged the code, now it works when it sees me and stay there for another round of seeing me again and again -  color or face

User-inserted image



User-inserted image



still my Blockly code some controls appears and the next time it is gone like set isFaceTracking, , go figure :-)


tracking color

User-inserted image


In Java:

setVar("$CameraTrackingType", 0);

if (getVar("$CameraTrackingType") == 1) {

// Wait until the camera detects the specified color
controlCommand("Camera", "CameraMovementTrackDisable");
controlCommand("Camera", "CameraUseTrackingScripts", false);
controlCommand("Camera", "CameraColorTracking", "Red");
while (getVar("$CameraIsTracking") == 0);
controlCommand("Camera", "CameraDisableTracking");
controlCommand("Camera", "CameraUseTrackingScripts", true);

}

if (getVar("$CameraTrackingType") == 1) {

controlCommand("Camera", "CameraColorTrackingEnable");


}

Audio.sayWait("I see red");

or 

User-inserted image



I guess simple is not so simple today :-)

be well,

thanks
EzAng