Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Camera Motion

Hi guys!
I have been trying to get my box robot up and running but cant get past the camera tracking. It just wont follow me or any colors. I have checked with motion control and everything is A O.K! I just find that the videos for helping are dated when it comes to the new software which becomes frustrating and at times over whelming!
I must be getting it all wrong with the Script for Command Contrals!
But what D.J Sures suggests does not exist anymore on the list!
I love Robots and would just like some help! PLEASE!
I have the new 16.0 version.
Thanks!

AI Support Bot
Related Content
Synthiam
United Kingdom
#4  
Thank you I'm going to put together another EZ-B board and servo camera to see if I have any another issues that's causing the problem
#5  
Thanks Rich!
That did help a bit. It moves now but just like Winstn60 mentioned, I'm having the same issue! It just doesn't follow smoothly or accurate and I adjusted it. It wont track me vertically. When I check " Track by relative position it goes everywhere and spots me but doesn't stop. I really think there is a glitch in the new software.
Let me know how you guys make out with this?
Thanks!
United Kingdom
#6  
Don't tick track by relative position, I believe that is for if the camera isn't mounted on the servos or something along those lines.

Horizontal and vertical increment may need adjusting, although I haven't played with the camera much lately so can't be sure, I will check it all out tonight. I doubt it's a software glitch as DJ loves the camera control and has mentioned how much better it now runs, so I assume there was substantial testing done on it.

I just noticed that my tracking speed in the image looks like it may have been reset on the update (or I might have messed it up at some point), it might be to do with that too, play with the slider and see what happens.

You may also need to adjust the servo speeds, I usually do these in an init script, in fact I know I have servo speeds set up so the head moves slower.


I'll post more in about 3 1/2 hours when I get home:)
United Kingdom
#7  
Nope, Melvin works better than ever with no settings changed.

However, I do have an init script running which sets the servo speeds for the pan & tilt

Code:


ServoSpeed(D1, 2)
ServoSpeed(D2, 2)
PRO
Synthiam
#8  
We have added hundreds of little question marks next to every option. Hover your cursor over the blue question mark to read what it does:)
United Kingdom
#10  
Well setting the servo speed has helped with my head servo speed useful tip Rich thanks.

Hooray! I had a eureka moment and now it works great you have to get the min and max servo settings the right way round its too easy to swap them over so to speak and then nothing will work. I have to have my servo inverted box ticked as well. Camera tracking was one of the most important features so I'm pleased to have sorted it at last:)
#11  
Thanks DJ Sures. I did try all of the marked question marks next to the options. I just don't know if i have to right servo speed.
Do i have to put a ControlCommand() code?
On the video Sures says to pick ControlCommand() ("found ball". Script Start)
and ControlCommand() ("Lost ball". Script Start.
If so, this is not in the list of scripts in the new software on tracking control options. I will take some pics of my setting and see if anyone can guide me.

This is a really great community you guys have here, Thanks;)
Oh, to Winstn60. what servo speed do you have it on?
United Kingdom
#12  
Mine is the same as Rich's ServoSpeed(D8, 2)

You wont have to use a ControlCommand() code for your camera to track correctly. You need a let lit subject and carefully adjust the colour setting so only the object you want gets detected. Glyph's are good for this as the don't need setting up in the same way. I have enable forward motion and left/right motion ticked but enable movement tracking is unticked but that shouldn't make any difference. Post some pics
#13  
I had issues with camera tracking because I forgot to set the grid. But after I did that it worked beautifully. Really like how nicely the camera works, the start and stop buttons make it more reliable.
United Kingdom
#14  
Servo speed of 2 was the smoothest I found when setting it up.
I also have the grid set up so the centre square is smaller than the outer 8 squares, not too small otherwise it's forever twitching. I'll try and post a screenshot later.
#15  
I have tried it this morning with little time I had before going to work. It did follow me, but would loose me easy at times. I think the lighting in this room sicks. you let me know with the pics I post. This is the settings I have it on right now.
User-inserted image


User-inserted image
#16  
Can someone Help? I'm still stuck on this problem.*confused*
This weekend is the best time for me. *stress*
United Kingdom
#17  
Hi are you tracking in both X & Y? as you have the Y axis servo invert direction ticked but with no servo movement possible as Min is set to 45 and Max is set to 45 as well

I would avoid D0 as a port in case you want to use it for another control

Try tracking a colored object 1st and adjust the color control carefully so the object is solidly highlighted by the camera control. Room lighting looks ok though

I drew a simple face on a piece of paper that was easier to move around in front of the camera rather than my own face. I also wear glasses and have noticed that wearing them sometimes the detection isn't as good

Also try using the custom Haar control and load up haarcascade_frontalface_alt2.xml from the example site listed.

I found that the highest camera resolution worked best for me on Face detection as I didn't get many false squares popping up which are smaller
United Kingdom
#18  
Also adjust your brightness on the settings, the lighting in my house is very dim (that's energy saving LED lamps for you...) but when increasing the brightness detection was improved.

I get a lot of "phantom faces" or false detection still though, but nothing so bad that it throws off the tracking, he just has a little twitch now and then, which adds to his character:)
United Kingdom
#19  
I just noticed motion tracking is really good now as you can adjust the check frames setting. I like sitting my Omnibot to look at my big TV screen and his head goes back and forward with the action its quite spooky especially if football is on (his favourite!)
#20  
Thanks you guys. Finally I have got it to track me around. I just changed ports like winstn60 said!
Need to work on the smoothness though. Any suggestions?
I got the wii remote going on it and now I'm working on the voice recognition and I'm stuck again. Any tips will save me some time.
Thanks!
#21  
I am having the same issues with tracking color or face. I am going to try out the settings you guys are talking about. However, the biggest problem is after about a couple of minutes the camera image freezes and I can't get it to work again unless I power off and back on the EZ-B. Don't know what is up with that. Still troubleshooting.
#22  
Hi all!

I just got my BoxBot running. This is all very cool stuff. I even got the Wii controller working. I searched the forum and cant find any help with my camera issue. The camera works and I see video but cant get the "Processed Video" to show up? I can control the V&H servo with the Wii controller, but no tracking. I see screen shots and in videos that everyone has a video with grid, but I cant get mine to show up. Am I missing something simple?

Any help would be great.

Thanks!

Added info:
I wanted to add that this is showing up in the debug:
Camera Initialized: USB Video Device @ 640x480
Error Camera.SetCaptureImage: System.OutOfMemoryException: Insufficient memory to continue the execution of the program.
at System.Runtime.InteropServices.Marshal.AllocHGlobal(IntPtr cb)
at AForge.Imaging.UnmanagedImage.FromManagedImage(BitmapData imageData)
at AForge.Imaging.UnmanagedImage.FromManagedImage(Bitmap image)
at EZ_B.Camera.SetCaptureImage(Bitmap bmIn)

I have plenty of RAM and Disk available, so what is out of memory?

I found the issue. Was simple, need WIN7 will not work in XP:)
United Kingdom
#23  
Great to hear its working now