Denmark
Asked — Edited
Resolved Resolved by DJ Sures!

Camera

Hi,

I just got a Roli robot for some SLAM experiments, but the camera does not work. I was trying the tutorial with the red ball that should be tracked, but the camera showed up as disabled in the on screen log.

The camera is plugged into the EZ-B board in the only correct manner there is possible.

Please, do you know what could be wrong ?

best

Jan Pedersen


ARC Pro

Upgrade to ARC Pro

ARC Pro is your passport to a world of endless possibilities in robot programming, waiting for you to explore.

#1  

Can you see a solid blue led light through the white casing? If not you can try Very carefully removing the camera from the casing... Unplugging it and plugging it back in again... Could just be a lose connection....

Denmark
#2  

Hi Richard,

Thanks a lot, I can see the solid blue light through the EZ-B casing, but it is blinking. Is this ok ?

/Jan

Denmark
#3  

Just another thing: everything else works. All the servos work and the robot can dance and wave

#4  

When the camera is working correctly the blue led will be solid... it should only blink momentarily when you first power it on... Are you using the same IP address for the camera as for your EZB?

Denmark
#5  

Camera IP is "EZB://192.168.1.1" and EZB IP is "192.168.1.1:23", so same IP but not port designation for the camera. Could this be the fault?

The strings above are copy and paste from the GUI of the desktop app.

The blue light is still blinking

/Jan

#6  

Your IP's are good... Stupid question, but in the camera control did you click start to start the camera?

Denmark
#7  

After restarting the ARC and reconnecting WiFi the blue light is constant (non-blinking).

I did press start to start the camera, but I think the client sw discovers that the camera is disconnected and returns to a stop mode so that the start button is visible again.

The camera is still shown as disconnected. I have tried to mingle the cables with no success

Denmark
#8  

I got a log:


20-02-2015 17:48 - Camera Initialized: EZB://192.168.1.1 @ 320x240 20-02-2015 17:48 - Object Recognition loaded. 20-02-2015 17:48 - Camera Disabled 20-02-2015 17:48 - Camera Initialized: EZB://192.168.1.1 @ 320x240 20-02-2015 17:48 - EZ-B v4 Camera Error: System.ObjectDisposedException: Der er ikke adgang til et fjernet objekt. Objektnavn: 'System.Net.Sockets.NetworkStream'. ved System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size) ved EZ_B.EZBv4Video.() 20-02-2015 17:48 - Camera Disabled 20-02-2015 17:48 - Camera Disabled 20-02-2015 17:48 - Camera Initialized: EZB://192.168.1.1 @ 320x240 20-02-2015 17:48 - EZ-B v4 Camera Error: System.IO.IOException:

I would say the camera is broke, ...

United Kingdom
#9  

@Jop.

Have you tried closing the project and opening up again to see if the camera initiates?

Denmark
#10  

Hi Steve,

Thanks for your comment. Yes, I tried to close the ARC application while the robot was still on, but no success. I don't know how to close the project as such.

More and more I suspsect that the camera must be at fault. I am happy with the robot as such and it would do a perfect job at mapping its surroundings, but it needs the camera to see.

PRO
Synthiam
#11  

job, are you able to use the USB camera on your laptop?

Denmark
#12  

Hi DJ,

Thanks for helping me on this. I don't use a laptop, but a HP desptop. Yes the camera works on the desktop and also in the ARC app, I just saw my own semi-nice face in ARC.

I don't have a USB camera, but a built in camera, a web-cam.

/Jan

Denmark
#13  

So you think it could be a communications problem between the camera and PC ?

Could be. I actually have slow mini-laptop and could run the stuff there. I will report back.

/Jan

Denmark
#14  

Exactly the same behavior on my acer mini-laptop, actuators work but not camera.

#15  

jop, Try deleting the camera from your project, then add it again. In ARC choose Project, add, camera, camera device, start camera. Steve S

Denmark
#16  

Hi Steve S.

Thanks for joining the discussion.

I tried to delete camera by closing the camera window and then adding it again by your method. The logs still show camera disconnected. I think the camera itself is the problem.

United Kingdom
#17  

A long shot but sometimes work, and one more thing you can try. Have you tried reseating the camera cable. Carefully remove it from the EZ-B and re-connect, insuring it's connected the correct way around. Then do the same in the camera itself.

#18  

@SteveG... That's what I suggested already... Maybe you need some coffee now too?:P

United Kingdom
#19  

Lol. I'm picking up your bad habits now Richard, and not reading the thread fully. Going to put the kettle on now:P. Sorry @jop. One thing though, is the camera cable ok? Someone had an issue a while ago where the cable was twisted at one of the plug ends.

Twisted camera cable

Denmark
#20  

I took the instant coffee, bad for the stumach.

I tried to open the camera, but the wiring is a one orientation only fit as in the robot, so if the cabling is wrong its one of the cable ends having orientation wrong. Also the connection in the robot is ok.

When I started on this SLAM thing I thought ROS would be good, but there you just run into sw problems instead, so as is usual problems everywhere.

/Jan

PRO
Synthiam
#21  

The camera may be defective. I would recommend pasting this forum thread URL into the Contact Us for warranty.

The way we can tell if the camera is working is by the blue LED on the camera flashing rapidly. Nearly a flicker... This flicker would begin within 2-3 seconds of the EZ-B being powered on.

If you see the flicker, that means the camera is functioning - however, if the data isn't being received to the PC, this might be a communication cable issue.

Worst case scenario is the EZ-B itself is not sending the video.

You can ask for an EZ-B and Camera replacement together - if that would help you feel more comfortable getting up and running. We would ask your current EZ-B and Camera to be sent back so we can investigate.

Denmark
#22  

Hi DJ,

Thanks a lot for letting me get a new EZB and camera. I will post a waranty.

I can see that after power up, the flicker is absent but followed by the "slow" pulsating blue pattern, so i guess somewhing is wrong. The slow pulsating gets to a constant blue light when connecting to WiFi.

On the other hand. I am impressed by this robot toy and look forward to get some AI into its workings. I have my hands on openCV, which I hope to integrate into your API, a C++/C# combination job.

/Jan

#23  

@jop ... That's the ezb... However, there is a blue led inside the actual camera case too.. As DJ mentioned it will flicker so fast it almost appears to be a solid blue....

Denmark
#24  

Hi Richard,

Thanks, I never realised the blue LED in the camera case. No this is completely dark in my case, so I guess it indicates that the camera is down. No "solid" blue or flickering to be seen.

/Jan

#25  

@Jop... so sounds like your camera is defective... Refer to DJ's post #22 and contact us....

Denmark
#26  

Hi DJ and all,

Thanks for getting my camera issue settled. I hope I can return with some of my own stuff after ½ year of coding and testing. I just started today, on my SLAM algorithm.

Sincerely

Jan Pedersen

#27  

@jop Jan, I know this thread is a little dated, but did you every make progress on your SLAM algorithm? Curious because I was looking into doing something similar.