Welcome to Synthiam!

The easiest way to program the most powerful robots. Use technologies by leading industry experts. ARC is a free-to-use robot programming software that makes servo automation, computer vision, autonomous navigation, and artificial intelligence easy.

Get Started
Asked — Edited

Builder Won't Open

My son and I made our first bit of progress last night by getting our little bot up and going. But when we opened builder this morning, we noticed the "update available" tab flashing so we clicked on it. it took us to the download page which we did and everything went normally until we clicked on "finish" to exit the installer. The little hour glass icon appeared and didn't leave- for hours. finally, I restarted my computer, only to find that builder wouldn't open. Nothing unusual happens except it won't open, actually nothing at all happens.


ARC Pro

Upgrade to ARC Pro

Harnessing the power of ARC Pro, your robot can be more than just a simple automated machine.

AI Support Bot
Related Content
Synthiam
#1  
Can't you just uninstall it and then re-install ARC again? Isn't there a repair feature in the installer package itself?
#2  
Remove the old version and install the new one: Control Panel/Uninstall a Program
#3  
I have uninstalled, installed, repaired, installed complete instead of typical, still nothing. I did notice though, that if I deselected the "launch builder" box in the finish installer menu before clicking "finish", then the window closed as normal, instead of the hour glass never going away. But, still won't open.
PRO
Synthiam
#4  
The file that you downloaded must have been corrupted during the transfer. Redownload the file.

Lastly, sometimes Windows is a strange beast and has mysteries that man will never understand... A reboot may be necessary:)
#5  
DJ,
Hello again, I'm sure I seem like a simpleton, but honestly, I can tie my own shoes. I have re-downloaded 5 times. Could you help me out with the reboot?
#6  
I think DJ was just trying to start at the simplest solutions that have worked for others in the past. If he doesn't know you, he has no way of knowing your computer experience level. Don't take it personally.
#7  
No, No, nothing personal. So far, I think everybody on the forum is awesome! I really appreciate all the help, and my computer experience is pretty basic. I have to keep asking my son what things mean. It's pretty laughable.
PRO
Synthiam
#8  
yes - to reboot the computer, perform these functions

1) Based on the version of Windows operating system that you are using, locate the power icon. In Windows 7, it is on the task bar. In windows 8, you can swipe from the right

2) Once you locate the power icon, press the SHUT DOWN option. This will ensure the computer entirely shuts down, which is the most reliable reboot method

3) Once the computer has entirely shut down. Locate the power button and press it. This will power the computer on

4) Wait for the PC to fully load. You may be required to enter a username/password, enter it

Now that your computer is logged in and rebooted. Visit www.ez-robot.com and locate the Software menu option from the top of the website. Press the Download option for ARC.

Depending on your web browser, the file may begin downloading or prompt. Either way, select OPEN if available. We want to ensure that you open the file that was downloaded, and not a previous downloaded copy.

There is no EZ-Robot related reason why the software will not load on your PC. At this point, diagnosing Windows issues on your PC is necessary.
#9  
Wait, reboot as in restart? No wonder I sounded sarcastic. I've restarted several times. Still nothing.
#11  
I AM a simpleton but I would approach it like this:

1. Uninstall previous version of software.
2. Reboot the PC
3. Delete any previous downloads of the software.
4. Download fresh install from ez-robot.com
5. Install from freshly downloaded file

In most cases, software install issues should be resolved by those steps.
#12  
OK, I just restarted my computer. I have deleted ARC. I checked program files86 for ez-anything, and found nothing. so, I think I'm ready to install, again. How do I check to make sure all previous builder downloads have been deleted?
#13  
My son just left, shaking his head. I'm only forty, but I've never felt so old. He's probably going out to get me a walker.
#16  
Ok, I just clicked the link you gave me, downloaded/installed it. But, I'll be honest, I have no idea what's supposed to happen, or what I'm supposed to do now.

Also, I re-installed builder. Still no go. The ARC icon is present and normal. I click on it, and nothing. It's almost like it's opening as normal, but the page doesn't come up. Like it does, when you open something to a screen that's minimized.
#17  
Did you install .net? Question has ARC ever worked before for you or is this the first time you are trying to install it? Also, do you have another PC to try this on?
#18  
Builder was working fine, until I clicked "update" this morning.

.net wouldn't install, because it said it was already installed on my computer.

I do not have another computer. I probably need to get a new one though, I've had this one for a few years now.
#19  
@Richard R, ARC worked because the problem started when he tried to upgrade when ARC told him about today's build. He reinstalled dotnet a few messages back.

I would offer to do a remote TeamViewer session, but it will be several hours until I am free. Might want to try a Windows restore back to the last restore point. Something is clearly corrupted. Restore will fix any registry issues.

Alan
#20  
@Alan... Pays to read the whole thread... :) I am with Alan, maybe do a restore from maybe a week ago and then try again?
#21  
Alan, I would be happy to have to see if there's anything you could do remotely. I've got to go do a little work anyway, so a few hours from now would be great.(keeps the wife happy if she can buy groceries and silly things like that) Maybe you could even just walk me through a restore.... I'll check back later to see if I/we can get this thing going again.
#22  
Sure. My email address is in my profile (click on my name) . Send me your phone number and I'll send you back a link for TeamViewer and give you a call after dinner and we can get this figured out.

Alan
PRO
Synthiam
#24  
Alan, need to buy you a super hero cape
#25  
@DJ You guys have been very good to me. If I can use some of my knowledge and customer service/ IT skills for your other customers, it is the least I can do.

Alan
PRO
Belgium
#26  
deleting your browser history might help to.sinds he try it several times.
#27  
System restore said that it failed, but must have cleaned up enough, because we were back on the previous version of ARC, and I was able to help him update to the current version successfully. I hate not knowing for sure what was wrong, but am glad that whatever it was got fixed.

Alan
PRO
Synthiam
#28  
Strange! Sometimes windows just doesn't play well. Great to hear here is up and running with little effort!
#29  
Thanks a ton Alan! I really appreciate your help. And everybody, really. Everyone's comments and suggestions were fantastic. I haven't been a part of EZ- Robot long, but I am very impressed. Thanks guys!:D:D
#30  
DJ,

Jake just uploaded a diagnostic report. After thinking we had success last night, after a reboot the problem came back where ARC would not start. Task Manager showed three instances of ARC.exe running, but each only taking up 112k of memory. If we tried to start again, it could add three more tasks. The tasks could not be killed by task manager, killtask (run in a command prompt as administratot) or with sysinternals process explorer.

We rebooted, uninstalled, rebooted, re-installed and kept having the same issue. When we reverted back to the January 22nd version, it runs fine. However, it did have a problem connecting to the EZ-B until we added exclusions to Avast anti-virus. I am suspecting that may have been the issue with the newer version of ARC not running at all, but after spending a couple of hours, we decided to leave the old version for a week or so before tackling it again.

Do more recent releases attempt any network communication other than checking for update on bootup that the january 22nd version didn't do that might explain why Avast could be blocking it? If not, can you take a look at the diagnostic report and see if anything else jumps out at you that might prevent a newer version from working?

Alan
#31  
Hey, just wanted to post a "thank you" to Alan. What a pain this was, but he just hung in there, being patient, with me and the computer. Just a great guy. Thanks a ton Alan!