Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.
Get Started

Asked — Edited
Resolved Resolved by DJ Sures!

Bing Speech Error - Unknown User ?

I just fired up my B9 after he's been shutdown for months. When I try to talk to him through Bing Speech Recognition plugin I get the error shown on the screenshot below. How can I get this to work?

I'm using the basic plugin supplied for free use without a API key. Most of my robot's reaction is triggered through the Bing Speech Recognition and he's basically dead in the water now. Sadly I have a showing tomorrow with people driving hours to view the advanced features that EZ Robots gives my B9. This will be a real disappointment to them if all he does is stand there. *tired*

User-inserted image

AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
#1  
I think that there is a built in version as in part of ARC. You should find both listed in controls. Are you using that one? You might need to remove any older versions (with api keys). I use the free one thru EZ but is limited to 200 a day. I went thru that pretty quick. I think DJ said you can use both (built in and API ver) in same project to double you daily usage?!...not sure what thread i saw that but I may have dreamed it all ..lol?!

Edit: Advanced Bing Speech is the pay for API key ver.
Bing Speech Rec is the EZ free version built in.

Both are listed in Audio controls
Canada
#2  
Maybe time to try ptp watson plugin. The speech recognition works exceptionally well.
United Kingdom
#3  
Hi Dave.

I just this moment tried the basic (not Advanced) Bing speech recognition control from the "Add Control", "Audio" menu as Will mentioned, and it's working okay for me. I have my Bing S/R control linked to the AIML Bot control to do similar to what you have to trigger actions.

User-inserted image


As mentioned, maybe try removing the Bing plugin you have, then add the basic Bing S/R control back in and give it another try.

Good luck and hope you get it sorted before your visitors arrive.
Synthiam
#4  
Dave - you're using the "Advanced Bing Speech Recognition", which means you need to supply your own Azure credentials. Your other option is to use the regular one which uses the ezrobot provided credentials.

Both are documented very well by pressing the ? (question mark) next to the X button in the control.

User-inserted image
#5  
Thanks for the help guys. Very odd. I must have something screwed up. Not sure what as everything was working perfectly last time he was up and running. I thought I was using the free version. I actually tried to replace it last night but have some confusion as to which one to choose. Neither choice in the Add Control window says Advance. See below.


User-inserted image
Synthiam
#6  
Oh - I know what it is. Your account settings in ARC are incorrect. This was a situation you had a few months ago regarding a misunderstanding of how email worked. You changed email providers and didn't know that also meant the email address changed for you. This means your ARC account information doesn't match the website credentials. Enter the correct credentials in ARC -> Options -> Account Settings.
#7  
Thanks DJ. That did it. Everything is working now.

As far as me not understanding how Email works, well, I'll say LOL. :P Of course I know how it works. The issue was I couldn't change my email address to my new one on this website. You told me to do it through customer support. I still haven't done that.

No matter. That's small potatoes. The main thing is that I'm up and running and still have an hour before my guests arrive. Thanks sincerely for the help. :)
#10  
As a follow up; Just wondering why I cant see the Advanced title on the Bing Speech Recognition? Is it my resolution? Can others see it?
Synthiam
#11  
Yeah - point your mouse cursor on the tab titled "Advanced" in the configuration settings of ARC. Once the mouse cursor is on the tab, press the mouse button. That will change the display to allow you to enter the API Key from Azure.
#12  
OK, I see it. The free version is in the Audio tab and the advanced version is in the plugin tab. However all these versions are just labeled Bing Speech. Nowhere is the advanced plugin labled "Advanced". I've viewed this on two different computers. For a screen shot of this please see my post #6.
#13  
Hey Dave. A little unrelated but would you be willing to share your project with me?

Chris
Synthiam
#14  
That’s because when you added the plugin a long time ago, it wasn’t called advanced. Now it is, so if you added it from scratch it would be named advanced.
#15  
Thanks DJ. That makes since.

Chris, I'd be happy to. Thanks for asking. However It's very large and the EZ Cloud won't accept my latest version. I've tried to upload and the EZ Cloud won't update my older version. You can find the old version by starting ARC, clicking on the Open tab in the EZ Cloud menu section then search for my name under all users . The older version really isn't much different then the newer as far as controls and running my robot. I'll have to go to a different computer to attach my latest version here in this post.

Edit: I can't seem to upload it here either. There must be a size limit for this also. The file is 55MB. Send me your email address and I'll send it privately. Here's my address: dschulpius at gmail dot com. Did you ask for this once before and did I not send it? I seem to remember that happening. If so my apologies. *blush*
#16  
Chris, I can't seem to upload it here either. There must be a size limit for this also. The file is 55MB. Send me your email address and I'll send it privately. Here's my address: dschulpius at gmail dot com. Did you ask for this once before and did I not send it? I seem to remember that happening. If so my apologies. *blush*
Synthiam
#17  
For projects that big that you wish to share, use Drop Box or something. Drop box is free if you only need small files like that...
#18  
Thanks Dj for the tip. Google Drive did the trick for us this time. I uploaded it to Gmail and Google sent a link to Chris to download it. It all happened automatically when I tried to attach the project file to the email I sent Chris.