Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Netherlands
Asked — Edited
Resolved Resolved by DJ Sures!

Auto Start Command Line Options

<Second time I have to type this text, fiurst time I got 404 error of the ARC website and all was lost>

This weekend I tried to auto-start EZ-B on power-on of the robot.
Step1: Enable auot power-on, https://www.onlogic.com/company/io-hub/back-in-business-how-to-enable-auto-power-on/
Step2: Starting Windows 10 Without a Password , https://www.nytimes.com/2016/02/16/technology/personaltech/starting-windows-10-without-a-password.html
Step3: Add EZ-B to run automatically at startup in Windows 10, https://support.microsoft.com/en-us/windows/add-an-app-to-run-automatically-at-startup-in-windows-10-150da165-dcd9-7230-517b-cf3c295d89dd
Step4: Auto Start Command Line Options, EDIT to show the supported website,  https://synthiam.com/Support/ARC-Overview/loading-saving-robot-projects/Auto%20Load%20Project

I can automatically load a project file with the first parameter. That works
Adding the second parameter "The name of the script control you wish to execute apon startup" gives an error. See below

The script I call does exists, e.g. I can execute

Code:

ControlCommand("ScriptInit", "ScriptStart")

But when executing the script at startup I get error below.
Is that a bug or did I miss a step?

Code:

Version: 2020.11.02.00

System.Exception: ControlCommand Error. 'ScriptInit' does not exist. Can not send command 'ScriptStart'.
at ARC.FormMain.SendFormCommand(String windowName, String controlCommand, String[] values)
at ARC.FormMain.T9T7yYt0tY(Object , EventArgs )
at System.Windows.Forms.Form.OnLoad(EventArgs e)
at System.Windows.Forms.Form.OnCreateControl()
at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
at System.Windows.Forms.Control.CreateControl()
at System.Windows.Forms.Control.WmShowWindow(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.Form.WmShowWindow(Message& m)
at System.Windows.Forms.Form.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


Related Hardware EZ-Robot EZ-B v4
PRO
Synthiam
#1   — Edited
Can you show me your command line please

I'm unable to reproduce the issue. The following works fine in my tests on this saturday morning. I have a project "test startup project", a script that is named "test script", and I launch ARC.EXE from the command line as such...

Code:


"C:\Program Files (x86)\Synthiam Inc\ARC by Synthiam\ARC.exe" "C:\My Documents\ARC\My Projects\tet startup project.EZB" "test script"
PRO
Synthiam
#2   — Edited
Lastly, the startup EZ-Script manual link is not officially supported and was created by a third party. You would want to use the SUPPORT tab on the top of this website to access commands, tutorials, manuals, etc.. 

Here is a direct link to the auto start in the official support section: https://synthiam.com/Support/ARC-Overview/loading-saving-robot-projects/Auto%20Load%20Project

Please reference the official support section for up to date documentation and instructions

PRO
Netherlands
#3  
Hi DJ,

Thank you for the quick reply, as usual.

I was not aware I did refer to a not supported website, my apologies, have updated the link with the correct one. My purpose to give back to the community by articulating the steps.

I tried the same as you and created a new small new test project and it all worked fine, no issues.

I tried again within an existing (large) project and it did not work, still got the same error.
The code:

Code:

"D:\EZ-Robot Inc\EZ-Builder\ARC.exe" "D:\Onedrive\Robotics\R2D2\EZ-B\R2D2 ARC V1.20.EZB" "ScriptInit"
The script does exist:
User-inserted image


Thinking about the differences: in the large project it contains camera, cognitive, speach recognition, etc. Maybe it misses a window/timing issue? Maybe related to the new windows update, I need to re-arrange constantly to find stuff back? Anyhow, just brainstorming to try to give the right input.

p.s. in the script help within EZ-B is a small typo. It states

Code:

   "c:\Program Files\EZ-Builder\EZ-Builder.exe "C:\files\My File.ezb" "InitScript"
while it should be (like it is correct in the official support website):

Code:

   "c:\Program Files\EZ-Builder\EZ-Builder.exe" "C:\files\My File.ezb" "InitScript"
PRO
Synthiam
#4  
Thanks! I'm looking into this. Stay tuned:)
PRO
Netherlands
#5   — Edited
Many thanks. Solved in version ARC 2020.11.11.00 (Early Access)