Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by Robot Doc!

Anyone Know The Value Of D1?

So, I took a gamble and replaced the already good Regulators. The EZB still doesn't work. All of the voltages are there. D1 has opened up and doesn't show any transistor or resistive, or capacitive readings, just completely OPEN. I need to know the value so I can replace it as a last shot at this. I have believed it was the cpu from the beginning. They used to sell those in the store for $15 , I think. Now, I have found this diode open.

So, does anyone know the value? I am guessing 5v Zenier?

AI Support Bot
Related Content
Synthiam
#1  
Nevermind, I found it. It is an SR-240 Scholttky Diode.

Thanks Anyway.

;)
#2  
lol, now you can close your own post.
United Kingdom
#3  
Except I think it needs someone else to have posted before he can close it as complete (unless it's changed since I last posted a question)... Free credit for Robot-Doc?:)
#5  
Thank You Both.

Got any ideas if I have voltages and everything looks good. The Regulators have been change and the bluetooth hooks up but no ports on cpu work.
#6  
Just a idea but have you tried heating up the solder on the other regulator just to make sure it has a good connection?
#7  
Yep! I change both regulators. They are putting out the right voltage. Regulated 7.2v coming in and 5v going out and also 3.3v after it is divided to that point. 5v on all middle leads and floating 1.5-2.1 on signal wires.
#8  
Try removing and then replacing the fuse between the two regulators. Then try re seating the MicroChip once more.

Thanks for the Freebie !
#9  
I realize you may have been recommended one or more of these already but just to cover the basics......My concern at this point assuming everything else was correct that resistors are burned or the chip itself overvolted. Now is a good time to test the resistance of the resistors with a multimeter. Please remove the chip before doing this. Pay attention to the direction of the chip when removed. If the resistors show resistance within tolerance 10% more or less then clean the pins of the chip from any debris and reseat the chip. Apply power , connect to ARC and use the digital IO panel and set each port on and test. I did this with leds before very simple.
User-inserted image


User-inserted image


You can use basic leds (except red those are low voltage) to test them , doing it this way is safer that trying to hold multimeter probes on pins and accidentally slipping and shorting something out.
#10  
Thanks for the Good Advice. I need to find an SR240 Scholttky Diode. I have replaced the diode with a regular one. It may not work. If that doesn't work and I can not find the cpu, I am sunk. Do you think it is possible to find that cpu that has no firmware in it and do the EZB firmware program and bring it up that way? Or is this a special chip that is proprietary enough for it not to work?

P.S. It is also bad that we cannot give credit to more than one person. Many times many people are helpful.
;)
#11  
In previous requests from other user DJ has said to use the "contact us" link to get replacement CPU, with the firmware. I think you need to get it from them because it needs their bootloader installed in order for the firmware updater to see it.

I have offered this to two other users who haven't taken me up on it. If you get to the point you just want to replace your EZ-B, I just ordered a V4 leaving me with a spare V3 board I don't need and would be willing to sell for what I paid for it plus shipping (which would be ~$5 for USPS delivery).

Contact me at alan@thetechguru.net if you get to that point.

Alan
#12  
You can check s diode with continuity setting on your meter. Measured one direction it will beep then the opposite it should not. If you get a connection in both directions your diode is bad.
#13  
OK, You guys have been SO Helpful! I used Josh's diode trick and it looks like I gave credit where it was due to Robo-Doc. I took the cpu out and reseated it back and BANG! I have all my ports back now. The EZB doesn't look exactly the same because I have replaced all the parts. But, She's-a-working. I was going into a depression with EZB withdrawals. I could NOT imagine not having an EZB until DEC. Of course I had my second EZB to work with. But, I need them both in my Sunshine computer. So, when I get my arms and my shoulders in and my package from Tony. I have one from Anthony and one from Tony. I will be all set. I'm-a-walkin' on cloud 9. Thank you Jesus! I should've remember this same thing happened to me in 1976 on an 8080A cpu. I drove 4 Hrs to Houston and back. When I got there, the Dealer told me I should've checked that first. I remembered this for a long time, but forgot it recently. It was a new and so fresh, It did not dawn on me that it could have this problem.

Thanks to Everyone!

:D:D:D
#14  
I thought you tried re-seating the CPU before and it worked for a while and then stopped.

My offer stands if it flakes out on you again.

Alan