Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by DJ Sures!

Android App Crashes In Servo Profile

After the last android app update, the app crashes whenever I select servo profile, on my Samsung GalaxyS5

AI Support Bot
Related Content
Synthiam
United Kingdom
#1  
There is a known bug, possibly caused by Google, that can cause the mobile app to crash on an Andriod upgrade which has something to do with apps that use a trackbar, such as Six and Roli. The link below outlines the problem that someone else had a short while back.

ARC mobile crashing after latest Galaxy S5 update

It's possible that removing the trackbar from the project might resolve the issue for now, so it might be worth a try.
#2  
Thanks for the suggestion, but I'm actually using the JD and JD no eyes apps. Both apps work fine with one exception, as soon as I press the servo Profile button the app closes.
PRO
Synthiam
#3  
What version of android are you using?
PRO
Synthiam
#5  
Okay, can you do a test - load the Six app and tell me if the main screen loads without errors? Do not load the servo config, only the main screen.

The huge challenge with android is the non-standard flavors of each manufacturer and device. We want people to have the ability to design their own apps and interfaces, which is a very powerful feature. However, because android is always different, there's so many exceptions in the code to support all flavors. There are many that we don't even hear about, such as this one.

One time I disliked developing for iOS because it was a pain to get developer approval. Now I'm disliking android for this reason :). The tables have turned!

iOS always works. Android, not so much...
PRO
Synthiam
#7  
Okay - I will see what I can do. I might need to give you a sample app to test with.

Can you elaborate on the steps taken to the error? I.e. Where are you selecting servo profile button from? What project file name is loaded? Etc. thanks! Any info will help.
#8  
I have gotten the same error using JD, JD no eyes and Six app. I can connect and control my JD robot with the app, including using the pose screen to control each servo. As soon as I press the servo profile button, from any screen I can find it on, the app closes and I get an error, saying "unfortunately ARC unexpectedly closed". It did work before I updated. Thank, for the support.
PRO
Synthiam
#9  
That's great feedback / thank you. I will connect as your user account and simulate the experience. Hopefully I receive the same error, which will make it easy to provide a fix. Stay tuned:)
#10  
The JD app, including the servo profile function works perfectly on my old HTC Thunderbolt running Android 4.0.4. I was able to use that phone to demo my JD robot at a local mini makerfaire last weekend.
PRO
Synthiam
#11  
Interesting... I'm still unable to identify a cause. Don't even know what I could change to begin to fix it for your device. It's still on my list though, maybe I will see a bug report resolve it soon from xamarin.
PRO
Synthiam
#12  
There is a new version of the android app - please try that one and let me know your result. Thanks
#13  
It no longer crashes, but I get an error saying I'm missing a .txt file. I checked the directory and found the folder referenced in the error, but there is only a config.xml file present. See attached photos for the error and the directory.
User-inserted image


User-inserted image
PRO
Synthiam
#14  
Delete that folder named -148738264

It would appear the storage on your device was corrupted and a file ended up missing.
United Kingdom
#17  
@DivideWorks.

Sorry I couldn't be of any more help, but I've been watching the progress with interest and glad it's all sorted. Looks like DJ saved the day here. Find another CEO who would take the time and act so fast to help solve an issue for someone. Really pleased to here your up and running now.
#18  
Ya @Steve, DJ has humbled me a few times also. Maybe that's why he's the creator of a product that is changing the world and the future master of the universe. :P