Asked — Edited
Resolved Resolved by DJ Sures!

ARC (Mobile) Crashing After Latest Galaxy S5 Update

Hello Roboticists,

This is my first post.

First, I am blown away by this platform. I feel grateful that DJ Sures had the vision to make this available and create some commercial products around it. I have EE background but am just an enthusiastic beginner here and have a lot of study ahead to begin to even scratch the surface of ARC scripting. Also, I have been browsing and I am extremely impressed by the knowledge and generosity of the participants on this forum. I know I've landed in the right place. A unique place, in terms of this platform and the community around it.

Getting to the point - I first purchased a Roli and have since purchased a Six and a developer's kit. Everyone is up and running, talking to the PC via my network.

I was able to get the Android application running great initially with the Roli ~1.5 weeks ago (in that case I recall the phone is directly connected to the Roli in AP mode).

Then I did a big update on my phone: Verizon Galaxy S5, now at Android version 5, Baseband version G900VVRU2B0E1 (this is actually a second update that I suspect fixes important bugs in the first version 5 update).

Now, when I attempt to download and install robot apps from the public cloud (like Roli and Six), the app downloads, saves, syncs servo profiles, then stops: "Unfortunately, ARC has stopped."

The same error occurs if I try to Open an installed robot app.

I tried clearing application cache, data, and then finally uninstalling and reinstalling ARC mobile. Same problem.

Has anyone seen this and might it just be an app compat issue with the latest Android?

Thanks for any ideas. Meanwhile I have plenty to keep me busy.

Best, Mike


Upgrade to ARC Pro

Unlock the true power of automation and robotics by becoming a proud subscriber of Synthiam ARC Pro.


This is a known issue and i was hoping Google would have it resolved by now with the latest update. My Note 4 is also suffering from the same problem - i'm sure they will have a solution soon. The issue is with the latest Android OS and the SeekBar (trackbar). I have an open ticket with them and hopefully we'll either receive word on a work around, or an OS patch.


Thank you, DJ. I'll just check again on the next S5 update. I verified that all is well on an iPad. Amusing myself with the Six mobile app. Confusing the cats. Congrats on this great platform! The possibilities are blowing my mind. ~Mike


Thank you for the compliments :). I will update this thread soon as I hear of a fix/solution. I've been actively focused on resolving it.


Are you willing to perform a test with your Android 5 device?

I have to make a decision - apparently google dropped backward compatibility between Android 5 and the currently supported 4.0.3


Sure, DJ, I'm happy to perform a test. Bring it on!


I would be happy to test as well. I have a Nexus 7 2013 with Android 5.1.1 and an HTC One M8 with 5.0.1 and ARC has started crashing on both of them. Not sure if it started with the latest update or earlier or maybe witb the latest Google Android System Web View which updated this week. A previous update of that component broke a lot of apps.



Alan, can you load the Six project on your device?


I also have a Nexus 7 with Android 5.1.1. I tried to downloa Six and it crashed, twice. I was, however able to download my own project from the cloud. I'm running the latest ARC.


Six is crashing right after install, and when I try to open after install on both devices. I sent crash reports. The Nexus 7 was after opening, the M8 was after installing.



I was also able to download JD and successfully install it and connect to and control My JD just fine. I connected to it as both of us being clients of my network.


Sorry, but I have to go, hope I was some help.


I can also load JD and Adventure bot. Six and Roli cause the crash.



The only apps that will crash are ones using the trackbar. Such as six.

This is obviously a move from Google to encourage older devices to upgrade.


Unfortunately, upgrades are (except for Nexus and Google Play Edition devices) at the discretion of the carrier. Most users can't choose to upgrade without buying a new device. :(



Interesting that the two crashing apps (Six and Roli) happen to be the only two that I tried (I've built both bots now). Sure enough, the JD app installs and starts just fine on my S5. I also did one or two crash reports, FWIW.


DJ, here's one more report for you. I have an older Samsung tablet: SCH-i705 running Android 4.1.2. I'm only using it as a Sonos controller these days. I tried ARC with the Roli, JD, and Six apps. It exhibits the exact same behavior as my S5, that is, JD does not crash but Roli and Six do.


@walunit See post #14. It is any project with the "trackbar" object in it that is crashing.



I saw that Alan, thanks. I thought that info on one more device with a different Android version might be helpful.



Gotcha... I wish my Xoom hadn't died. It was Android 4.03. Would have been interesting to see if it worked. I'll have to see if my Rezound still boots up. I think it was on 4.03 last update too.



Isn't there some way to eliminate the trackbar from the project? Or, at the least, substitute something else. Such as two buttons that increment a horizontal gauge type display. Or a series of dots the user runs their fingers over. Basically just not use the trackbar at all. Side step the problem altogether.