Welcome to Synthiam!

The easiest way to program the most powerful robots. Use technologies by leading industry experts. ARC is a free-to-use robot programming software that makes servo automation, computer vision, autonomous navigation, and artificial intelligence easy.

Get Started
Austria
Asked — Edited

ARC

Hi I'm from Germany also have a EZ - Board V3 +
and think it's really cool what you can do with it but unfortunately
I have a big problem connecting to EZ builder . So I connect my bluetooth give 1234 and it connects to the PC but when I select the EZ builder the correct port the smaller of the two
and click Connect comes an error see
Screenshot what am I doing wrong that can not be true , I try it already had days I'm very technically gifted eigendlich but that part will simply not connect other Bluetooth dongles have already try with the laptop it does not connect This message comes is the port that right ez - b flashes blue and red LED:


Attempting connection on COM50
Connection Failed: System.TimeoutException: Timeout bei Schreibvorgang ├╝berschritten.
bei System.IO.Ports.SerialStream.Write(Byte[] array, Int32 offset, Int32 count, Int32 timeout)
bei System.IO.Ports.SerialPort.Write(Byte[] buffer, Int32 offset, Int32 count)
bei EZ_B.EZB.Connect(String hostname, Int32 baudRate)
Disconnected



User-inserted image


User-inserted image


ARC Pro

Upgrade to ARC Pro

Unleash your creativity with the power of easy robot programming using Synthiam ARC Pro

#1  
Try both comm ports, and double check that the Bluetooth is actually connected. I have had it where the computer says it's connected and the ez-b is off.
#2  
It is typically the 2nd com port, not the first that works with the V3 (I don't know why).

Strange that your com port numbers are so high. If you don't have other ports, Windows should have given 2 and 3, not 50 and 51. I am not sure ARC can address a com port that high. You might want to see if Windows will let you renumber them if you can't connect to either.

Alan
Austria
#3  
EZ - B is on and flashing blue LED and red LED flashes
now I have switched it on COM 2 and COM 3 and bluetooth
Now I noticed it is paired but not connected to it , it will be wealthy entered the code 1234 and then coupled is close together and then just re- coupled and disconnected why he does not connect ?see the screenshot

User-inserted image


User-inserted image


User-inserted image


User-inserted image


User-inserted image


User-inserted image
PRO
Synthiam
#4  
1) Reseat bluetooth module? Maybe the plug is loose

2) Maybe damaged ez-b v3?
Austria
#5  
So this is something I 've never had the bluetooth can not connect unsolvable problem usually I get everything to run , I can not at all believe that I do not hammer out the problen it to solve itself !
Austria
#6  
how should I bluetooht reseten module ? There's the way it is ausgelieert have not changed anything had also with a multimeter as shown in the video pin 5 and 6
continuity checked everything ok
Austria
#7  
as bluetooth reseten ?
#8  
He means remove the bluetooth module and plug it back in. You just pull it straight up. It is taped to the EZ-B processor chip, but should come loose easily. Just pull straight up so you don't bend hte pins, then press straight down until fully seated.

Do this with it unplugged from power.

Then order yourself a V4. You will be much happier:)

Alan
Austria
#9  
So now have the original driver downloaded for bluetooth dongle and and there is software here with whom I have now a connection to the red LED lights get bluetooth down permanently but blue flashes Imer yet and whom I now going to connect com 2 comes back error message see screenshot

User-inserted image

User-inserted image
Austria
#11  
I can see here , there is no help or support for the V3 , I have noticed there is only support for the V4 who owns an old V3 lost . In ezrobot forum you will find nothing about V3 or bluetooth connection problems ! I do a lot with the PC in my home is all crosslinkable with TV satellite receiver Linux with custom firmware , have PS3 , mobile phones FLASHE an own server , encode different things on my car with NCS expert and so on. But the connection with the ARC I do not get out . That can not be that is it so complicated to connect the stupid software board with or has the software bugs and Problem solving correctly with the V3 but only with the V4 . The proposals were made ??here since I 'm already even come on it and have all been previously applied before I signed here unfortunately without success .
*mad* *mad* *mad* *mad* *mad*
#12  
The ez-b V3 is not supported by Ez-robot, but the forum still answers questions on them. Your problem is unlike anything I have seen before. It could very well be that you fried the processor chip somehow and it no longer communicates with the pc, or the bluetooth module is messed up.

As for your statement about the lack of bluetooth problem help, a quick search of the forum will reveal many threads on the issue that have been resolved. No they may not be on the first page, but there are many answered forum posts.

What I would do next is:

1. Reinstall ARC. First remove it, then install the latest version off the web using the complete install option.

2. Re-seat the bluetooth module if not already done. As well, make sure nothing is connected to the ez-b.

3. Delete the ez-robot device from your bluetooth and re-do the connection process.

Then we will look at what to do next.
Austria
#13  
1. I've done several times already some old versions ARC tried to install more software completely.

2. bluetooth module I have tested with multimeter as shown in the video pin 5 and pin 6 of the chip to the bluetooth module 0 ohms. have all pins examined by the bluetooth module to the motherboard connector on passage (contact) everything ok

3. I once made already 100 bluetooth dongel with another Usb


What struck me when I blutooth briefly connected with windows settings associate comes and then only coupled it does not remain connected at gekoppel. One can not only connect disconnect and re-connect and re not connected when I got to the ARC the com port select them to combine then press the blue LED lights up continuously and then the message is (see photos in the first post) and danch It Begins flashing again so there is kontact but it does not connect dauehaft.

Have win10 64bit it may perhaps be due? no matching driver for the bluetooth usb dongel ? does anyone know who is the manufacturer of usb bluetooth dongel ? Then I can maybe download and install manuel driver for win10 64bit *confused* *confused* *confused* *confused* *confused*
PRO
Synthiam
#15  
Have you tried updating the firmware?
Austria
#16  
not going no connection
User-inserted image
#17  
I would look into the driver. Take a look at the bluetooth dongles maker and see if you can find the right driver. if you have one that lists no manufacturer, then it likely will just use the Microsoft "Generic Bluetooth" driver. try running that driver in a compatibility mode, or if your not using it currently, try installing it instead of the in use one.

Also, reinstalling the bluetooth driver is an option.
PRO
Synthiam
#18  
Why did you use Com3 on the earlier screen shots and Com4 in the firmware update?

Did you try Com3 with firmware update?
Austria
#19  
But I have already tried both ports of com 4 is but for firmware update or ? I've already written as a different USB Bluetooth dongel used there but very high com ports are shown me . Can one tell me who is the manufacturer of this usb bluetooth dongel is there is the ez robot board found ? Then I could download the driver from the manufacturer website and install manually .

User-inserted image
#20  
Optimus I just want to clarify. You have in fact tried ALL com ports?

As for the dongle, it's a generic build. Search kns3620a2 Bluetooth to find all the available drivers. The generic Microsoft Bluetooth driver is the best.
Austria
#21  
I can not believe it's finally amazing I already I lost all hope have already want to give it it's here my screenshot

User-inserted image
Austria
#23  
now I 've been trying to connect this christmas I have been despair . I have not changed the same settings , the same driver , have only an older version ARC withdrawn . It is the only old version I own which is from 11.14.2015 . With it works without problems all goes 've staked out and re- inserted several times everything and is still doing everything . The firmware update for the ez board I have done it all without problems ! I still can not believe it 's finally there . It was up to the new ARC software !


Now I always get the message that I should make an ARC update have now naturally fear again get no connection with the new version ARC .
#24  
@Optimus Don't live in fear... buy an ezb4 and be happy:D
Austria
#25  
Thanks to all who have worked here and have tried to help me . I As written normal as not to get such big problems around something out but that was really bad .
Austria
#26  
What should I do with the ARC update ?
PRO
Synthiam
#27  
If it works - don't fix it:D
Austria
#28  
Have now make one last question I have looked in the projects folder from ARC there is a project from Robosapiens V1 for control over the PC . I found none of the Robosapiens V2 , as much as I know but Robosapiens V2 other IR codes or ? The project from the V1 can not do that ? Or is it ?
Austria
#29  
If it works - don't fix it Grin

Ha ha ha :-(
#30  
@Optimus If that were true then why do we drive cars instead of riding horses to work?:D Even worse, we could all be using arduinos today if @DJ decided not to make a better robot controller... *eek*
#31  
To answer your question about the robosepian v1 versus v2, wowee changes their codes much to often and so DJ stopped developing after V1.
Austria
#32  
yes but when Robosapiens v2 it would be worth the real in the project list aufzunehmen.Er offers many possibilities , it is twice as large robot has many sensors better cross arms and even a USB camera to detect colors of objects ir sensors and movements look really cool when liquid drain so the original joypad controls go , it is difficult and
gradually the movements are difficult to program joypad liquid with which he does something it would be but only ir codes that you must change project at V1 or not the ir codes I 've been to the internet


http://www.aibohack.com/robosap/ir_codes.htm
Austria
#34  
I would make the codes from Robosapiens V2 itself at ARC to insert it then instead of the Robosapiens V1 codes to use the ARC is complicated that ?
Austria
#35  
DJ Sures can the EZ - Builder somehow the IR codes of Robosapiens V1 with the IR code from V2 Robosapiens Replace the IR codes from V2 I . It ought to be possible to replace the V1 with the V2 ?
PRO
Synthiam
#36  
There are no plans to add the Wowwee robosapien toy to ezrobot platform.